17:06:33 <czajkowski> #startmeeting
17:06:33 <meetingology> Meeting started Thu Jul  5 17:06:33 2012 UTC.  The chair is czajkowski. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:06:33 <meetingology> 
17:06:33 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:06:44 <czajkowski> #link https://wiki.ubuntu.com/CommunityCouncilAgenda
17:06:47 <czajkowski> todays agenda
17:06:51 <czajkowski> welcome to the CC meeting
17:07:21 <czajkowski> so who is here from the DMB ?
17:07:28 <tumbleweed> !dmb-ping
17:07:29 <ubottu> bdrung, cody-somerville, Laney, micahg, barry, tumbleweed, stgraber: DMB ping
17:07:31 <tumbleweed> hi
17:07:39 <micahg> hi
17:07:47 * stgraber waves
17:07:53 <czajkowski> hey folks thanks for coming
17:08:20 <czajkowski> so in past meetings and in the last cycle we've invited boards to come along and just give us an inforaml update on how things are going, any issues and if we can help in any way
17:09:33 <czajkowski> so bdrung cody-somerville Laney micahg tumbleweed stgraber care to update us
17:11:24 <micahg> so, overall, think we're doing ok, I think we've only missed quorum twice in the last 6 months
17:11:44 <czajkowski> that's not bad at all.
17:12:35 <beuno> apologies for the stupid question, but meeting how often?
17:12:40 <tumbleweed> we limited the number of candidates per meeting, which also seems to have helped streamline things
17:12:44 <micahg> beuno: once a fortnight
17:12:58 <czajkowski> tumbleweed: oh nice idea. how does that work ?
17:13:28 <tumbleweed> 2 per meeting
17:13:29 * bdrung is back
17:13:40 <tumbleweed> our meetings used to run towards 2 hours each
17:14:05 <czajkowski> tumbleweed: so limit the number of applicants and increase meeting frequency has worked?
17:14:17 <tumbleweed> frequency has stayed the same
17:14:36 <tumbleweed> but we used to have people hanging around, hoping we'd get to them
17:14:45 <tumbleweed> now it's obvious before the meeting who is goin gto be processed
17:14:52 <cprofitt> is there a backlog of applicants?
17:15:09 <micahg> just DMB members at this point
17:15:22 <tumbleweed> we wish :(
17:15:34 <tumbleweed> applications are slowing
17:16:21 <beuno> tumbleweed, why do you think that's happening?
17:16:47 <tumbleweed> there haven't been many new contributors recently, that I've seen
17:17:22 <beuno> anything that can be done to improve that?  does it need improving?
17:18:23 <micahg> well, for a while it seemed like the MOTU community has stalled
17:18:38 <tumbleweed> fortunately, that's outside our control (as a board) so we should probably concentrate on other issues
17:18:47 <micahg> there were several sessions at UDS and I think we're hoping that the reinvigoration will lead to more applicants
17:19:21 <micahg> dholbach has been a great help in getting these things going again
17:19:56 <czajkowski> nods
17:20:10 <czajkowski> are there any areas we the CC can help in ?
17:21:00 <micahg> also, now that we have a smoother sponsorship process, as well as the number of contributors increasing, I'm hoping that in time we'll get more applicants
17:21:19 * ScottK thinks that over the long run things like PPAs and extras.ubuntu.com have reduced the incentive to get involved in the distro.
17:21:43 <micahg> ScottK: yeah, well, the ARB is good about redirecting when appropriate
17:22:04 <Laney> oops, this is now
17:22:05 <ScottK> Yes, but it'd have been 100% redirect before (effectively).
17:22:06 <Laney> hello :-)
17:22:21 <micahg> and as for PPAs, I wanted to start talking to people running specific PPAs to see if they're interested in distro work
17:22:31 <micahg> with backports being more active, that's a big help as well
17:23:39 <ScottK> I've asked in the past and the response has generally been something like "why should I bother - the PPA solves my problem."
17:23:44 <cprofitt> that sounds promising micahg and ScottK
17:23:49 <bdrung> PPAs helped me when I started contributing to Ubuntu.
17:24:39 <micahg> well, for the people doing stuff for themselves, you probably won't get traction, but for people trying to help others, they might be interested in reaching a larger audience, also with backports enabled by default in oneiric+, that's a big impetus to use backports vs PPAs
17:25:12 <ScottK> bdrung: I'm not saying PPAs aren't useful.  They are very much so, but they also have their costs.
17:25:23 <micahg> yeah, it should probably be the developer advisory board that follows up on the PPA people
17:25:24 <tumbleweed> I'm frequently amazed by the number of PPAs people use. There must be people there worth attracting
17:25:36 <bdrung> ScottK: Distro work requires sustainable contribution. PPA allow to just do one thing and then forget about it.
17:25:41 <cprofitt> I rarely use PPAs
17:25:42 <czajkowski> tumbleweed: indeed!
17:25:47 <czajkowski> so many people use them
17:26:05 <micahg> bdrung: well, no, people can do one off distro contributions as well if it suits their need
17:26:21 <micahg> upload rights require sustained contribution
17:26:45 <bdrung> blog post like http://www.omgubuntu.co.uk/2012/07/how-to-upgrade-to-the-latest-vlc-release-in-ubuntu-12-04 do not help
17:27:31 <micahg> right, well, I didn't see a backport request for vlc 2.0.2 :)
17:27:41 <bdrung> micahg: we are more interested in sustained contribution if someone wants to get a new package in the archive
17:28:07 <micahg> bdrung: sure, but I think a lot of PPAs are just the newest version of foo in the archiv
17:28:07 <bdrung> micahg: i want 2.0.2 in precise-security or -updates
17:28:29 <micahg> bdrung: that probably won't happen unless you go for an MRE (but that's for another discussion)
17:28:44 <bdrung> MRE?
17:28:51 <micahg> MicroRelease Exception
17:28:51 <ScottK> Micro Release Exception.
17:29:14 <joshuahoover> ralsina: any ideas on how to help a 11.10 user who is showing this in the syncdaemon log: ubuntuone.SyncDaemon.StorageClient - INFO - Connection lost, reason:  [Failure instance: Traceback (failure with no frames): <class  'OpenSSL.SSL.Error'>: [('SSL routines',  'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]
17:29:23 <micahg> so, back to the CC, we were wondering about the 6 month requirement for membership with regard to contributing developer
17:29:27 <czajkowski> so moving back to the DMB checkup, is there anything else you wish to say
17:29:30 <czajkowski> joshuahoover: wrong channel!
17:29:31 <micahg> joshuahoover: this is a meeting channel :)
17:29:50 <joshuahoover> czajkowski, micahg: sorry about that!
17:30:17 <czajkowski> micahg: do you want to increase or decrease it or what is the issue?
17:30:21 <ralsina> joshuahoover: dobey's symlink trick?
17:30:26 * beuno slaps ralsina
17:30:37 <ralsina> beuno: oops
17:30:44 <micahg> czajkowski: well, basically, is it a hard requirement or is it just a nice to have
17:30:50 <ScottK> micahg: Isn't that more of a guidelane than a rule?
17:30:59 <micahg> ScottK: that's what we're asking :)
17:31:24 <ScottK> (Speaking as a Kubuntu Council member who decides such stuff I've always thought it was a guideline)
17:31:25 <czajkowski> micahg: well has it helped or do you think your numbers would be higher if it were reduced or removed?
17:31:45 <micahg> czajkowski: to be honest, we haven't had many applicants going for that
17:32:23 <tumbleweed> ScottK: we do treat it as a guideline. But there are times when there is very little sustained contribution, but PPU still seems like a reasonable thing to grant
17:32:36 <czajkowski> micahg: can you elaborate ?
17:32:55 <cprofitt> where is the requirement for six months listed?
17:32:55 <micahg> czajkowski: we don't get a lot of applicants for dev membership without upload rights
17:33:02 <ScottK> tumbleweed: Personally I very uncomfortable with non-members being Ubuntu developers.
17:33:28 <ScottK> I also think significant and sustained are important parts of the requirement.
17:33:33 <micahg> ScottK: so, I take it you don't like the DM process?
17:33:59 <ScottK> micahg: I'd feel better if PPU weren't part of ubuntu-dev.
17:34:14 <tumbleweed> ScottK: which would make them not members
17:34:33 <micahg> cprofitt: on https://wiki.ubuntu.com/Membership, it says that it's rare for an application to be accepted with < 6 months of contributions
17:34:47 <ScottK> Right, don't make them members without significant and sustained contributions.
17:34:52 <micahg> ScottK: so would I :), that's the second point I wanted to bring up, but the DMB is still trying to find consensus on
17:35:22 <cprofitt> micahg: how long does it take to get upload rights?
17:35:36 <ScottK> I think having them not necessarily be ubuntu-dev/members makes PPU more like DM.
17:36:10 <micahg> cprofitt: that depends on the second point which I wanted to bring up of decoupling upload rights from membership
17:36:26 <cprofitt> micahg: I would think that getting several sponsored uploads would take a while... is it frequent that a person accomplishes this under six months?
17:36:40 <micahg> cprofitt: it can be done in a matter of weeks
17:36:52 <micahg> err..several sponsored uploads
17:37:07 <ScottK> If one is already a DD, it could (technically) be very fast.
17:37:07 <cprofitt> to be honest I am more concerned with sustained activity than anything
17:37:32 <tumbleweed> ScottK: in that case, granting membership is more straightforward, I think
17:37:33 <micahg> but upload rights require good working knowledge of what's being applied for, that can be either a short time or a long one depending on the person
17:37:44 <cprofitt> I think we want to avoid a person who is really excited about 'package x' gets several uploads done... goes for membership and then loses the momentum
17:38:07 <micahg> but generally, we want to see someone go through an entire dev cycle (6 months) to see how the freeze schedule works
17:38:13 <ScottK> tumbleweed: I disagree.  I think granting upload rights for packages they maintain is pretty straightforward.  I don't think that also means membership is straightforward.
17:38:23 <cprofitt> I agree there may be situations that merit things moving faster
17:39:34 <bdrung> ScottK: that's where decoupled upload rights and membership is a benefit
17:39:42 <ScottK> yes.
17:39:49 <ScottK> (for PPU)
17:40:21 <czajkowski> tumbleweed: micahg Laney is there anything you want to follow up post this meeting as we do seem to have gone off track here from the check up
17:40:26 <tumbleweed> ScottK: yes. It does depend on the situation. I also recall debian people who care about their packages in Ubuntu and fix the bugs in debian, so there are few uploads but clear development-related involvement in our community
17:40:29 <bdrung> the question is: are we allowed to grant PPU without membership?
17:40:34 <czajkowski> what needs to be followed up on and posisbly reviewed
17:41:02 <Laney> Sorry I forgot to pay attention as I was on the phone to the stupid gas company sorting out readings
17:41:15 * Laney grumbles
17:42:24 <ScottK> bdrung: I suspect that's a TB question, but I'm not sure.
17:42:31 <Laney> do we have a resolution?
17:42:35 <Laney> I think membership is a CC thing.
17:42:58 <Laney> I've come around to kind of liking the idea of decoupling it. People can apply for both simultaneously if they want.
17:43:10 <micahg> exactly
17:43:11 <beuno> so
17:43:19 <beuno> conceptually
17:43:24 <beuno> would we want casual contributors?
17:43:31 <Laney> want for what?
17:43:35 <bdrung> Laney: core-dev, MOTU should infer membership
17:43:38 <beuno> as a healthy project
17:43:41 <cprofitt> Laney: micahg: ScottK:
17:43:41 <micahg> bdrung: yes
17:43:44 <Laney> bdrung: yes
17:43:49 <tumbleweed> beuno: sustained casual contributors seem to be candidates fro membership
17:43:55 <tumbleweed> drive-by, not so much
17:43:56 <beuno> right
17:43:57 <micahg> beuno: of course, that's what the sponsorship process is for
17:44:02 <cprofitt> I think you folks should discuss this and arrange to meet with the CC again about this issue
17:44:15 <beuno> if they are sustained, then the qualify for membership
17:44:20 <Laney> I think you should tell us if we're allowed to decouple it in principle and then we don't need to come back
17:44:28 <micahg> +1
17:44:29 <cprofitt> I think you should formulate a desired outcome and plan to achieve it and then have the CC take a look at it
17:44:43 <cprofitt> there appears to be a great deal of depth in this topic
17:44:59 <tumbleweed> I think the plan is very straightforward: Make PPU not imply membership
17:45:02 <micahg> membership requires sustained contribution, upload rights require proficiency
17:45:13 <Laney> It would make it easier to let us grant people PPU
17:45:21 <beuno> but not sustained?
17:45:31 <tumbleweed> currently we evaluate the PPU rights, and the membership goes along for free. But we don't think that's fair on the other members who had to prove themselves
17:45:32 <Laney> just enough for us to be convinced that they know what they're doing
17:45:42 <micahg> beuno: not necessarily (Debian Developers are the easiest example)
17:46:17 <cprofitt> can we move to any other topics you have?
17:46:30 <micahg> those 2 were it AIUI
17:46:30 <beuno> so, lets pick this up again
17:46:35 <Laney> So what we'd do is remove ~ubuntumembers from ~ubuntu-dev
17:46:36 <beuno> schedule it
17:46:39 <Laney> err, the other way around
17:46:57 <beuno> I think it's absolutely worth discussing, if you guys feel it would help
17:47:01 <Laney> Or, think about whether these people should be in ubuntu-dev at all.
17:47:07 <beuno> just need to weigh in long-term effects a bit more
17:47:17 <micahg> Laney: well, it's a little more complicated than that
17:47:30 <Laney> Maybe /that/ is a question for the TB.
17:47:38 <czajkowski> beuno: perhaps email as our schedule is done for a few weeks
17:47:44 <tumbleweed> I don't know of any other pressing questions from our side
17:48:03 <beuno> sure, email works
17:48:10 <czajkowski> I think we should follow this up after the meeting via email to discuss this further
17:48:28 <czajkowski> #action beuno to start a thread with the DMB and CC to discuss the topics that have come from todays meeting
17:48:28 * meetingology beuno to start a thread with the DMB and CC to discuss the topics that have come from todays meeting
17:48:32 <czajkowski> :)
17:48:43 <beuno> look at that, I win a task!  :)
17:48:48 <beuno> well played
17:49:02 <czajkowski> hey I got landed with chairing I feel the need to share the love!
17:49:06 <czajkowski> right moving on
17:49:14 <czajkowski> #topic Juju Governance
17:49:19 <czajkowski> #link https://wiki.ubuntu.com/CommunityCouncilAgenda/talk
17:49:25 <czajkowski> jcastro: ping
17:49:31 <jcastro> hi
17:49:58 <czajkowski> really that link isn't helpful
17:50:20 <beuno> https://juju.ubuntu.com/CharmReviewBoard
17:50:21 <jcastro> sorry I didn't know how to link the header
17:50:39 <jcastro> it's the top paragraph but it's not really as important as the link beuno just posted
17:50:45 <czajkowski> #link  https://juju.ubuntu.com/CharmReviewBoard
17:51:27 <beuno> thanks btw, Laney, micahg, tumbleweed, ScottK  :)
17:52:14 <czajkowski> jcastro: so how did this idea come about
17:52:24 <czajkowski> and who would it be aimed at
17:52:48 <jcastro> right so the idea would basically be for juju to be like everything else in ubuntu
17:52:57 <jcastro> since the charm store is analogous to an archive
17:53:16 <jcastro> and has it's own policies and all that, then it would make sense to have it governed in the same way as ubuntu itself
17:53:31 <jcastro> we've basically been doing that the entire time
17:53:46 <jcastro> but there was no escalation process, nor a policy that was official or anything
17:53:56 <jcastro> it was just a bunch of us kind of self-governing ourselves.
17:54:14 <jcastro> which is fine when you're small, but at some point we needed to tighten things up and codify these things, hence this document
17:54:19 <beuno> +1 from me, really. Makes a lot of sense, it's well layed out.
17:54:33 <cprofitt> +1 from me as well... nice job to those who contributed
17:54:35 <jcastro> it's mostly a clone of the existing forums process
17:54:47 <jcastro> since I didn't want to be special, just another board. :)
17:55:13 <czajkowski> jcastro: so would members have to be Ubuntu members and or juju developers?
17:55:31 <jcastro> they would have to be ubuntu members
17:55:49 <jcastro> and in order to even review charms they need to be in the ~charmers group
17:56:14 <czajkowski> #link https://launchpad.net/~charmers
17:56:24 <beuno> which is different from a juju dev, yes>
17:56:25 <czajkowski> so there is atm 26 people and 4 pending
17:56:25 <beuno> ?
17:56:28 <jcastro> yes
17:56:34 <beuno> right, makes sense
17:56:36 <czajkowski> what's the difference as I'm unsure
17:56:37 <ScottK> I see charms have listed maintainers.  Is that a strong maintainer like in Debian or more like a primary point of contact?
17:56:53 <jcastro> primarily a POC right now
17:57:03 <jcastro> we're trying to make it more of a strong maintainership
17:57:10 <jcastro> but we didn't have maintainers when it started
17:57:20 <jcastro> so when it came down to "claim your charm!" a few people bailed
17:57:23 <ScottK> That's a bit different than we do in Ubuntu with package maintainership.
17:57:33 <cprofitt> so if I get this right... there would be Juju devs, Juju reviewers and the Juju Council?
17:58:01 <jcastro> it's a board
17:58:08 <jcastro> so there are juju core devs
17:58:15 <jcastro> who may or may not be ubuntu members
17:58:22 <jcastro> and then the ~charmers, which are reviewers
17:58:23 <cprofitt> so if I get this right... there would be Juju devs, Juju reviewers and the Juju Board... that is correct?
17:58:27 <micahg> I thought juju was bigger than Ubuntu, is this not the case?
17:58:30 <jcastro> and the review board would be made up of ~charmers
17:58:36 * cprofitt nods
17:58:56 <jcastro> micahg: what do you mean?
17:59:02 <micahg> jcastro: more encompassing
17:59:07 <jcastro> sure, it can be
17:59:15 <cprofitt> micahg: it is certainly bigger than Ubuntu, but there is also an Ubuntu part of it
17:59:31 <jcastro> but we still need a process for say, escalation, etc.
18:02:12 <beuno> sounds great to me
18:02:46 <cprofitt> me as well jcastro
18:02:55 <beuno> czajkowski?
18:03:13 <czajkowski> it's intersting that;s fore sure
18:03:21 <czajkowski> but there are only 3 of us here from the CC today
18:03:33 <czajkowski> so I think we should follow up on this with the others via email
18:04:00 <czajkowski> any other comments regarding the juju board?
18:04:05 <micahg> shouldn't the Ubuntu/non-Ubuntu things be clarified since wouldn't the CC only have authority over the Ubuntu part of the ecosystem
18:04:24 <czajkowski> micahg: yup thats one thing I want to clarify with the CC
18:04:32 <czajkowski> but ther are only 3/8 here atm
18:04:40 <czajkowski> sorry 3/7
18:05:01 <czajkowski> grr 8
18:05:16 <czajkowski> anything else folks?
18:05:21 <micahg> either way, no quorum :)
18:05:26 <czajkowski> micahg: bingo :)
18:06:00 <beuno> I'm tempted to not have meetings with no quorum
18:06:07 <beuno> but, the future
18:06:14 <beuno> is that a wrap up?
18:06:22 <czajkowski> yes
18:06:35 <czajkowski> #endmeeting