15:00:23 <skaet_> #startmeeting
15:00:23 <meetingology> Meeting started Fri Jun 15 15:00:23 2012 UTC.  The chair is skaet_. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00:23 <meetingology> 
15:00:23 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:00:25 <Laney> SHIP IT
15:00:37 <skaet_> lo
15:00:46 <skaet_> lol even.
15:01:01 <skaet_> Upcoming dates:
15:01:01 <skaet_> 2012/06/25 - Alpha 2 candidate images
15:01:01 <skaet_> 2012/06/28 - Alpha 2
15:01:01 <skaet_> 2012/07/05 - DebianImportFreeze
15:01:01 <skaet_> Work Items:
15:01:02 <skaet_> 2012/06/15 - 2627 : trending above burndown line.
15:01:25 <skaet_> Weekly Status:
15:01:26 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001354.html - brendand
15:01:26 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001359.html - ScottL
15:01:26 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001360.html - joshuahoover
15:01:26 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001361.html - gilir
15:01:26 <skaet_> ** 2100 UTC - due time
15:01:28 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001362.html - ogasawara
15:01:30 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001363.html - stgraber
15:01:32 <skaet_> ** 2300 UTC - late but could still prep from.
15:01:34 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001364.html - jdstrand
15:01:38 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001365.html - fabo
15:01:40 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001366.html - astrajava
15:01:42 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001367.html - seb128
15:01:44 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001368.html - Riddell
15:01:46 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001369.html - ogra_
15:01:48 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001370.html - jibel
15:01:50 <skaet_> https://lists.ubuntu.com/archives/ubuntu-release/2012-June/001375.html - arosales
15:02:18 <skaet_> Thank you to those teams who got the status in before 2100 UTC.  :)    It helps keep the meeting short, as more discussion can happen on email.
15:02:37 <skaet_> #topic Questions and Comments
15:02:52 <skaet_> Workitems are currently at 2627,  at FPF was 2282, so we had some teams that missed the freeze.  We're also starting to trend above burndown line - teams,  please review and update as needed.
15:02:52 <skaet_> Any teams want to request their workitem burndown trend lines reset?   otherwise will go with what was set on on FPF.
15:03:13 <jibel> QA
15:03:27 <skaet_> jibel,  will do.
15:03:29 <Riddell> what is FPF?
15:03:35 <skaet_> Feature Planning Freeze
15:03:42 <Daviey> skaet_: I suspect we'll want us adjusted next week.
15:04:08 <skaet_> Daviey,  will synch with you early next week then.
15:04:17 <ogasawara> skaet, I wouldn't mind seeing ours reset as well
15:04:20 <arosales> +1 Daviey on reset
15:04:34 <skaet_> ogasawara, arosales,  noted.
15:04:36 <skaet_> :)
15:04:46 <arosales> thanks skaet_
15:05:00 <seb128> skaet_, can you reset the desktop one as well?
15:05:14 <skaet_> seb128,  ok,  you're on the list for a reset too.
15:05:20 <seb128> thanks
15:05:32 <Daviey> skaet_: Hmm, maybe reset them all? :)
15:06:00 <skaet_> Daviey,  nah,  only those who are paying attention ;)
15:06:11 <stgraber> skaet_: looks like edubuntu would need a reset as well (was it actually reset after FPF, the graph suggests otherwise?)
15:06:19 <jdstrand> security's is fine
15:06:35 <seb128> jdstrand, you are not a team player! :p
15:06:37 <skaet_> stgraber,  ok,  edubuntu's on the list now as well.
15:06:46 <jdstrand> I'm trying, I promise! :)
15:06:47 * skaet_ hugs jdstrand
15:07:37 <skaet_> any one else who notices,  please chime in before meeting ends.
15:07:45 <skaet_> I'll head on to other questions now
15:07:46 <skaet_> ..
15:08:21 * skaet_ reminds folks to o/ if they want to get on the question queue
15:08:24 <skaet_> seb128 - mail list is inconclusive as to how we'll be handling the c++98 and c++0x/c++11 incompatibility.   what's the recommendation?
15:09:25 <skaet_> is there a plan to get this closed?  or do we need to have a meeting?
15:09:44 <seb128> skaet_, that would be a question for foundation,doko, that's a gcc,toolchain issue, I don't have good answers
15:10:04 <skaet_> ogra_, ^ cjwatson ^ ??
15:10:42 <cjwatson> I'm not up to date on this, sorry.  It's not a shallow issue.
15:10:47 <seb128> skaet_, Didier has been trying to discuss it with some other gcc upstream people and they acknowledge some issues that they might fix in 4.7.2 ... but they don't have any fixed schedule for that and it's not really sorted out
15:11:12 <cjwatson> I'm not entirely sure how a meeting would help, though ...
15:11:17 <skaet_> seb128,  is there evidence its impacting more than unity?  (ie.  dependency on c++11 features?)
15:11:24 <seb128> skaet_, yes
15:11:49 <seb128> skaet_, other softwares using c++11 features have been mentioned in that discussion
15:12:35 <skaet_> seb128,  ok,  will fine tooth that thread a little closer then.    didn't have as much time on it as would be good this morning.
15:13:19 <skaet_> cjwatson,  if right folk are talking, and there's no cross team discussions about workarounds needed, then meeting may not be appropriate.   Just couldn't tell from thread.
15:13:23 <seb128> skaet_, the utouch stack was listed as well as potentially problematic on that thread and I think somebody mentioned something else but I don't find it now
15:13:53 <cjwatson> What I mean is that the level of thought required is unlikely to be assisted by a meeting.
15:14:14 <Daviey> I am also not as close to this issue as i'd like.. but is this something that would manifest itself when packages are rebuilt ?
15:14:15 <skaet_> ok,  Will move this back to the thread for now then.
15:14:27 <ogra_> sorry, i'm late
15:14:50 <seb128> Daviey, yes, it's not happening until you rebuild with gcc-4.7
15:14:57 <Daviey> Ie, is it that our toolchain has changed this cycle, and might negatively affect packages which havne't been built this cycle.. particularly risky with SRU's
15:15:14 * skaet_ nods
15:15:22 <seb128> Daviey, the issue is specific to q so it shouldn't impact SRUs
15:15:33 <Daviey> seb128: i mean Q SRU's.
15:15:43 <Daviey> ie, we don't catch it pre-release.
15:15:45 <seb128> right
15:16:21 * skaet_ wondering if a transition plan is going to be needed then...
15:16:34 <Daviey> perhaps no-change rebuilds soon might help flush this out?
15:16:52 <Daviey> is doko present ?
15:17:19 <skaet_> worth discussing with doko,  definitely.    He doesn't seem to be around right now.
15:17:21 * ogra_ will carry it forward to him if he isnt
15:17:27 <Daviey> super
15:17:42 <seb128> Daviey, upstream is discussing bumping the soname today: http://gcc.gnu.org/ml/gcc/2012-06/msg00223.html
15:17:46 <ubottu> gcc.gnu.org bug 2012 in c "ICE when compiling the current cvs gcc as cross-compiler to mingw32" [Critical,Resolved: duplicate]
15:17:52 <seb128> Daviey, so I guess we need to see what that goes
15:17:59 <seb128> what->where
15:18:56 <Daviey> sounds good.
15:18:58 <skaet_> I think we've got some actions on this topic now,  so moving on.
15:18:59 <skaet_> ..
15:19:01 <doko> see http://gcc.gnu.org/ml/gcc/2012-06/msg00201.html
15:19:07 <ubottu> gcc.gnu.org bug 2012 in c "ICE when compiling the current cvs gcc as cross-compiler to mingw32" [Critical,Resolved: duplicate]
15:19:40 <doko> soname bump won't happen
15:20:14 <skaet_> doko,  thanks for joining.
15:20:43 <doko> it's a major pita ...
15:21:13 <skaet_> doko,  does it make sense to prioritize doing a no-change rebuild, so we can get the scope of this figured out?
15:21:41 <doko> skaet_, what for?
15:22:02 <skaet_> how much upstream c++11 use there is...
15:22:22 <skaet_> scope of problem
15:22:23 <Daviey> doko: Sorry, that was my suggestion.. And i admit i don't fully grok the issue at hand.  But i wondered if building this not yet built against 4.7 will help identify problematic packages
15:22:37 <doko> right, it would be nice if somebody could analyze the build logs for c++11/c++0x usage
15:22:51 <Daviey> doko: is there an easy metric in buildlogs?
15:23:01 <doko> Daviey, it's only in c++11 mode,
15:23:35 <Daviey> doko: You are far more experienced in this than anyone.. So really.. What do you suggest as a path forward?
15:23:58 <doko> you should search for -std={c,gnu}++{0x,11}
15:24:32 <doko> Daviey, well, first find out which packages are involved. that would be searching the build logs
15:25:08 <Daviey> I have a script that pulls down build logs for a given package.. If that is of use, i'll certainly help.
15:25:21 <doko> then, if library packages do export symbols from the stl, and especiall std::list symbols
15:26:10 <doko> but skaet_, Daviey: the real issue is here mixing c++98/c++11 code, which we should avoid anyway
15:27:13 <doko> the recent change for c++11 mode broke things evidently, but there were more issues in earlier gcc versions
15:27:35 <doko> but I don't want to delay the meeting now
15:27:39 <skaet_> yup.  ABI changes happen when standards change, so shouldn't be mixed.   Challenge is managing the transition, and libraries.
15:27:59 <skaet_> ok lets take this to the other channels.
15:28:00 <skaet_> ..
15:28:07 <doko> and we don't want a second stack of c++ libs ...
15:28:37 <skaet_> seb128, From A1 discussions, Ubuntu DVD isn't going to be part of manifest,  any objections to turning it off in the dailies, and removing from the iso tracker.
15:28:43 <skaet_> ?
15:28:47 <seb128> skaet_, +1
15:29:01 <seb128> i.e: do it, no objection
15:29:08 <skaet_> :)
15:29:26 <skaet_> #action remove Ubuntu DVD from daily images and ISO tracker for quantal.
15:29:26 * meetingology remove Ubuntu DVD from daily images and ISO tracker for quantal.
15:29:42 <skaet_> thanks seb128
15:29:48 <seb128> yw ;-)
15:30:07 <skaet_> seb128,   is it known which images we'll be putting out for 12.04.1?
15:30:22 <Riddell> skaet_: Kubuntu dvd can go too
15:30:29 <skaet_> (ie, sometimes we do DVD and sometimes not,  just wondering about it for that manifest as well).
15:30:41 <skaet_> thanks Riddell,  was going to ask you next.  :)
15:30:56 <skaet_> Riddell,  just to be clear,  no Kubuntu DVD for 12.10?
15:31:01 <Riddell> skaet_: right
15:31:22 <skaet_> #ACTION: remove Kubuntu DVD from daily images and ISO tracker for quantal.
15:31:22 * meetingology : remove Kubuntu DVD from daily images and ISO tracker for quantal.
15:31:36 <seb128> skaet_, good question, I'm not sure, I assuming we would ship the same set as for 12.04 for 12.04.1 but I need to check
15:31:47 <seb128> assuming->assumed
15:32:20 <seb128> skaet_, I will not get a reply for you before the end of the meeting but it's on my list, I will get back to you about that ;-)
15:32:43 <skaet_> seb128,  ok,  will you take an action to summarize on ubuntu-release what you want for 12.04.1 for next week?  :)
15:33:13 <seb128> #ACTION: summarize on ubuntu-release what desktop want for 12.04.1
15:33:13 * meetingology : summarize on ubuntu-release what desktop want for 12.04.1
15:33:20 <skaet_> Riddell,  will you follow up with the images you want for Kubuntu for 12.04.1 as well?
15:33:23 <seb128> skaet_, ^
15:33:32 <skaet_> thanks seb128  :)
15:33:37 <seb128> yw ;-)
15:33:44 <Riddell> skaet_: ok
15:34:12 <skaet_> ..
15:34:50 <Daviey> o/
15:34:55 <skaet_> go Daviey
15:35:04 <Daviey> seb128: Are you currently working on bug 1008537 ?
15:35:05 <ubottu> Launchpad bug 1008537 in webkit (Ubuntu) "[FTBFS] Segmentation fault during tests" [Undecided,Confirmed] https://launchpad.net/bugs/1008537
15:35:21 <Daviey> (it's impacting us aswell)
15:35:39 <seb128> Daviey, no, it's the first time I read about it, looking
15:36:13 <seb128> Daviey, is that a precise or quantal or both issue?
15:36:34 <Daviey> seb128: quantal... michag mentioned that it was hitting firefox builds?
15:36:54 <seb128> Daviey, that seems a xvfb issue, I know that others mentioned that as well before
15:37:12 <Daviey> yeah
15:37:56 <seb128> Daviey, I will check out with some people, but probably an out of meeting topic
15:38:13 <Daviey> seb128: sure, thanks.
15:38:19 <Daviey> ...
15:38:19 <seb128> thank you for pointing it
15:38:22 <seb128> ..
15:39:06 <skaet_> superm1, Anyone looking into the Mythbuntu failures?  does it make sense to keep it in the dailies?
15:39:35 <skaet_> hmm... superm1 isn't around, so anyone else know about plans with this image set?
15:40:05 <Daviey> skaet_: II'm on that team, but not been able to commit any time this week.  I will either make time, or coordinate a plan
15:40:20 <skaet_> Thanks Daviey.
15:40:30 <skaet_> ..
15:40:48 <skaet_> anyone else have questions?
15:41:27 <skaet_> Thanks seb128, arosales, Daviey, cjwatson, ogra_, doko, ogasawara, jibel, stgraber, jdstrand, roadmr, brendand, Laney
15:41:30 <skaet_> #endmeeting