16:01:44 <roaksoax> #startmeeting
16:01:44 <meetingology> Meeting started Tue May 29 16:01:44 2012 UTC.  The chair is roaksoax. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01:44 <meetingology> 
16:01:44 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01:48 <Daviey> hey-ol-a
16:02:10 <roaksoax> so let's get started
16:02:15 <roaksoax> [TOPIC] Review ACTION points from previous meeting
16:02:16 <utlemming> o/
16:02:32 <roaksoax> zul talk to arosales and jamespage offline about SRU tracker
16:02:41 <zul> in progress
16:02:41 <roaksoax> zul: any updates about the SRU tracker?
16:02:45 <arosales> roaksoax: I am syncing up with zul and jamespage
16:02:55 <arosales> deciding on which tool to use
16:03:05 <arosales> zul or possibly Ursinha's
16:03:10 <arosales> so in progress
16:03:16 <roaksoax> arosales: awesome!
16:03:24 <jamespage> o/
16:03:25 <Ursinha> we're talking about it tomorrow :)
16:03:34 <roaksoax> [ACTION] zul to sync up with arosales and jamespage.
16:03:34 * meetingology zul to sync up with arosales and jamespage.
16:03:45 <roaksoax> zul: zul to also pull Ursinha into SRU tracker talks --> I'm guessing that's stillk in progress too
16:03:54 <arosales> roaksoax: correct :-)
16:04:07 <zul> yay
16:04:09 <roaksoax> alright, let'/s move on
16:04:11 <roaksoax> email arosales/Daviey if interested in ubuntu-mir membership
16:04:34 <roaksoax> who's displayed their interes in becoming part of the ubuntu-mir team?
16:04:54 <roaksoax> or should the question be, have all the interested people emailed arosales and/or Daviey ?
16:04:54 <arosales> I am also sync'ing up with Ursinha on blueprint management (ie tracking blueprint changes)
16:05:08 <hallyn> ruh roh
16:05:35 <arosales> I didn't receive any mails on interest for ubuntu-mir team
16:05:46 <Daviey> me neider
16:05:59 <roaksoax> alright, so people I believe you have a chance to offer yourselves and become part of the ubuntu-mir team
16:06:17 <Daviey> lets defer it again.
16:06:17 <roaksoax> moving on
16:06:24 <arosales> roaksoax: can we give it one additional week for follow up and then close on it next week?
16:06:34 <roaksoax> arosales: sure!
16:06:37 <arosales> thanks
16:06:47 <roaksoax> [ACTION] email arosales/Daviey if interested in ubuntu-mir membership
16:06:47 * meetingology email arosales/Daviey if interested in ubuntu-mir membership
16:06:58 <roaksoax> alright, moving on
16:07:01 <roaksoax> [TOPIC] Quantal Development
16:07:08 <roaksoax> Release Bugs - http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:07:28 <roaksoax> bug #888123
16:07:30 <ubottu> Launchpad bug 888123 in openjdk-7 (Ubuntu Quantal) "erlang version 14.b.2-dfsg-3ubuntu2 failed to build with openjdk-7" [High,Confirmed] https://launchpad.net/bugs/888123
16:07:47 <roaksoax> jamespage: any updates?
16:08:00 <jamespage> nope
16:08:15 <jamespage> work on the underlying issue is on hold ATM
16:08:25 <roaksoax> ok
16:08:29 <roaksoax> bug 974584
16:08:29 <jamespage> not mega urgent at this point in time unless someone wants to merge erlang
16:08:31 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged] https://launchpad.net/bugs/974584
16:08:44 <hallyn> working with debian maintainer
16:09:07 <roaksoax> awesome!
16:09:23 <roaksoax> bug #920197
16:09:25 <ubottu> Launchpad bug 920197 in python-webob (Ubuntu Quantal) "[SRU] webob last stable version 1.1.1 response header bug" [High,Triaged] https://launchpad.net/bugs/920197
16:09:37 <roaksoax> zul: any updates?
16:09:54 <zul> roaksoax: pending SRU team
16:10:16 <roaksoax> awesome!
16:10:23 <roaksoax> bug #1001846
16:10:25 <ubottu> Launchpad bug 1001846 in cobbler (Ubuntu) "cobbler fails to install with error code 1" [High,Confirmed] https://launchpad.net/bugs/1001846
16:10:48 <roaksoax> we were waiting for more input, and we got it. It should be taken care of this week
16:10:54 <Daviey> \o/
16:11:02 <roaksoax> bug #880339
16:11:03 <ubottu> Launchpad bug 880339 in mysql-5.5 (Ubuntu Precise) "AppArmor profile needs update" [Medium,Incomplete] https://launchpad.net/bugs/880339
16:11:33 <roaksoax> still incomplete
16:11:47 <roaksoax> comments point to a might be related bug
16:12:19 <roaksoax> bug #993291
16:12:21 <ubottu> Launchpad bug 993291 in nis (Ubuntu Quantal) "[SRU] package nis 3.17-32ubuntu1.2 failed to install/upgrade: invoke-rc.d: unknown initscript, /etc/init.d/nis not found." [Medium,Triaged] https://launchpad.net/bugs/993291
16:13:01 <roaksoax> jamespage: any updates ^^?
16:13:09 <jamespage> yeah - I need to take a look at that still
16:13:13 <jamespage> so no
16:13:20 <roaksoax> alright!
16:13:23 <roaksoax> so let's move on to blueprints
16:13:33 <roaksoax> Blueprints - http://status.ubuntu.com/ubuntu-precise/ubuntu-server.html
16:13:58 <arosales> how are folks doing with getting work items documented?
16:14:07 * rbasak hasn't started yet :-/
16:14:10 <rbasak> It's on my todo list
16:14:20 * m_3 too
16:14:31 <arosales> The release team would like to start setting topics and tread lines by tomorrow
16:14:32 <roaksoax> we also need to update the above link as they quantal BP's are not yet listed
16:14:39 <Daviey> So.. Started going through the ones with myself as approver... and they are taking good shape.
16:14:46 <Daviey> Still needs a little more detail on some.
16:14:47 <smoser> that url above should probably have been http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:14:55 <hallyn> Daviey: note the user-ns and device-ns ones are not yet approved
16:14:57 <roaksoax> ah daa
16:14:59 <hallyn> (I marked them 'Review')
16:15:01 * roaksoax dumbd
16:15:02 <arosales> The list I am looking at for q for server
16:15:03 <arosales> https://blueprints.launchpad.net/~ubuntu-server/+specs?role=drafter
16:15:39 <arosales> at least for blueprints we need to get work items on, prioritize, and approve for work this cycle
16:15:43 <Daviey> The links i supplied in last weeks meeting are probably of use.
16:16:01 <roaksoax> ok, so all of us should finish writing our BP's, make sure the WI are docmented so that they can get approved and we can start working on them
16:16:04 <Daviey> http://ubuntuserver.wordpress.com/2012/05/23/server-team-20120522-meeting-minutes/
16:16:08 <Daviey> Read Quantal Development
16:16:54 <roaksoax> Specs currently under consideration are at https://blueprints.launchpad.net/~ubuntu-server/+specs?role=drafter. If a spec is missing, let Daviey know.
16:17:10 <roaksoax> Blueprints which $user is responsible for driving to Approved state can be found at https://blueprints.launchpad.net/~$user/+specs?searchtext=servercloud-q&role=assignee. Please set those which require review to Review state.
16:17:22 <arosales> So is EOD wednesday too soon to have the blueprints ready for approval?
16:17:43 <roaksoax> Yes from my part
16:17:51 <roaksoax> s/part/side
16:17:52 <m_3> yes
16:17:55 <Daviey> Hmm
16:17:58 <rbasak> Daviey: can we please get the typo fixed on ubuntuserver.wordpress.com? It's embarrassing. I don't want to be associated with that site!
16:18:25 <Daviey> rbasak: Do you want to drive it's migration to ubuntuserver.org, canonical hosted?
16:18:30 <Daviey> [ACTION] ^
16:18:30 * meetingology ^
16:18:49 <roaksoax> [ACTION] rbasak to drive migration to ubuntuserver.org
16:18:49 * meetingology rbasak to drive migration to ubuntuserver.org
16:18:53 <roaksoax> thank you rbasak :)
16:18:58 <Daviey> thanks rbasak
16:19:04 <Daviey> So.. Lets re-cap of the process...
16:19:15 <arosales> Thursday an better for folks completing blueprint work item documentation?
16:19:22 <Daviey> When you think your spec is ready for review, please mark them 'Review'
16:20:07 <Daviey> arosales & myself with significant help from jamespage and smoser will either give feedback, or Approve
16:20:44 <Daviey> So.. We can start that ASAP.. so please get your blueprints into a state where you can mark them Review ASAP, and we can start getting them rolled out
16:20:48 <Daviey> Sound good?
16:21:42 <roaksoax> [ACTION] To finish BP documentation and mark them Review
16:21:42 * meetingology To finish BP documentation and mark them Review
16:22:05 <Daviey> (ASAP :)
16:22:10 <roaksoax> so I guess the silence means all of us agree
16:22:14 <roaksoax> [ACTION] To finish BP documentation and mark them Review ASAP!
16:22:14 * meetingology To finish BP documentation and mark them Review ASAP!
16:22:15 <zul> suuuure :)
16:22:20 <jamespage> +1
16:22:25 <roaksoax> ok, let's move on
16:22:30 <arosales> it would be nice for trend line setting, and tracking if we could have the bulk of work item documentation this competed by this week :-)
16:22:49 <roaksoax> indeed!
16:23:00 <roaksoax> alright, so we also have merges to take care of
16:23:10 <roaksoax> [LINK] http://people.canonical.com/~davewalker/delta.html
16:23:25 <roaksoax> LINK: http://people.canonical.com/~davewalker/delta.html
16:23:48 <roaksoax> please take care of your merges, so go wild and have fun
16:24:03 <roaksoax> anyone else has anything to discuss?
16:24:05 <Daviey> Please feel free to open sync/merge bugs to track assignment. :)
16:24:09 <Daviey> ^ optional
16:24:46 <roaksoax> ok, so there doesn't seem to be anything else. Let's move on then
16:24:55 <roaksoax> [TOPIC] Ubuntu Server Team Events
16:25:10 <roaksoax> any event where we will be particupating that's coming soon?
16:26:24 <roaksoax> I guess there isn't
16:26:38 <roaksoax> moving on
16:26:40 <roaksoax> [TOPIC] Weekly Updates & Questions for the QA Team (hggdh)
16:26:42 <roaksoax> hggdh: o/
16:27:27 <roaksoax> uhmm it seems that hggdh is not around, so let;s come back t him later
16:27:40 <roaksoax> [TOPIC] Weekly Updates & Questions for the Kernel Team (smb)
16:27:44 <roaksoax> smb: o/
16:27:49 <smb> yessir! :)
16:27:53 <smb> Beside of other pieces here and there, a quick test on the libvirt merge and most time spent on trying to reproduce bug 999755 without having a simple test case. This was unsuccessful but since someone posted exactly what was their reproducer I could confirm this to be no problem restricted to VMs. So now I can try out some variations locally.
16:27:54 <ubottu> Launchpad bug 999755 in linux (Ubuntu) "Kernel crash in rb_next doing ohai loops" [Medium,Confirmed] https://launchpad.net/bugs/999755
16:27:57 <smb> ..
16:28:45 <roaksoax> awesome
16:28:54 <roaksoax> smb: anything else you'd like us to be aware of?
16:29:15 <Daviey> smb: Anything on the xen front?
16:29:18 <smb> smoser, and utlemming are already away of -virtual going away
16:29:29 <Daviey> going away?
16:29:30 <smb> away -> aware
16:29:36 <Daviey> Where is this documented ?
16:29:47 <rbasak> It was mentioned at UDS IIRC
16:30:01 <smb> Should be somewhere in the uds flavours track
16:30:16 <smoser> we were aware.
16:30:20 <Daviey> That should probably be documented somewhere more expressive
16:30:20 <smoser> but that didn't stop it from breaking things./
16:30:37 <smoser> smb spoke to me about it.
16:30:57 <smb> Daviey, where would such a place be?
16:31:07 <Daviey> smoser: so it's your fault i didn't know?  noted. :)
16:31:08 <utlemming> On our side, it is being tracked as Bug #1005551
16:31:10 <ubottu> Launchpad bug 1005551 in cloud-init (Ubuntu) "Quantal does not boot on EC2" [Critical,Confirmed] https://launchpad.net/bugs/1005551
16:31:18 <Daviey> smb: probably -server ML
16:31:31 <smoser> well, probably -devel actually.
16:31:37 <smoser> its not just -server
16:31:39 <rbasak> https://blueprints.launchpad.net/ubuntu/+spec/hardware-q-kernel-version-and-flavors
16:31:58 <smb> OK, I can check and send out a specific "warning" about that
16:32:02 <utlemming> I'm working on cleaning up the fallout for the build process, but it will require packaing changes and build process changes.
16:32:23 <Daviey> smb: thanks!
16:32:41 <Daviey> utlemming: if it's significant, better track it on a blueprint :)
16:33:22 <utlemming> Daviey: ack
16:33:45 <roaksoax> alright, should that be all, let's move on
16:34:31 <roaksoax> [TOPIC] Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:34:33 <roaksoax> rbasak: o/
16:34:34 <rbasak> Nothing to report, although you may be interested in some ARM server news: http://www.theregister.co.uk/2012/05/29/dell_copper_arm_server/ . Any questions for me?
16:35:22 <roaksoax> i guess there's not
16:35:23 <zul> copper is shiney
16:36:12 <roaksoax> anotherone hgere : http://www.marketwatch.com/story/dell-unveils-programs-to-enable-the-arm-based-server-ecosystem-and-accelerate-development-and-testing-of-arm-based-applications-and-solutions-2012-05-29
16:36:40 <roaksoax> ok, so moving on
16:36:43 <roaksoax> [TOPIC] Open Discussion
16:36:58 <roaksoax> anyone has anything for us?
16:37:06 <smoser> i've got one
16:37:14 <roaksoax> I just want to publicly congratulate smoser :)
16:37:17 <smoser> rbasak, and i would like to solicit bids for https://bugs.launchpad.net/ubuntu/+source/apt/+bug/972077
16:37:19 <ubottu> Launchpad bug 972077 in apt (Ubuntu) "apt repository disk format has race conditions" [Medium,Confirmed]
16:37:25 <Daviey> Yeah... So.
16:37:29 <smoser> by solicit bids, i mean "any one interested in doing this ?"
16:37:36 <zul> lol
16:37:43 <Daviey> Smoser has been declared the Infrastructure team Tech Lead.  Three cheers for smoser
16:37:46 <Daviey> o/
16:37:50 <zul> yay!
16:37:52 <jamespage> \o/
16:37:53 <roaksoax> \o/
16:37:58 <smb> \o/
16:37:58 <Ursinha> :D
16:37:59 <jamespage> congrats smoer
16:37:59 <smoser> rbasak, is interested, but is time limited, and if someone else wants to take a whack at it, we have an idea of a proof of concept that we'd like to implement
16:38:02 <lynxman> \o/
16:38:02 <jamespage> or even smoser
16:38:03 <Daviey> Now.. Any hard questions related to Infra, please feel free to tax smoser.
16:38:04 <Ursinha> congrats smoser
16:38:05 <arosales> congrats smoser
16:38:06 <lynxman> smoser: you're da man
16:38:07 <utlemming> all praise to smoser!
16:38:07 <m_3> *\o/*
16:38:10 <roaksoax> congrats Mr. Moser
16:38:10 <smoser> (yes, thanks for the congrats, NOW BACK TO THE MEETING!)
16:38:11 <smoser> :)
16:38:15 <Ursinha> lol
16:38:16 <SpamapS> hody
16:38:19 <SpamapS> howdy even
16:38:21 <roaksoax> smoser: Open Discussion :)
16:38:25 <Daviey> SpamapS: just in time.
16:38:37 <zul> congrats captain oh my captain...my sparkle in my eye
16:38:40 <rbasak> congrats smoser!
16:38:46 <smoser> so, if anyone would want to take a look at implementing the apt client side of our proposed fix, please feel free to ping me.
16:39:18 <jamespage> o/
16:39:21 <roaksoax> [ACTION]: Anyone interested in taking care of bug #972077 to ping smoser
16:39:21 * meetingology : Anyone interested in taking care of bug #972077 to ping smoser
16:39:22 <ubottu> Launchpad bug 972077 in apt (Ubuntu) "apt repository disk format has race conditions" [Medium,Confirmed] https://launchpad.net/bugs/972077
16:39:39 <jamespage> Bug Triage Process - I sent an email to ubuntu-server last week
16:39:46 <roaksoax> alright, no other subject to bring to the table?
16:39:51 <jamespage> please could people have a read and provide feedback - thanks
16:40:07 <rbasak> I think I need to follow the process that jamespage has documented and then make a note of any bugs I get stuck on and why
16:40:19 <jamespage> rbasak, that is a fine way to debug it!
16:40:57 <rbasak> jamespage: deubg? You want me to file bugs on the triage process? And how should we triage those bugs?
16:41:06 <rbasak> :-)
16:41:09 <jamespage> lol
16:41:21 <roaksoax> lol
16:41:36 <roaksoax> alright, if there's nothing more
16:41:39 <roaksoax> I guess we can end this
16:41:42 <roaksoax> [TOPIC] Announce next meeting date and time
16:41:48 <roaksoax> same time/place
16:41:59 <roaksoax> (June 5th)
16:42:02 <roaksoax> thank you all
16:42:05 <roaksoax> #endmeeting