16:01:31 <dholbach> #startmeeting
16:01:31 <meetingology> Meeting started Thu May 24 16:01:31 2012 UTC.  The chair is dholbach. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01:31 <meetingology> 
16:01:31 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02:01 <dholbach> this is the first MOTU meeting in a long while, so please bring up whatever you want to discuss, even if it's not yet on https://wiki.ubuntu.com/MOTU/Meetings
16:02:20 <dholbach> #topic meeting times
16:02:41 <dholbach> when we discussed this at UDS, the proposal was 2nd & 4th Thursday, 16 UTC
16:03:01 <dholbach> back then we already realised that this might be bad for some
16:03:18 <ajmitch> bad for a few :)
16:03:37 <highvoltage> it's right over lunch time EST, but I can live with it.
16:03:54 <dholbach> ajmitch, isn't it insane o clock where you are? :)
16:03:55 <micahg> highvoltage: it's the middle of the night for ajmitch
16:04:07 <broder> oh, o/ btw :)
16:04:12 <ajmitch> 4AM
16:04:12 <broder> looking at the wrong window
16:04:24 <dholbach> geser dug out the meeting times of the last MOTU meetings and it seems we alternated between 4:00 UTC, 12:00 UTC and 20:00 UTC
16:05:11 <dholbach> and AFAIK the new RMB teams will meet at 10 and 20 UTC to try to cover most of the world
16:05:27 <dholbach> any strong feelings about either of the possibilities? :)
16:05:34 * ajmitch is still of the opinion that rotating meeting times is only useful if you'll have enough people show up
16:05:54 <pleia2> dholbach: 12 and 22
16:06:08 <dholbach> thanks pleia2 - I was close, wasn't I? :)
16:06:11 <pleia2> :)
16:06:45 <dholbach> we could trial one of the solution for a couple of months
16:07:12 <dholbach> any strong feelings or should we move this to the mailing list?
16:07:31 <vibhav> o/
16:07:37 <asomething> to the list!
16:07:54 <dholbach> alrightie
16:07:59 <porthose> o/
16:08:00 <dholbach> #action dholbach to mail list about meetings times
16:08:00 * meetingology dholbach to mail list about meetings times
16:08:03 <dholbach> moving on
16:08:13 <dholbach> #topic MOTU School (Bhavani Shankar)
16:08:38 <dholbach> it's unfortunate that Bhavani can't make the meeting, but he wanted us to briefly talk about MOTU school and ideas for this cycle
16:09:10 <dholbach> I think there was a work item in the blueprint as well
16:09:16 <dholbach> does anyone still have it in front of them?
16:09:45 <tumbleweed> can't see a workitem https://blueprints.launchpad.net/ubuntu/+spec/other-q-motu-bof
16:09:59 <highvoltage> bhavani is in UTC+6 right?
16:10:04 <dholbach> I think the idea was to have a couple of training sessions throughout the cycle
16:10:17 <dholbach> highvoltage, UTC+5h30m I think
16:10:30 <vibhav> highvoltage: UTC+0530
16:11:19 <dholbach> ok, I can't find the action right now, but I think it was Bhavani (and others)  who wanted to have some training sessions this cycle, not as often as weekly, but every now and then
16:11:34 <dholbach> to provide an entry point for new contributors
16:11:49 <asomething> I think we could probably swing a few sessions, I just don't want to start promising regular sessions again and then fail
16:11:50 <ajmitch> it's a nice idea, as long as someone's willing to run them
16:12:24 <dholbach> maybe we could discuss a few ideas and collect a list of people who won't volunteer, but at least want to be involved in the discussions?
16:12:36 <tumbleweed> if it is only one or two sessions, that should be easier to staff, than a week-long UDW
16:13:09 <dholbach> yes, it should be a lot easier, if we would for example do a Q&A session or a "demo a bug fix" session
16:13:14 <dholbach> which doesn't huge amounts of preparation
16:13:20 <dholbach> ... require ...
16:13:44 <dholbach> do we have any reasonably new contributors here with some requests for training sessions?
16:13:51 <vibhav> me
16:14:24 <dholbach> vibhav, what would you like to see discussed in one of those sessions?
16:15:12 <vibhav> The debian/rules file
16:15:17 <highvoltage> maybe I'm going a bit off-cource, but it might be nice to have some kind of a list of people who'd like to attend beginners training, and every time there's 5 or so people in that list a session is scheduled. when there's small groups of enthusiastic people then google hangouts might be nice for that too. (and as I'm typing that I'm already dreading all the problems that come with google hangouts)
16:15:29 <vibhav> It took me some time to understand it :)
16:15:38 <dholbach> highvoltage, nice idea
16:16:03 <dholbach> vibhav, yes - sounds good
16:16:13 <dholbach> asomething, maybe we can even steal some of the content for the packaging guide :-)
16:16:52 <dholbach> highvoltage, I'd really like to get semi-regular hangouts going - as an experiment this cycle
16:17:01 <asomething> sure, there's also stuff that's been done before that we can update: https://wiki.ubuntu.com/Packaging/Training/Logs
16:17:14 <dholbach> ah yes, that might serve as a great basis
16:17:21 <highvoltage> dholbach: nice :)
16:17:24 <dholbach> it really doesn't hurt to repeat topics
16:17:47 <dholbach> everytime at UOW or UDW there's new folks who listen to the same "get started" sessions :)
16:18:10 <dholbach> ok, that sounds like a good start for Bhavani and others :)
16:18:25 <dholbach> everyone OK, if I mail Bhavani and CC the lot of you? :)
16:19:04 <dholbach> ok :)
16:19:04 <dholbach> #action mail Bhavani with info about MOTU School discussions, CC everyone who showed interest in the topic
16:19:04 * meetingology mail Bhavani with info about MOTU School discussions, CC everyone who showed interest in the topic
16:19:09 <ajmitch> sure
16:19:24 <dholbach> #topic review https://wiki.ubuntu.com/MOTU/FAQ/New_Draft (Bhavani Shankar)
16:19:39 <dholbach> Bhavani updated the MOTU FAQ and wanted us to have a look at it
16:20:00 <vibhav> That FAq is a bit short
16:20:01 <dholbach> I think it'd be good if we all quickly went through it and commented in here, so he can review the log later on
16:20:24 <tumbleweed> there are definitly language issues to sort out (I almost sat down and edited it, but wanted to chat to him first)
16:20:28 <dholbach> vibhav: if you have some questions you feel should be answered, feel free to ask them in here
16:20:44 <dholbach> ... so they can be addressed
16:20:58 <vibhav> I dont have any questions till now
16:21:24 <dholbach> for "What prerequisites do I need to start off ubuntu development?" I think I could borrow some text from the packaging guide
16:21:27 <highvoltage> it would be nice if it had a bunch of packaging related questions and answers.
16:21:38 <tumbleweed> It may be worth leaving in a question on mentoring that maakes it clear that there isn't any, just use #ubuntu-motu
16:21:41 <vibhav> "Is MOTU Rocket Science?"
16:22:03 <dholbach> tumbleweed: good point :)
16:22:10 <highvoltage> does motu get a lot of questions about what ubuntu is? if that's the case then perhaps that page should also link to a more generic ubuntu FAQ first
16:22:35 <tumbleweed> highvoltage: that also occured to me
16:22:52 <tumbleweed> we do get lots of questions from new users asking what programming languages they need to know, that could probably be better addressed in the FAQ
16:23:00 <dholbach> yep
16:23:10 <highvoltage> tumbleweed: *nod*
16:23:20 <dholbach> it sounds like we can very easily fix a couple of things in there, and also merge the missing old content from https://wiki.ubuntu.com/MOTU/FAQ
16:23:35 <vibhav> A question like: Do I need to know any programming languages for MOTU?
16:23:40 <dholbach> yes
16:24:07 <dholbach> I think if we all take just a couple of minutes after meeting we should be able to sort most of this out very easily
16:24:26 <vibhav> dholbach: I thought it was no, one can contribute to MOTU by only bringing upstream changes to Ubuntu or backporting fixes
16:24:53 <dholbach> vibhav: can you elaborate? I'm not quite sure I understand
16:25:41 <dholbach> bringing upstream fixes in and backporting them is definitely a good way to contribute - not the only one, but definitely a good one
16:26:06 <asomething> vibhav, I think dholbach was saying "yes, we need that question in the FAQ" not answering it yes
16:26:12 <highvoltage> it would be nice if we could link to my "where's the right place to submit my fix!?" flowchart once it exists :)
16:26:39 <vibhav> dholbach: Sure, For example: https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/873784 , Fixing it in Ubuntu only requires one to copy the changes from upstream and preapre a debdiff
16:26:41 <ubottu> Launchpad bug 873784 in accountsservice (Ubuntu) "reload_passwd uses fgetpwent rather than getpwent, ignoring /etc/nsswitch.conf" [Undecided,Confirmed]
16:26:48 <vibhav> hush you stuipid bot
16:26:54 <dholbach> yes, that's definitely a good way to contribute
16:27:16 <vibhav> SO, Apparently, You dont need to know any programming language
16:27:42 <vibhav> Just a knowledge of the debian build toolchain :)
16:27:46 <dholbach> it helps, but there are tasks where you don't need to know much yet and where you can learn as you go :)
16:28:09 <dholbach> alrightie, we should probably just all take a look at it later on - I'm sure Bhavani will appreciate it
16:28:13 <dholbach> shall we move on?
16:28:17 <vibhav> sure
16:28:30 <dholbach> #topic Update from Developer Advisory Team
16:28:38 <highvoltage> in many cases it's more important to know the policies around the languages, like python or perl or ruby each have their own additional policies and tricks in addition to the usual packaging things
16:29:15 <micahg> PHP, R, haskell...
16:29:40 <dholbach> highvoltage, yep - I'm sure we can phrase it in a general and reassuring way still :)
16:29:51 <dholbach> asomething, broder, huats: did any of you prepare anything update-wise? :)
16:30:03 <ajmitch> micahg: dont forget C#
16:30:08 <highvoltage> heh, I didn't even realise that that could sounds scary
16:30:10 <broder> nope, i haven't had time to do anything :-/
16:30:10 <broder> sorry
16:30:38 <asomething> dholbach, I didn't get around to much DAT wise in the past week
16:30:39 <dholbach> the only thing I have from the advisory team is: in the last 3-4 weeks we had 5 people joining ~ubuntu-dev which is great :)
16:30:53 <dholbach> and also we have the first very new people contributing to quantal
16:31:14 <dholbach> although I expect more new folks getting involved in fixing their pet bug in precise still
16:31:33 <dholbach> asomething, broder: I didn't get much done either - more in the next week :)
16:31:48 <dholbach> any questions for the advisory team people?
16:31:55 <geser> what is the Developer Advisory Team? hearing it the first time
16:32:06 <dholbach> oh ok
16:32:17 <ajmitch> top-secret cabal
16:32:30 <vibhav> http://daniel.holba.ch/blog/tag/developer-advisory-team/
16:32:44 <dholbach> forgive me, if I quote from the wiki page
16:32:46 <dholbach> This team in terms of UbuntuDevelopment, tries to fulfill the following tasks in the Ubuntu world:
16:32:46 <dholbach> Reach out to new contributors, thank them for their work and get feedback.
16:32:46 <dholbach> Reach out to people who might be ready to apply for upload rights and help them.
16:32:46 <dholbach> Reach out to contributors that went inactive and get feedback from them and offer help.
16:33:09 <vibhav> A seperate channel dedicated for new contributors run the the DAT for questions might help
16:33:32 <dholbach> the idea of it was to close some of the gaps in process by social means - currently on the team are asomething, huats, broder, bhavi, warp10 and myself
16:33:54 <dholbach> the team has been in place since some time in the last cycle
16:33:56 <vibhav> Does the DAT have a facebook page or something
16:34:15 <ajmitch> -motu itself is quiet enough, I don't think a separate channel is necessarily a good idea
16:34:21 <asomething> dholbach, is your lightning talk about DAT from UDS online?
16:34:29 <dholbach> and a report of the outreach to new contributors has largely been put together by asomething here: http://people.ubuntu.com/~andrewsomething/dat/
16:34:45 <vibhav> Or the Ubuntu Developer Page on G+ could congratulate people who have got their first fixes into Ubuntu
16:34:49 <dholbach> asomething, I don't know
16:35:19 <dholbach> vibhav: up until now the DAT has mostly been reaching out to new contributors on a personal level - we never wanted it to become a mentoring team
16:35:31 <vibhav> ah
16:35:37 <dholbach> we felt that #ubuntu-motu or the motu mailing list were much better candidates to answer all kinds of questions
16:35:58 <dholbach> geser, does that sort of answer your question?
16:36:05 <geser> yes
16:36:23 <dholbach> ok cool
16:36:41 <dholbach> any more questions?
16:37:00 <dholbach> ok, moving on then :)
16:37:13 <dholbach> #topic Review https://wiki.ubuntu.com/UbuntuDevelopment/BugFixingInitiative (dholbach)
16:37:54 <broder> hey guys - need to run early. don't give me too many actions ;)
16:38:15 <dholbach> another thing we discussed at UDS was to have regular bug fixing initiatives during the cycle and to use some of the time of the MOTU meetings to review the list and announce if afterwards, so new contributors have some predictably easy tasks to get started with
16:38:27 <ajmitch> broder: that's just asking for it..
16:38:34 <highvoltage> that's like fixit fridays right?
16:38:36 <dholbach> #action broder to update https://wiki.ubuntu.com/UbuntuDevelopment/BugFixingInitiative with new thoughts and clever ideas
16:38:36 * meetingology broder to update https://wiki.ubuntu.com/UbuntuDevelopment/BugFixingInitiative with new thoughts and clever ideas
16:38:38 <dholbach> thanks broder
16:38:43 <vibhav> What about a sponser-it-$DAY ?
16:39:06 <ajmitch> highvoltage: right, but getting the list together of things to work on beforehand
16:39:18 <dholbach> highvoltage, yes, but we'd keep the list up until the next motu meeting - so more like a "fix it week" or "fix it 14 days" :)
16:39:28 <highvoltage> heh, ok
16:39:36 <dholbach> vibhav: I would hope that the patch pilots would handle that
16:39:36 <tumbleweed> highvoltage: also deals with all the newbies coming into the channel saying "what can I help with"
16:39:48 <vibhav> ah fine
16:40:09 <dholbach> so does the page look generally alright to you? anything we should change or add?
16:40:43 <ajmitch> it's a good start for the week, we don't want to overload people with 500 things to fix
16:40:46 <dholbach> the speling-errors-in-description are just for ubuntu packages, so we should be able to more easily get them in
16:41:04 <dholbach> ajmitch, any other tasks we should be featuring? (maybe for intermediate contributors)
16:41:20 <micahg> dholbach: security CVE fixes :)
16:41:25 <vibhav> dholbach: backporting fixes?
16:41:34 <dholbach> vibhav: like which? from which list?
16:41:39 <ajmitch> the perennial favourites of the rc bugs list which I'll rewrite any day now(tm)
16:41:45 <dholbach> micahg, if we can curate a list of a few which should be reasonably easy - that'd be awesome
16:41:54 <micahg> dholbach: https://wiki.ubuntu.com/SecurityTeam/HighlightedPackages
16:42:08 * micahg isn't sure if they're easy though
16:42:11 <ajmitch> security fixes is a good one
16:42:19 <vibhav> dholbach: I dont know any lists though, but we could create a list for backporting fixes
16:42:20 <ajmitch> they don't have to be easy
16:42:29 <dholbach> micahg, awesome - just to be sure we could pack it into the "experienced contributors" section
16:42:55 <dholbach> vibhav: the problem with curating lists of easy tasks is that it's easier if you have a list you can pick them off
16:43:36 <dholbach> micahg, would you be fine with those bugs being on the UbuntuDevelopment/BugFixingInitiative page?
16:43:48 <vibhav> Eg: A bug reported from 1.04 is fixed in an SRU in 11.10; There could a list for "SRUs missing from the Ubuntu version they have reported"
16:44:01 <micahg> dholbach: sure, though the list changes every week, so you might just want to link to the page
16:44:22 <dholbach> micahg, nice
16:44:40 <asomething> I liked the idea of teaching about patch systems by finding a few good patches from: https://bugs.launchpad.net/ubuntu/+bugs?field.subscriber=ubuntu-reviewers&field.tag=patch
16:44:56 <asomething> I can take an action item to add a handful to the wiki page
16:45:02 <dholbach> awesome
16:45:19 <dholbach> #action asomething to review https://bugs.launchpad.net/ubuntu/+bugs?field.subscriber=ubuntu-reviewers&field.tag=patch and add a few to the bug fixing page
16:45:19 * meetingology asomething to review https://bugs.launchpad.net/ubuntu/+bugs?field.subscriber=ubuntu-reviewers&field.tag=patch and add a few to the bug fixing page
16:45:40 <vibhav> But that would require some help from Launchpad too :)
16:45:53 <dholbach> I also added the lists you mentioned to https://wiki.ubuntu.com/UbuntuDevelopment/BugFixingInitiative/Organisation so it will be easier next time to pick tasks :)
16:46:15 <micahg> well, over half the archive should be source format 3.0 by now
16:46:31 <dholbach> ok, I think that should have us set up to announce our first bugfixing initiative early next week - what do you think?
16:46:48 <ajmitch> sounds good
16:46:55 <asomething> +1
16:46:55 <dholbach> awesome
16:46:57 <vibhav> dholbach: A list for fixing easy lintian errors
16:47:21 <vibhav> Like "Outdated Standards Version"
16:47:36 <vibhav> changing the source format to 3.0
16:47:43 <vibhav> ... etc
16:47:49 <dholbach> the issue with many of them is that these changes would better be done in Debian
16:47:54 <highvoltage> well... sometimes those are better to fix in debian
16:48:09 <dholbach> so we can sync the changes and not keep a delta just for a string change which almost has no impact
16:48:09 <vibhav> I almost forgot that
16:48:23 <dholbach> vibhav: but if you can think of something really easy for new contributors, feel free to add it to https://wiki.ubuntu.com/UbuntuDevelopment/BugFixingInitiative/Organisation
16:48:31 <vibhav> sure
16:48:43 <dholbach> thanks
16:48:51 <dholbach> #topic any other business
16:48:59 * dholbach reloads agenda page
16:49:18 <dholbach> no, nothing new on there -- does anyone have anything they'd like to talk about?
16:49:29 <vibhav> let me think
16:50:00 <vibhav> Could the packaging guide be translated?
16:50:06 <asomething> yes!
16:50:10 <dholbach> ha, great you're asking!
16:50:14 <vibhav> (Though it sounds silly)
16:50:18 <dholbach> https://translations.launchpad.net/ubuntu-packaging-guide/
16:50:31 <micahg> dholbach: well, maybe towards the end of the cycle, helping Debian reduce their RC bug count once they're frozen
16:50:31 <vibhav> Oh wait, it can be
16:50:47 <dholbach> and the translations updates will automatically flow into trunk
16:51:06 <ajmitch> micahg: that should be sometime next month, probably worth doing that after feature freeze
16:51:19 <dholbach> we are currently figuring out how we can deliver these changes in Ubuntu (separate packages for separate languages, etc.) and to figure out how complete we want translations to be before we ship them
16:51:31 <dholbach> https://bugs.launchpad.net/ubuntu-packaging-guide/+bug/961936 has more of this discussions
16:51:32 <ubottu> Launchpad bug 961936 in Ubuntu Packaging Guide "Only ship translations which accomplish a certain level of completion" [High,Triaged]
16:51:38 <dholbach> micahg, yes, totally
16:51:44 <vibhav> dholbach: I agree
16:52:16 <dholbach> micahg, on the bug fixing initiative page we have some instructions for how to submit fixes to debian for packages which are not ubuntu-only
16:52:41 <dholbach> in the future we might want to collaborate with the debian-derivatives to pick a few targets we want to advertise
16:52:43 <micahg> dholbach: yes, but I'm talking about gleaning the Debian RC bug list that's unfixed and submitting patches
16:52:45 <vibhav> dholbach: Lintian error for Ubuntu-only packages
16:53:05 <micahg> then we can sync the fixes to Ubuntu
16:53:05 <dholbach> micahg, yep, exactly
16:53:44 <dholbach> sounds great to me - would you like to start doing that now already or in one of the next bug fixing initiatives?
16:53:53 <ajmitch> micahg: I've got some work items about the reverse RC bugs page, where we've fixed something in ubuntu
16:53:57 <micahg> gah, I forgot to do my work item of writing the criteria for dropping universe packages not in Debian
16:54:36 <dholbach> micahg, ^? :)
16:55:13 <vibhav> "check for packages that are worth removing from the next release"
16:55:30 <micahg> dholbach: I think later in the cycle is fine (once Debian is frozen and that RC bug list is the release criteria)
16:55:45 <dholbach> vibhav: yes, that's an action in here: https://blueprints.launchpad.net/ubuntu/+spec/other-q-motu-bof :)
16:55:48 <vibhav> dholbach: I think  https://bugs.launchpad.net/ubuntu-packaging-guide/+bug/961936 should be for all packages in the Ubuntu Archive
16:55:49 <ubottu> Launchpad bug 961936 in Ubuntu Packaging Guide "Only ship translations which accomplish a certain level of completion" [High,Triaged]
16:55:50 <ajmitch> micahg: run wild with that chainsaw, please :)
16:55:56 <dholbach> micahg, ok, great - I'll keep you in mind for that :-)
16:56:28 <dholbach> vibhav: maybe it'd be a good topic to discuss in #ubuntu-translators
16:56:34 <dholbach> is there any other business?
16:57:23 <dholbach> #action dholbach to update minutes and wiki page
16:57:23 * meetingology dholbach to update minutes and wiki page
16:57:28 <dholbach> do we want to pick a chair for next time?
16:57:30 <micahg> dholbach: here's a handy link foe the Debian bug initiative: http://upsilon.cc/~zack/hacking/debian/rcbw/
16:58:14 <dholbach> micahg, thanks, noted on the ..../Organisation page
16:58:26 <tumbleweed> yeah, we can't make you chair them all :)
16:58:47 <asomething> dholbach, not if we don't know what time next time is
16:58:48 <ajmitch> broder volunteered, didn't he? :)
16:58:54 <dholbach> especially if we should decide in the meantime that all meetings are going to happen at 4 my time :-P
16:58:58 <dholbach> ajmitch, haha
16:59:02 <dholbach> asomething, yes :)
16:59:15 <dholbach> ok, let's leave it open until next time, then - I'm sure we'll find somebody
16:59:19 <dholbach> but I'll add it as a standing agenda item
16:59:24 <dholbach> thanks a lot everyone
16:59:26 <vibhav> There should be an FAQ on how does one apply to be a maintainer for an orphaned package
16:59:29 <dholbach> this was an awesome MOTU meeting
16:59:30 <ajmitch> thanks
16:59:40 * dholbach hugs you all
16:59:44 <dholbach> #endmeeting