16:01:01 <s3h> #startmeeting
16:01:01 <meetingology> Meeting started Tue May 22 16:01:01 2012 UTC.  The chair is s3h. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01:01 <meetingology> 
16:01:01 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01:39 <s3h> #TOPIC Review ACTION points from previous
16:02:12 <s3h> sigh, bad lag
16:02:16 <s3h> jamespage to send out an email to ubuntu-server about the new template
16:02:28 <jamespage> done
16:02:38 <s3h> sweet
16:02:49 <s3h> daviey update release bugs for quantal
16:03:21 <s3h> Daviey: ^
16:03:38 * utlemming has a conflict
16:04:01 <Daviey> hye
16:04:03 <Daviey> Hey
16:04:06 <Daviey> The spec's which are currently under consideration are:
16:04:06 <Daviey> https://blueprints.launchpad.net/~ubuntu-server/+specs?role=drafter
16:04:06 <Daviey> If there is a spec you are watching that is not on this list, please make it known.
16:04:08 <zul> heeeeeylo
16:04:09 <Daviey> The Spec's that people are responsible for driving to Approved state are, for example:
16:04:12 <Daviey> https://blueprints.launchpad.net/~james-page/+specs?searchtext=servercloud-q&role=assignee
16:04:15 <Daviey> Note, that 'Assignee' actually means the person responsible for driving the WI *specifications* (and getting the blueprint Approved).. *NOT* necessarily doing the tasks. :)
16:04:18 <Daviey> I went through them earlier today, and most are in a pretty good state.  However, please can those that require review (to be Approved), please be set to 'Review' state please.
16:04:30 <Daviey> Any questions about Spec state?
16:04:31 <roaksoax> o/
16:04:37 <s3h> LINK https://blueprints.launchpad.net/~james-page/+specs?searchtext=servercloud-q&role=assignee
16:04:55 <Daviey> ^^ obv, switch out james-page for $launchpad-id
16:04:57 <s3h> #LINK https://blueprints.launchpad.net/~james-page/+specs?searchtext=servercloud-q&role=assignee
16:05:12 <s3h> thanks Daviey
16:05:17 <s3h> zul
16:05:27 <zul> hmm?
16:05:31 <s3h> zul talk to arosales and jamespage offline about SRU tracker
16:05:35 <zul> havent done yet
16:05:37 <arosales> jamespage:  did zul sync up with you?  If not, I'll need to catch up with zul.
16:05:44 <arosales> ah ok
16:05:53 <arosales> I'll catch up with you later zul
16:05:59 <zul> oh no!
16:06:04 <s3h> (null)
16:06:10 <roaksoax> zul: you can't run.. your knee :P
16:06:11 <Daviey> Regarding Development for Quantal... Are people frantically working on Merges?
16:06:19 <zul> knee is fine :P
16:06:33 <lynxman> o/ (sorry for the tardiness)
16:06:34 <SpamapS> Are we not using the bot?
16:06:35 <roaksoax> i started working on merges yesterday
16:06:37 <s3h> zul: arosales: carry that over?
16:06:48 <rbasak> I'm frantically working on the critical path for ARM server and MAAS. I regret I haven't managed to look at blueprints since UDS. And not done any merges :-/
16:06:50 <Daviey> I have a report here, showing the delta with *sid*/*unstable*... NOT the default parent series of wheezy/testing:
16:06:52 <zul> s3h: yep
16:06:53 <Daviey> http://people.canonical.com/~davewalker/delta.html
16:07:05 <s3h> #ACTION zul talk to arosales and jamespage offline about SRU tracker
16:07:05 * meetingology zul talk to arosales and jamespage offline about SRU tracker
16:07:18 <s3h> ok NOW carrying on :)
16:07:24 <s3h> #TOPIC Quantal Development
16:07:25 <rbasak> I'd still like to do some merges though if there are any that can wait a couple of weeks. I have an apache2 one in a local branch pending testing.
16:07:32 <roaksoax> Daviey: so we should me merging from wheezy?
16:07:36 <Ursinha> can I be involved in the SRU tracker discussion, please?
16:07:51 <zul> Ursinha: yes since you took over it basically
16:07:53 <Ursinha> :)
16:08:01 <Daviey> roaksoax: no, but see if there are hits we should be merging.
16:08:08 <Ursinha> lol, thanks zul
16:08:22 <SpamapS> rbasak: apache2 should be 2.4, right?
16:08:28 <s3h> #ACTION zul to also pull Ursinha into SRU tracker talks
16:08:28 * meetingology zul to also pull Ursinha into SRU tracker talks
16:08:31 * rbasak looks
16:08:49 <SpamapS> wait no
16:08:54 <SpamapS> 2.4 is stil in Debian experimental
16:09:00 <SpamapS> looks like squeeze will ship w/ 2.2
16:09:07 <SpamapS> (which sucks)
16:09:12 <SpamapS> But, timing. ;)
16:09:12 <rbasak> I just have a 2.2.22-5ubuntu1 prepared, to fix a specific bug
16:09:21 <rbasak> quantal is on 2.2.22-1ubuntu1
16:09:24 <SpamapS> rbasak: yeah stick with that
16:09:30 <SpamapS> we don't want to do the transition before Debian :)
16:09:34 <rbasak> :-)
16:09:40 * SpamapS has learned how painful that can be w/ MySQL 5.5
16:10:25 <s3h> (null)
16:10:59 <s3h> SpamapS: do you mind driving release bugs?
16:11:05 <zul> SpamapS:  hah hah :)
16:11:28 <SpamapS> eh, uh.. sure.. let me just find that link
16:11:40 <s3h> SpamapS: http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:11:49 <Daviey> ^^ I updated it to Quantal the other day.
16:12:00 <Daviey> Still, not very populated.. but that is expected at this point in the cycle.
16:12:01 <SpamapS> bug 888123
16:12:02 <ubottu> Launchpad bug 888123 in openjdk-7 (Ubuntu Quantal) "erlang version 14.b.2-dfsg-3ubuntu2 failed to build with openjdk-7" [High,Confirmed] https://launchpad.net/bugs/888123
16:12:18 <SpamapS> jamespage: ^
16:12:35 <SpamapS> bug 930916
16:12:36 <jamespage> on it - waiting for doko to reappear to check my openjdk-7 fix (its a scary package)
16:12:37 <ubottu> Launchpad bug 930916 in amavisd-new (Ubuntu) "amavis start-stop script fails to stop amavisd" [High,Confirmed] https://launchpad.net/bugs/930916
16:12:59 <SpamapS> The bug I keep procrastinating on. Will try to get some time for it later this week. Busy w/ juju SRU to precise today.
16:13:03 <jamespage> SpamapS, is that SRU worthy?
16:13:09 <SpamapS> Yes
16:13:16 <SpamapS> it was in precise's release bugs too :-P
16:13:16 <jamespage> I could pick it up if that would help
16:13:28 <SpamapS> jamespage: sure. take it. :) Its a very simple fix.
16:13:35 <jamespage> SpamapS, ack
16:13:37 <SpamapS> bug 974584
16:13:39 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged] https://launchpad.net/bugs/974584
16:13:54 <s3h> I'm waiting to see if someone speaks up there, else I'll aks for the patch to be sponsored tomorrow
16:14:03 <SpamapS> woot
16:14:18 <SpamapS> bug 1001846
16:14:19 <ubottu> Launchpad bug 1001846 in cobbler (Ubuntu) "cobbler fails to install with error code 1" [High,New] https://launchpad.net/bugs/1001846
16:15:13 <roaksoax> so that seems to be a corner case and I've requested for more information even though the proposed fix makes sense
16:15:26 <SpamapS> bug 880339
16:15:27 <ubottu> Launchpad bug 880339 in mysql-5.5 (Ubuntu Precise) "AppArmor profile needs update" [Medium,Incomplete] https://launchpad.net/bugs/880339
16:15:39 <SpamapS> I believe that one is well understood and is actually a bug in dh_apparmor
16:16:18 <SpamapS> In some cases, /etc/apparmor.d/local/usr.sbin.mysqld is removed because of the transfer of ownership from 5.1 -> 5.5
16:16:35 <SpamapS> Have a patch, just need to apply it (got stalled because apparmor was FTBFS, but that got fixed recently)
16:16:38 <SpamapS> bug 901881
16:16:40 <ubottu> Launchpad bug 901881 in glance (Ubuntu) "nova and glance should depend on python-keystone" [Low,In progress] https://launchpad.net/bugs/901881
16:17:15 <SpamapS> zul: ^^
16:17:24 <zul> SpamapS: ill double check
16:18:04 <SpamapS> I see we have the MIR's listed there too... we should probably track those
16:18:25 <zul> new libvirt is pending a MIR btw
16:18:38 <Daviey> Now is also a good time to raise any issues NOT being tracked on that list. :)
16:18:44 <s3h> and that MIR is not on ts list
16:19:02 <s3h> (dwarves-dfsg)
16:19:03 <SpamapS> zookeeper, I think, is approved.. but we haven't added the depends yet because it was basically done for juju
16:19:17 <s3h> netcf should also be on that list
16:19:30 <s3h> is that accomplished with a tag?
16:19:39 <zul> do we have a server team member on the MIR team?
16:19:54 <SpamapS> no, but it really wouldn't matter. The MIR process is bottlenecked on security
16:20:17 <zul> i mean after the bottleneck
16:20:29 <SpamapS> after the bottleneck there's nothing to do but seed/upload/etc.
16:20:38 <Daviey> zul: we do not.
16:21:01 <zul> SpamapS:  i mean when the bottleneck is done someone the server team can poke and do our bidding
16:21:04 <zul> but anyways
16:21:10 <s3h> care to discuss in open discussion?
16:21:18 <zul> sure
16:21:18 <SpamapS> zul: we don't need to be on the MIR team to do anything after the security review is done.
16:21:26 * jdstrand looked at the queue and doesn't see security team subscribed to anything
16:21:28 <s3h> arosales: Daviey: do we wannt to o through blueprints at this point?
16:21:36 <jdstrand> (for MIRs)
16:21:37 <SpamapS> zul: once that is done, the bug is approved, and any core dev can go edit the seeds or upload a depending package
16:21:40 <s3h> ruh ro
16:21:53 <jdstrand> SpamapS: what MIR(s) are you referring to?
16:22:16 <arosales> s3h: I think the main points Daviey already discussed
16:22:20 <SpamapS> jdstrand: I'm more discussing the general process and the fact that adding MIR team members would just overload your team more.
16:22:29 <jdstrand> oh
16:22:31 <arosales> ie getting blueprints updated, correct status, and approved
16:22:36 <s3h> arosales: thanks, great
16:22:40 <jdstrand> well, I was promised it wouldn't be like last time ;)
16:22:58 <SpamapS> jdstrand: "Words are wind, Jon Snow"
16:23:03 <jdstrand> heh
16:23:03 <SpamapS> ;)
16:23:09 <s3h> moving on then
16:23:19 <SpamapS> I don't see any big MIR's this cycle
16:23:21 <s3h> thanks SpamapS!
16:23:28 <s3h> #TOPIC Ubuntu Server Team Events
16:23:43 <zul> SpamapS: i do
16:23:48 <zul> but anyways
16:23:58 <jdstrand> SpamapS, zul: actually, doko and I discussed adding members to the ubuntu-mir team. we think it would be a good idea if someone else wanted to help out (beyond security audits)
16:24:07 <s3h> zul: do you want to discuss that now?
16:24:23 <SpamapS> jdstrand: sure lets discuss that in the open discussion section
16:24:29 * jdstrand nods
16:24:31 <zul> s3h: no lets continue later
16:24:44 <s3h> ok, any events coming up?
16:25:06 <arosales> m_3 @ gluecon 23-24 of May
16:25:07 <SpamapS> m_3: you still going to gluecon?
16:25:19 <m_3> submitting for the aws/ec2 conference in November
16:25:22 <jimbaker`> i'm at usenix config mgmt summit to discuss juju on june 12
16:25:36 <SpamapS> jimbaker`: cool!
16:25:53 <m_3> SpamapS: they rejected the talks... but they're local so maybe I can get a lightning talk in
16:26:01 <jimbaker`> SpamapS, thanks, this will be my first time presenting juju in public, so fingers crossed ;)
16:26:19 <s3h> cool, thanks
16:26:26 <s3h> #TPIC Weekly Updates & Questions for the QA Team (hggdh)
16:26:26 <jimbaker`> m_3, lightning talks for gluecon are tonight, so doable
16:26:38 <hggdh> hi
16:27:13 <hggdh> I have been working the last week in Boston, so I have no updates.
16:27:15 <SpamapS> m_3: and no charm school?
16:27:21 <hggdh> But I will answer any questions ;-)
16:27:22 <hggdh> ..
16:27:42 <m_3> SpamapS: nope... hopefully next year... it'd be a good crowd for at least an intro juju talk
16:27:45 <s3h> any questions for hggdh?
16:28:12 <s3h> thanks hggdh.  moving on,
16:28:23 <s3h> #TOPIC Weekly Updates & Questions for the Kernel Team (smb)
16:28:25 <smb> Hello...
16:28:36 <smb> Trying to understand bug 999755... slowly. Apart from that... other questions?
16:28:37 <ubottu> Launchpad bug 999755 in linux (Ubuntu) "Kernel crash on EC2 m1.large instances" [Medium,Confirmed] https://launchpad.net/bugs/999755
16:28:45 <smb> ..
16:29:06 <s3h> smb: you might wnat to test zul's proposed libvirt merge for quantal against xen
16:29:37 <s3h> http://people.canonical.com/chucks/libvirt
16:29:46 <zul> ~chucks/libvirt
16:29:55 <smb> s3h, Yes, I guess I should...
16:29:57 <s3h> yeah that
16:30:26 <s3h> any other questions for smb?  if not...
16:30:52 <s3h> #TOPIC Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:30:53 <rbasak> Nothing to report. Work on ARM server continues. Any questions for me?
16:31:40 <s3h> sounds like no, thanks rbasak
16:31:46 <s3h> #TOPIC Open Discussion
16:32:10 <SpamapS> jdstrand: so, despite what I thought, the  MIR team actually *could* use a member from the server team?
16:33:05 <jdstrand> SpamapS: yes!
16:33:56 <jdstrand> how it would probably work though is that the server team member would review non-server stuff and the desktop member would review server stuff (to avoid conflict of interest). but that is an implementation detail
16:34:11 <SpamapS> Yeah that sounds like a good idea.
16:34:27 <jdstrand> there is certainly enough work to go around and I feel it would benefit not only the mir team, but all teams trying to pursue MIRs
16:34:33 <SpamapS> arosales: maybe you and Daviey can work out who might be available for such a post?
16:34:33 <s3h> who all would be interested?
16:34:36 <SpamapS> Daviey: ^^
16:34:46 * SpamapS steps backward
16:34:49 <SpamapS> I have enough :)
16:35:01 <arosales> any volunteers ?
16:35:03 * s3h Daviey and arosales to work a list of who is available for MIR team
16:35:08 <jdstrand> (as an aside, we have work items on the security team surrounding improving the audit process as well)
16:35:11 <zul> he/she doesnt need to be core-dev do they?
16:35:19 <s3h> I might be interested.  if i don't have to be cored-ev
16:35:30 <s3h> or be able to speell
16:35:40 <zul> spelling is a must ;)
16:35:47 <zul> so i am out as well
16:35:49 <SpamapS> s3h: you're a server dev, are you not?
16:36:00 <s3h> yes
16:36:01 <jdstrand> well, they all currently are, but technically no because it is up to the filer to adjust the seeds, etc
16:36:07 <SpamapS> s3h: I think that shows enough packaging know-how
16:36:36 <jdstrand> but the person must be able to do pretty thorough packaging reviews. core-dev just happens to demonstrate that
16:36:59 <s3h> let's not focus on me :)  perahps whoeer is interested should email Daviey/arosales
16:37:18 <jdstrand> https://wiki.ubuntu.com/MainInclusionProcess and https://wiki.ubuntu.com/UbuntuMainInclusionRequirements should be reviewed by interested people
16:37:23 <s3h> and turn on their spell checker
16:37:52 <s3h> ok, anything actionable here?
16:38:20 <s3h> #ACTION email arosales/Daviey if interested in ubuntu-mir membership
16:38:20 * meetingology email arosales/Daviey if interested in ubuntu-mir membership
16:38:21 <SpamapS> s3h: you forgot the #
16:38:36 <SpamapS> on the first one
16:38:51 <s3h> do you think we need both actions?
16:39:02 <arosales> I also assume a couple of of rounds of MIR can help with core-dev applicaton
16:39:19 <arosales> I am sure the MIR team would welcome help
16:39:20 <rbasak> What is required for membership?
16:39:34 <arosales> able to do pretty thorough packaging reviews
16:40:00 <s3h> ok shall we move on?  any further topics?
16:40:02 <rbasak> Is contributing developer a requirement for example?
16:40:08 <arosales> and knowledgeable about  https://wiki.ubuntu.com/MainInclusionProcess and https://wiki.ubuntu.com/UbuntuMainInclusionRequirements
16:40:22 <arosales> s3h: one other topic
16:40:39 <arosales> rbasak: jdstrand would know for sure
16:40:54 <SpamapS> rbasak: you're about ready for a server dev application tho.. so I wouldn't worry too much about not having upload rights "today" :)
16:41:06 <arosales> s3h: Everyone comfortable with integrating the blueprint template jamespage emailed out?
16:41:14 <arosales> Also documented at https://wiki.ubuntu.com/BlueprintSpec
16:41:34 <s3h> I followed it with my blueprints and liked it
16:41:37 <jdstrand> well, actually I wouldn't. I kind of inherited my position :) if you are core-dev, I don't think there is any problem. if you aren't, I think the existing team would have to talk to the candidate
16:41:53 <s3h> what do others think?
16:42:05 <arosales> thanks for giving it a try s3h
16:42:55 <jamespage> if anyone needs any help interpreting the template into their blueprints please feel free to ping me
16:43:06 <arosales> or ping in ubuntu-server
16:43:14 <smoser> for reference: http://comments.gmane.org/gmane.linux.ubuntu.server/6138
16:43:27 <arosales> be great if server team had some solid blueprint documentation with this template
16:44:04 <s3h> so I personally am backing my bp's in lp +junk.  What are others doing?  Do we set up a team to combine all the blueprints?
16:44:16 <s3h> (as per smoser's suggestion)
16:44:42 <arosales> I think we still need to iron that out and perhaps sync up with Ursinha
16:44:49 <smoser> Ursinha was working on some things to make this better integrated with launchpad.
16:44:59 <arosales> s3h: good point to bring up though
16:45:07 <smoser> ie, to give a comment field and history of work items.
16:45:20 <s3h> Ursinha: do you have any update on that?
16:45:39 <arosales> s3h: you can give me an action to follow up with Ursinha on the best approach for this cycle.
16:45:43 <smoser> the issue with you doing that on your own, s3h is that someone will just edit the whiteboard manually, and then either lose their changes, or not be able to commit to your +junk branch to change it properly
16:45:49 <s3h> and is there anything in that work that would block creating the ubuntu-server-blueprints lp group
16:46:14 <SpamapS> Its worth noting that any branch can be attached to any blueprint..
16:46:18 <s3h> #ACTION arosales to follow up with Ursinha on best approach for blueprint management this cycle
16:46:18 * meetingology arosales to follow up with Ursinha on best approach for blueprint management this cycle
16:46:28 <smoser> well, s3h, urshina's proposal would largely mitigate the need for that.
16:46:32 <SpamapS> so if we do an auto-sync thing from branch -> BP we can also link the branch, and make a project, like 'ubuntu-blueprints' to keep them all in
16:46:36 <s3h> smoser: I get emails whenever they do, so I can udpate it in my copy
16:46:57 <SpamapS> this sounds like an implementation discussion tho :-P
16:46:59 <s3h> smoser: sure, but in the meantime we risk losing our whiteboard contents
16:46:59 <Ursinha> there are two things that can be done
16:47:03 <SpamapS> not something for this meeting. :p
16:47:09 <Ursinha> okay :P
16:47:09 <smoser> there she is!
16:47:21 <smoser> good. please discuss, and lets find a solution for this.
16:47:24 <Ursinha> thanks god I have hilight for misspells :P
16:47:26 <arosales> Ursinha: I catch up with you off-line
16:47:29 <Ursinha> sure
16:47:51 <Ursinha> first: using a bot that parses email, and also parses a message in the whiteboard explaining the change
16:48:17 <Ursinha> then the bot removes that and we have a page somewhere else looking like the bug activity pagwe in launchpad
16:48:35 <Ursinha> second approach, is changing launchpad to include blueprint activity
16:48:49 <s3h> Ursinha: thanks
16:48:54 <Ursinha> second one in way cleaner, but it will take a bit of time
16:49:00 <s3h> can you send an email to the m-l after you and arosales discus?
16:49:18 <Ursinha> I'm currently working on it, but don't want to wait for it to finish to start doing something
16:49:19 <Ursinha> sure
16:49:37 <s3h> thanks.  any other topics?
16:49:42 <arosales> thanks for working on that Ursinha
16:49:58 <Ursinha> arosales, it's my pleasure
16:50:00 <jamespage> I've been doing some work on the bug triage workflow
16:50:09 <s3h> ah!
16:50:09 <jamespage> should have something for you all to review this week
16:50:18 <s3h> jamespage: awesome, thanks
16:50:19 <Ursinha> jamespage, awesome :)
16:50:38 <s3h> #TOPIC Announce next meeting date and time
16:50:55 <s3h> Tuesday May 29 at 1600 UTC.  right here.
16:51:06 <s3h> #endmeeting