17:10:26 <czajkowski> #startmeeting
17:10:26 <meetingology> Meeting started Thu May 17 17:10:26 2012 UTC.  The chair is czajkowski. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:10:26 <meetingology> 
17:10:26 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:10:34 <pleia2> week after UDS is always hard
17:10:40 <czajkowski> #link https://wiki.ubuntu.com/CommunityCouncilAgendatodays agenda
17:10:52 <czajkowski> #topic TB Catch up
17:11:03 <pleia2> #link https://wiki.ubuntu.com/CommunityCouncilAgenda
17:11:10 <pleia2> (just cleaning up the link for minutes :))
17:11:13 <czajkowski> mdz: cjwatson thanks for coming along
17:11:17 <czajkowski> pleia2: thank you
17:12:56 <pleia2> mdz, cjohnston, this is just a quick status check, how are things doing? any concerns?
17:13:16 <mdz> pleia2, there are a few things worth discussing I think
17:13:32 <mdz> first the administrative
17:13:51 <mdz> we seem to have had quite some difficulty scheduling meetings lately
17:14:04 <pleia2> oops, s/cjohnston/cjwatson
17:14:13 <mdz> not with attendance per se, but with people having different ideas of when the meeting was scheduled
17:14:21 <mdz> due to there being multiple resources for that
17:14:33 <pleia2> yeah, so there is the wiki, fridge calendar
17:14:39 <czajkowski> mdz: nods, always hard.
17:14:41 <mdz> there's also a Canonical calendar
17:15:20 <czajkowski> mdz: could the person who's due to chair send out a a day before reminder so people remember to turn up?
17:15:22 <mdz> and sometimes any two of them may disagree, and it's frustrating for folks who have adapted their schedules to attend meetings in the evenings etc.
17:15:50 <mdz> czajkowski, yes, but that just creates one MORE place where the meeting time is recorded :-)
17:15:52 <pleia2> since the TB isn't all Canonical, and we want to encourage community to see what happens at these meetings, should probably make sure wiki and fridge agree and go with that as the canonical calendar (er, little "c" canonical :))
17:15:57 <mdz> is it the time in the email? or what the calendar says?
17:16:14 <mdz> I wondered what other teams are doing, and whether we could simplify to only ONE authoritative schedule
17:16:22 <mdz> whether that's the fridge calendar, or something else
17:16:31 <mdz> and remove the others so there's no misunderstanding
17:16:36 <pleia2> yeah
17:16:46 <mdz> historically, this was problematic for various reasons
17:16:55 <pleia2> fridge is what the community largely uses
17:16:55 <mdz> e.g. google calendar losing its mind on DST changes
17:17:01 <mdz> or the right people not having access to change it
17:17:02 <cjwatson> I'm in principle here, but may have to leave at mid-meeting as I'm approaching EOD
17:17:27 <pleia2> I'd suggest adding the time as reykjavik, iceland - always UTC, no DST
17:17:29 * stgraber waves (in the middle of something but on IRC if needed)
17:17:51 <cjwatson> the other people in this case was me not moderating list mail until late, but that was just a screw-up, I did at least barely remember in time
17:17:57 <cjwatson> s/people/problem/
17:18:01 <czajkowski> mdz: possibly just the fridge and then if people want to add an ical feed for their own use fine, but the fridge would always be right
17:18:27 <cjwatson> I think just the fridge is fine as long as we agree; didn't that use to be synced from google calendar?
17:18:42 <pleia2> fridge is a google calendar
17:19:05 <mdz> according to https://wiki.ubuntu.com/Fridge/Calendar the recommended approach is to create the event on your own calendar, and invite the fridge to it
17:19:10 <pleia2> and if any changes are ever needed and don't show up, you just swing by #ubuntu-news and give us a nudge
17:19:41 <pleia2> mdz: yeah, you can also ask the news team directly to add stuff
17:19:50 <mdz> OK, I'll do that then
17:19:56 <pleia2> great
17:20:09 <mdz> second topic is a small governance thing
17:20:23 <mdz> I'm listed as the "chair" of the TB, and have been since approximately the dawn of time
17:20:47 <mdz> but AFAIK that role is completely undefined, and I don't think it exists in practice
17:21:01 <cjwatson> in practice we rotate chairship from meeting to meeting
17:21:12 <mdz> in terms of the meeting chair, yes
17:21:18 <mdz> and I don't think there's a need for any other kind of chair
17:21:31 <mdz> all of the members of the TB are (should be) in equal standing
17:21:49 <czajkowski> nods
17:21:56 <czajkowski> that's how I saw it at least from the outside
17:22:07 <mdz> how would we go about making that official?
17:22:26 <pleia2> on the CC the Chair is responsible for tie-breaking
17:22:46 <cjwatson> Where's that documented for the TB?  Just the wiki and maybe a copy on the website?
17:22:48 <pleia2> I think there is a wiki page somewhere outlining this, but I'm having trouble finding it
17:23:14 <cjwatson> I believe our official tie-break procedure is to invoke sabdfl; I can't recall ever needing it
17:23:24 <czajkowski> pleia2: ah I assumed on the CC as we rotate the chair, it was equal standing only sabdfl had tie-breaking
17:23:28 <mdz> cjwatson, yes and yes
17:23:40 <pleia2> czajkowski: that's meeting chair, this is full council chair (sabdfl is ours)
17:23:40 <mdz> I don't think it has happened once in practice in 8 years
17:24:18 <mdz> cjwatson, website for sure
17:24:30 <czajkowski> pleia2: ahh ok, this is where the term chair should possibly be defined then tbh, as chair has always been rotated on all boards with equal standing except CC which has mark as chair chair
17:24:36 <pleia2> mdz: sabdfl likes the idea of chairs, so I think we might want to defer this for feedback from him too (he may have a clearer picture or remember where we documented the role)
17:24:48 <cjwatson> We used to be closer to it when we were responsible for developer approval, but with the odd exception most other matters that come to us seem to be relatively consensual at least among the board
17:24:49 <mdz> I don't think it's causing any problem per se, but it seemed like a rough edge worth reviewing
17:25:27 <mdz> pleia2, if it's to be an official role, it should be elected
17:25:29 <pleia2> czajkowski: in theory membership boards have "chair" or "secretary" as well, who is also responsible for making sure the stuff gets done (team reports, meetings happen)
17:25:33 <cjwatson> back in Oxford in 2004 I'm sure I remember an explicit idea that Mark would break ties on the CC and TB
17:25:47 <mdz> cjwatson, that matches my recollection
17:25:48 <cjwatson> The notion drifted for a while because Mark also sat directly on both
17:26:40 <pleia2> ok, so I think we want to determine what the role is supposed to be, and then take the conversation from there
17:26:45 <cjwatson> Then he decided he wanted to step down from a direct seat on the TB, but I don't think that ever superseded his general benevolent-dictator role
17:27:04 <pleia2> ah
17:27:07 <mdz> pleia2, so that's a CC action then?
17:27:21 <pleia2> yeah, I'll take it
17:27:50 <pleia2> czajkowski: action me to look into definition of chair on these boards and follow up with CC and TB?
17:27:52 <czajkowski> #action pleia2 to start a thread on the role of a chair on boards
17:27:52 * meetingology pleia2 to start a thread on the role of a chair on boards
17:27:57 <mdz> thanks
17:27:57 <pleia2> thanks :D
17:28:04 <czajkowski> pleia2: np sorry in 2 meetings at once :)
17:28:38 <czajkowski> any other comments from the TB members?
17:28:53 <mdz> in general, the various descriptions of the TB's role feel dated these days
17:29:07 <mdz> they talk about library versions and feature goals and so on
17:29:33 <mdz> and don't really capture that, at the scale Ubuntu operates at today, the TB isn't involved day to day in any routine decision making
17:30:28 <mdz> the de facto scope of the TB is to offer assistance in exceptional cases
17:30:35 <czajkowski> mdz: would it be an idea for the board to update the description and mail the CC afterwards for review?
17:30:46 <mdz> for example, if a team needs specific technical advice, or is having trouble reaching a consensus
17:30:59 <cjwatson> gah, we didn't get rid of all that library versions stuff?  I thought we nuked that from our own description a while back
17:31:14 <mdz> cjwatson, it's still on http://www.ubuntu.com/project/about-ubuntu/governance
17:31:37 <mdz> https://wiki.ubuntu.com/TechnicalBoard is a little less specific but still doesn't describe the present scope very well IMO
17:31:39 <cjwatson> grumble.  https://wiki.ubuntu.com/TechnicalBoard is marginally better but could still use improvement.
17:31:53 <mdz> czajkowski, we could do that
17:32:11 <pleia2> it doesn't strictly need our review, but we can offer feedback if needed
17:32:18 <mdz> does that content belong on the website or on the wiki? it should only be in one place
17:32:32 <mdz> I think for most teams, it's in the wiki
17:32:46 <pleia2> the trouble with ubuntu.com is it requires a ticket and follow-up, it takes a while, so we want to make the website docs as simplified as possible
17:32:55 <mdz> but the CC, TB and SABDFL also have (redundant?) content on the website
17:33:10 <pleia2> yeah :\
17:33:30 <pleia2> that has never been coordinated very well, I don't know who writes the content for the website or who they work with in the community
17:33:44 <mdz> heh, it even says that the TB meetings alternate with CC, which I don't think is particularly accurate
17:34:07 <mdz> pleia2, if you could let us know where the verbage should go, I can take a stab at writing it
17:34:34 <pleia2> mdz: I'd say update the wiki and then we'll worry about the website
17:34:36 <cjwatson> I think the last time we talked about this I pared down the website content to be just our headline description; I should have gone further and made it a link
17:34:40 <mdz> ok
17:34:47 <pleia2> cjwatson: yeah
17:35:21 <pleia2> czajkowski: can you action mdz to update TB docs?
17:35:23 <mdz> those are the things which came to mind for me
17:35:35 <mdz> pleia2, I've got it
17:35:39 <czajkowski> #action mdz update the TB docs
17:35:39 * meetingology mdz update the TB docs
17:35:40 <pleia2> thanks
17:35:43 <mdz> we'll track it as a TB action
17:35:47 <pleia2> great
17:36:35 <mdz> cjwatson, anything else?
17:37:02 <mdz> czajkowski, pleia2, is this the kind of thing you were looking for in the catch-up? this is the first one I've participated in
17:37:14 <pleia2> mdz: yep! thanks for coming
17:37:17 <czajkowski> mdz: yes thanks
17:37:22 <mdz> the email mentioned "reviewing team reports together"
17:37:27 <czajkowski> always nice to see how other boards are doing
17:37:37 <czajkowski> mdz: indeed some boards do a monthly team report
17:38:12 <pleia2> mdz: just under "might" cover :)
17:38:20 <mdz> we used to do that, but AFAIK it was never more than a concatenation of the meeting minutes
17:38:34 <mdz> do you want to look at those and let us know if you have any questions?
17:38:41 <cjwatson> I fill in the TeamReports thing when I remember, which gets automatically concatenated
17:38:50 <cjwatson> We have been extremely quiet of late, in general; not much stuff has come to us
17:38:57 <czajkowski> nofd
17:38:59 <pleia2> the benefit of team reports is they end up on https://wiki.ubuntu.com/TeamReports which is included in UWN so the broader community has a place to go to see all reports
17:39:01 <czajkowski> nofd
17:39:08 <cjwatson> For the most part I view this as a good sign since our scope has been moving in the direction of dispute resolution
17:39:11 <mdz> oh, one other thing
17:39:32 <cjwatson> We've had some discussions about being more proactive about "issues of the day", but they haven't tended to come to much and perhaps they're not a god idea
17:39:35 <cjwatson> *good
17:39:52 <czajkowski> cjwatson: at least you discussed it
17:39:54 <mdz> the one recurring task (self)assigned to the TB, we've had trouble actually doing
17:39:54 <czajkowski> :)
17:39:57 <mdz> that being the brainstorm reviews
17:40:16 <pleia2> mdz: is anyone else formally reviewing brainstorm?
17:40:28 <mdz> pleia2, there are moderators who help garden it
17:40:46 <mdz> pleia2, but "review" is maybe a misleading name for what was intended on behalf of the TB
17:41:08 <pleia2> yeah, I think the idea of TB "review" was to find actionable development items
17:41:11 <mdz> the goal was that the most popular ideas in brainstorm should elicit an official response from the project
17:41:17 <cjwatson> The brainstorm reviews have been popular and (I think) useful when we've done them, but the last couple have been belated (I can hardly complain, since I started that trend apparently)
17:41:30 <mdz> to use brainstorm as a tool for listening to the user community
17:41:43 <mdz> maybe this is a sign that this should be delegated
17:41:46 <mdz> we had a brief discussion about that
17:41:52 <pleia2> I do think it's valuable thing
17:42:03 <cjwatson> It's sort of like the big-and-fluffy equivalent of looking at the top crashers on errors.ubuntu.com
17:42:16 <mdz> exactly
17:43:10 <mdz> anyway, just an FYI for purposes of this meeting I guess. nothing for the CC to do I think
17:43:13 <cjwatson> My feeling is that this does belong with the TB, but too many of our members are too busy; I don't know whether this view is shared
17:43:24 <czajkowski> mdz: cjwatson is it meant to be done at the meeting  or via mailing list ?
17:43:27 <mdz> of course I don't think we would turn away help :-)
17:43:38 <pleia2> I don't think it needs to be very formal, maybe grab some more general devs in the community and ask them to help out?
17:43:53 <cjwatson> czajkowski: too big for at a meeting, we've been rotating one member doing a review of the top ten (notionally) every three months
17:43:55 <mdz> czajkowski, it's a medium sized project, which involves working with various people in other teams and getting their help writing responses and publishing them
17:43:55 <pleia2> (it does seem that delegation is needed here)
17:44:10 <cjwatson> which is supposed to involve going and talking with appropriate developers to get them to supply responses
17:44:26 <cjwatson> when I did it I think I got something like a 60% response rate, which was lower than I'd hoped but wasn't bad
17:44:27 <pleia2> cheesehead from brainstorm is quite the active community member, talking to him about what brings the most value may be useful too
17:44:55 <cjwatson> it took me about three weeks elapsed time, probably about a day's total work
17:45:02 <czajkowski> cjwatson: 3 months is a long time as well.
17:45:17 <mdz> Ian Weisser offered help
17:45:39 <pleia2> ah, good
17:45:48 <mdz> the total amount of work across everyone involved makes it a sizeable effort
17:46:01 <mdz> maybe an hour's work each, but for a dozen or so people
17:46:08 <czajkowski> nods thanks for the explaination
17:47:44 <mdz> anything else?
17:47:50 <pleia2> I think that's it
17:47:52 <czajkowski> nope I'm all good thanks
17:47:54 <pleia2> thanks for coming
17:48:17 <czajkowski> ok we'll move on
17:48:23 <czajkowski> next person isn't about
17:48:26 <czajkowski> AlanBell: ping
17:48:29 <AlanBell> hi
17:48:33 <pleia2> JC Hulce/soaringsky - are you here with another nickname?
17:48:57 <pleia2> I'll follow up with them via email
17:49:00 <czajkowski> pleia2: I did that already in /whois
17:49:02 <czajkowski> #topic Election and appointment of the 5th member of the IRCC
17:49:35 <czajkowski> AlanBell: thanks for coming
17:50:18 <AlanBell> so the IRCC charter states we should have 5 members, back when this IRCC was appointed there were only 4 applicants
17:50:39 <AlanBell> we decided to hold off on recruiting until the Q cycle, so now we are ready
17:50:51 <czajkowski> great to hear
17:50:56 <pleia2> great
17:51:10 <AlanBell> the appointment process is here https://wiki.ubuntu.com/IRC/IrcCouncil
17:51:57 <pleia2> AlanBell: last time a sitting member of the IRCC did the call for nominations, so I'd suggest moving forward with a similar process this time https://lists.ubuntu.com/archives/ubuntu-irc/2011-November/001465.html
17:52:11 <pleia2> send to the cc list, -irc and -news-team
17:52:12 <czajkowski> AlanBell: do you have a time frame in mind
17:52:33 <AlanBell> pleia2: ok, great, that bit wasn't so clear, I can do that
17:52:46 <AlanBell> czajkowski: lets get on and do it
17:53:07 <pleia2> https://lists.ubuntu.com/archives/ubuntu-irc/2011-November/001467.html is the second email in that (he had to make some adjustments :))
17:53:23 <pleia2> looks like the call was open for 2 weeks last time
17:53:42 <czajkowski> AlanBell: great just be really clear on the date/deadlines
17:53:45 <AlanBell> which takes it nicely to the end of the month if announced today
17:53:53 * pleia2 nods
17:54:10 <czajkowski> AlanBell: thanks for this
17:54:44 <czajkowski> no actions from us from this
17:54:54 <czajkowski> anything else?
17:55:05 <pleia2> just a quick thing about the CoC
17:55:05 <AlanBell> ok, so end of this month for applications, then we can start the vote during next month
17:55:16 <pleia2> AlanBell: sounds good!
17:55:29 <czajkowski> #topic Code of Conduct
17:56:01 <pleia2> at UDS the CC met to discuss the proposed CoC again, cproffit blogged about it here and linked to the notes: http://ftbeowulf.wordpress.com/2012/05/10/uds-day-four-code-of-conduct-review/
17:56:34 <pleia2> there have been some revisions based on this discussion (huge thanks to Laney in particular for his great feedback)
17:56:51 <pleia2> but being post-UDS week, we're still catching up to make sure everything was addressed :)
17:57:07 <pleia2> once we're at a good stopping point, we'll put it out to the community for another review before publishing
17:57:31 <pleia2> that's it from me
17:57:51 <czajkowski> great
17:58:06 <czajkowski> #topic AOB
17:58:10 <czajkowski> anything else ?
17:58:39 <czajkowski> nope ok then
17:58:50 <czajkowski> #endmeeting