17:03:23 <czajkowski> #startmeeting
17:03:23 <meetingology> Meeting started Thu Apr  5 17:03:23 2012 UTC.  The chair is czajkowski. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:03:23 <meetingology> 
17:03:23 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:03:31 <czajkowski> aloha and welcome to the CC meeting
17:03:41 <czajkowski> #link https://wiki.ubuntu.com/CommunityCouncilAgenda
17:03:43 <czajkowski> todays agenda
17:04:03 <czajkowski> dpic: ping
17:04:12 <dholbach> o/
17:04:21 <dpic> hi
17:04:44 <czajkowski> #topic Bug 1
17:04:50 <czajkowski> #link https://wiki.ubuntu.com/Bug1
17:05:02 <czajkowski> dpic: care to talk to us regarding your agenda item?
17:05:18 <dpic> So, bug #1 is a bit vague because it is specific to microsoft. that means apple could solve it for us
17:05:22 <ubottu> Launchpad bug 1 in Ubuntu "Microsoft has a majority market share" [Critical,In progress] https://launchpad.net/bugs/1
17:05:28 <dpic> i don't think that was the intention
17:05:39 <dpic> so i drafted this: https://wiki.ubuntu.com/Bug1
17:05:55 <mog> dpic, or that ubuntu could solve the problem via equally non-free software
17:06:00 <dpic> it cites the ubuntu philosophy and commitment to making floss available
17:07:41 <beuno> that's interesting
17:07:49 <dpic> i don't think ubuntu would be completely proprietary ever, but it does make sense to shift the conversation to proprietary software and away from windows
17:08:27 <dpic> because if Apple suddenly took over the world, we would have less free software but bug #1 would technically be solved
17:08:31 <ubottu> Launchpad bug 1 in Ubuntu "Microsoft has a majority market share" [Critical,In progress] https://launchpad.net/bugs/1
17:08:59 <dpic> ok, i'll refer to it as "the bug" or "#1" from now on to avoid the bot haha
17:09:14 <mog> dpic, given how ubuntu already integrates non free software into the core distro i don't think its outlandish to say it would become more proprietary
17:09:22 <sabdfl> hello hello
17:09:31 <dpic> sabdfl: hello there
17:09:40 <dholbach> it's a shame LP is timing out right now, because I'd love to read the bug description and everything again
17:09:42 <dpic> sabdfl: do you have logs or shall i pastebin?
17:09:56 <sabdfl> thanks dpic, yes please
17:09:58 <pleia2> I pastebined them
17:09:59 <dpic> dholbach: i can pastebin it if you like
17:10:01 <pleia2> http://paste.ubuntu.com/916280/
17:10:07 <dpic> pleia2: great, thanks
17:10:56 <dholbach> dpic, ah no, now it opened
17:11:02 <dpic> this is the buf now dholbach http://paste.ubuntu.com/916281/
17:11:10 <dpic> ah, okay [=
17:11:22 <sabdfl> i think it would be a mistake to turn bug 1 from tease to dogma
17:11:26 <ubottu> Launchpad bug 1 in Ubuntu "Microsoft has a majority market share" [Critical,In progress] https://launchpad.net/bugs/1
17:11:46 <sabdfl> and i think it would be moving the goal posts to edit it now
17:12:09 <dpic> sabdfl: interesting point.
17:12:09 <mog> sabdfl, so ubuntu doesnt stand for expanding free software but was just teasing?
17:12:19 <sabdfl> if we get too focused on it, we end up in impossible conversations
17:12:22 <dpic> mog: i think that wasn't the point
17:12:24 <sabdfl> like what the meaning of proprietary is
17:12:30 <dpic> sabdfl: true
17:12:31 <sabdfl> and mog's point
17:12:32 <pleia2> I've always seen bug #1 to be a bit tongue in cheek
17:12:36 <ubottu> Launchpad bug 1 in Ubuntu "Microsoft has a majority market share" [Critical,In progress] https://launchpad.net/bugs/1
17:12:48 <sabdfl> exactly, it was a tease, and frankly one i regret for being a smallminded way to start
17:13:01 <sabdfl> we don't win by being smallminded
17:13:09 <dpic> yes
17:13:11 <sabdfl> nor do we win by being pedantic
17:13:41 <sabdfl> and arguing about the wording of a smallminded tease sounds like the third or fourth century of a successful religion, not what we need to be now ;)
17:13:47 <dpic> i think the goalposts deserve shifting, but is there a way this bug could be used for that without running into those concerns?
17:14:05 <sabdfl> let sleeping dogs lie, is my view
17:14:10 <beuno> if we close that bug, I think we can celebrate. If someone else is now dominating, well, we can always file a new bug  ;)
17:14:25 <sabdfl> if the cc feels it needs changing, fine, but i'd be happy to say 'let's focus on more meaningful discussions'
17:14:34 <dpic> beuno: there will only be one (bug) #1!
17:14:52 <sabdfl> indeed. bug 1000000 is coming up though ;)
17:14:53 <ubottu> Error: Launchpad bug 1000000 could not be found
17:15:00 <sabdfl> thank you, ubottu
17:15:00 <dpic> haha
17:15:07 <dholbach> sabdfl, then we'd better be quick :)
17:15:18 <sabdfl> can we thank those who raised it, and move on?
17:15:37 <beuno> yeah, I'm happy to leave it and look forward to closing it
17:15:43 <czajkowski> sounds like a great idea
17:15:46 <dholbach> yes, same here
17:15:52 <czajkowski> moving on
17:15:53 <beuno> am happy we're even considering it needs broadening, makes it look smaller!
17:15:53 <pleia2> agreed
17:16:08 <czajkowski> #topic Asia/Oceania Regional Membership Board Catch up
17:16:27 <czajkowski> anyone here from the A/O Board?
17:16:29 <pleia2> I haven't gotten replies from any A/O folks about attending today, but it's the middle of the night for them
17:16:42 <pleia2> (3AM in Sydney, and it goes from there)
17:16:57 <beuno> good, so lifeless should be awake  :p
17:17:04 <pleia2> hah :)
17:17:07 <czajkowski> beuno: *grin* true!
17:17:40 <dholbach> damn, I should've considered that when I set up the schedule :/
17:17:45 <czajkowski> do we have any other items to discuss ?
17:17:57 <czajkowski> dholbach: unless you can move timezones it's not your fault :)
17:19:34 <dholbach> I have a quick one - when will we move over the Teams page? :)
17:20:00 <czajkowski> #topic move over teams page
17:20:05 <sabdfl> sooner rather than later
17:20:12 <sabdfl> it's already better than what went before, isn't it?
17:20:17 <czajkowski> nods it is
17:20:31 <czajkowski> and we've merged two columns into one to create more room
17:20:35 <pleia2> great
17:20:47 <pleia2> I think we go live with it now, it'll always need tending and updates, it's fine for now
17:20:49 <czajkowski> if people want to add their team information to it when it's up they can
17:20:54 <czajkowski> pleia2: exactly
17:21:06 <dholbach> who wants to do the honours?
17:21:08 <czajkowski> I can copy over the /temp version to live version this evening
17:21:15 <pleia2> thanks czajkowski :)
17:21:16 <dholbach> great
17:21:38 <czajkowski> #action czajkowski to update the /teams page with working draft
17:21:38 * meetingology czajkowski to update the /teams page with working draft
17:22:21 <czajkowski> anything else ? anyone ?
17:23:37 <sabdfl> merged code of conduct 2.0
17:23:50 <czajkowski> #topic merged code of conduct 2.0
17:24:30 <sabdfl> http://bazaar.launchpad.net/~sabdfl/ubuntu-codeofconduct/v2-draft/changes
17:24:43 <sabdfl> by way of background
17:25:01 <sabdfl> we were looking at how to build awareness of the leadership coc
17:25:11 <sabdfl> and how to make it possible for people to sign / support that
17:25:22 <sabdfl> as part of our general review of governance and leadership in ubuntu
17:25:42 <sabdfl> and thought it might be better to merge the leadership value statement into the normal coc
17:25:53 <sabdfl> on the grounds that all of us have opportunities for leadership
17:26:06 <sabdfl> and we should be clear throughout the community what we think makes for good leadership
17:26:31 <sabdfl> so, (amber?) set about merging them, i crunched it down a few tens of lines, and others have made suggestions
17:26:39 <sabdfl> along the way, it made sense to integrate the diversity statement
17:26:57 <sabdfl> and the link is where we stand with a current draft Code of Conduct 2.0
17:27:18 <sabdfl> there is some email from the CC on it which i confess to having failed to parse and integrate
17:27:19 <dholbach> http://bazaar.launchpad.net/~sabdfl/ubuntu-codeofconduct/v2-draft/view/head:/MergedCodeOfConduct.txt is the actual changed document
17:27:36 <sabdfl> should we take comments and feedback here?
17:27:46 <dholbach> sure
17:28:58 <czajkowski> I think it's good we've addressed peoples issues that they couldnt sign a LCoC but with it being addressed now in the CoC this  helps
17:29:00 <dholbach> when I googled an expression used in the CoC I was pleasantly surprised to see many other communities who adopted it :)
17:30:28 <bkerensa> There is talk of Mozilla adopting portions of the Ubuntu CoC
17:30:46 <sabdfl> they might want to get a heads-up on this 2.0, and we could take suggestions from them
17:30:57 <sabdfl> i tried to generalise it but.... it was difficult
17:31:01 <dholbach> I'm very happy with the new CoC - the only bit I think we could improve is the BDFL bit - it might need some clarification, particularly for new contributors
17:31:08 <sabdfl> dholbach, i've tried to demystify the BDFL reference
17:31:13 <dholbach> sabdfl, they're aware - czajkowski and I are in conversations
17:31:16 <sabdfl> ok
17:33:26 <czajkowski> any further comments on the CoC V 2.0 ?
17:34:15 <czajkowski> should we blog this
17:34:25 <czajkowski> post to mailing lists?
17:34:37 <czajkowski> to let people know of this change and when should we do it ?
17:35:23 <sabdfl> i'm going to work through the CC comments now and make tweaks
17:35:36 <sabdfl> dholbach said the latter portion felt a bit too heavy on the delegation mechanics
17:36:05 <czajkowski> I think that was in reference to the Leadership part no? 'Their teams' ?
17:36:38 <dholbach> ah yes - sabdfl, you're right - I missed that when reviewing the thread again
17:38:05 <dholbach> while it is important to explain leaders what good leadership is and how delegation works, a casual Ubuntu contributor might feel a bit less free to jump in and pioneer in a given area
17:38:48 <dholbach> ... after reading a few paragraphs about delegated powers and delegated responsibilities
17:38:56 <dholbach> I'm not sure if this is also a concern of yours
17:41:02 * beuno re-reads
17:41:48 <sabdfl> there are a couple of things i really wanted to convey
17:42:04 <sabdfl> this is as much about being a leader as it is about being lead
17:42:34 <sabdfl> i think it's important we avoid some of the post-decision carping that is toxic in other communities
17:42:40 <sabdfl> you know the story:
17:42:53 <sabdfl> * there is a hard decision to be taken ("Upstart vs Systemd")
17:43:02 <sabdfl> * someone steps up to do the analysis and the work
17:43:10 <sabdfl> * they take a decision and do a ton of work tomake it real
17:43:47 <sabdfl> * then others who weren't around jump in and say it's all wrong
17:43:53 <sabdfl> * so it all goes on hold for three years
17:43:57 <sabdfl> * people resign in frustration
17:44:05 <sabdfl> * then someone just does it that way anyway
17:44:10 <sabdfl> let's not go there
17:44:39 <dholbach> totally agreed
17:44:44 <sabdfl> so i was being forceful about the importance of getting the delegation right (top down delegation, bottom up confirmation)
17:44:54 <czajkowski> +1
17:44:59 <sabdfl> and the importance of letting the folk do the work they have taken on
17:45:08 <sabdfl> recognising the occasional need to escalate
17:45:34 <sabdfl> all of that becomes a little longwinded
17:45:39 <sabdfl> i'll give it another spin
17:45:46 <sabdfl> i think that covers all the feedback
17:46:03 <sabdfl> will push a few more commits up, then am happy for blogging and feedback
17:46:15 <sabdfl> could we identify someone to act as a central taker of feedback?
17:46:26 <sabdfl> so we can consider, say, one wiki page of feedback rather than a long thread?
17:46:43 <czajkowski> nods makes sense to keep the feedback in one place
17:46:50 <dholbach> maybe we can blog about it on the fridge and collect replies there?
17:46:51 <czajkowski> rather than here on a ml then another chunk elsewhere
17:47:00 <sabdfl> +1
17:47:16 <dholbach> ...as we don't really have a general purpose mailing list
17:47:18 <czajkowski> sabdfl: I could collect any feedback mailed to my @ubuntu.com address
17:47:23 <czajkowski> and put it on a wiki page for us to review
17:47:25 <beuno> +1
17:47:29 <sabdfl> perfect
17:47:38 <czajkowski> grand job
17:47:54 <dholbach> yes, I'm quite happy with it as well :)
17:49:01 <czajkowski> ok are we done folks ?
17:49:13 * dholbach is
17:49:19 * beuno too
17:50:33 <czajkowski> right
17:50:39 <czajkowski> #endmeeting