19:03:17 <cody-somerville> #startmeeting
19:03:17 <meetingology> Meeting started Mon Mar 26 19:03:17 2012 UTC.  The chair is cody-somerville. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:03:17 <meetingology> 
19:03:17 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:03:33 <adam_g> o/
19:03:42 <cody-somerville> [topic] Review of previous action items: cody-somerville to write some documentation on how to endorse someone
19:04:11 <cody-somerville> Sadly, this still isn't done. I've written some stuff up so might just end up sending what I have to dmb mailing list so that someone else can pick up on this instead of it continuing to block on me.
19:04:22 <cody-somerville> Apologies to the rest of the council on the delay on this.
19:04:39 <cody-somerville> Any questions on this action item before we move on?
19:04:45 <tumbleweed> not from me
19:04:46 <Laney> please do, that would be appreciated
19:05:35 <cody-somerville> From the looks of it, the rest of the action items on the agenda are complete. Does anyone wish to discuss any of them specifically?
19:07:15 <cody-somerville> [topic] MOTU Applications: Kilian Krause
19:07:50 <cody-somerville> kilian, Hello Kilian. Could you please introduce yourself and your application for MOTU?
19:07:57 <kilian> hi cody-somerville
19:08:06 <micahg> cody-somerville: I believe adam_g was first
19:08:21 <cody-somerville> adam_g, Sorry. We'll get to you next.
19:08:24 <adam_g> np
19:08:39 <kilian> as already laid out on the wiki page I'm a DD who would like to more intensely contribute to Ubuntu
19:08:43 <cody-somerville> #link https://wiki.ubuntu.com/KilianKrause/DeveloperApplication
19:08:47 <cody-somerville> [link] https://wiki.ubuntu.com/KilianKrause/DeveloperApplication
19:08:49 <kilian> right ;-)
19:09:50 <kilian> I've had a number of packages that I sponsored to Debian which I felt were good in enough shape for both Debian and Ubuntu so here I am asking whether the fake sync is the way to go or what we can do about direct upload right...
19:10:00 <Laney> What experience do you have in directly contribution to Ubuntu?
19:10:12 <Laney> contributing ...
19:10:32 <kilian> Laney: I've just had a couple of security uploads into ubuntu for one of my Debian packages and I'm using LTS at work
19:11:00 <kilian> Laney: so I fairly well know what release schedule to follow for I need it at work anyway ..
19:11:36 <Laney> Right. Since you're a DD I am not so concerned about your packaging skills so I just want to probe at your knowledge of Ubuntu processes
19:11:41 <kilian> Laney: and yes it was a coleague of me and I who introduced Ubuntu as a second enterprise distro so I'm all for not letting it down
19:11:48 <Laney> Do you know about our various freezes?
19:11:51 <cody-somerville> kilian, What is DIF? When would you apply for an exception? How would you apply?
19:12:20 <Laney> a DIF exception?
19:12:28 <kilian> dif is a debian import freeze
19:12:38 * Laney doesn't know what that is :P
19:12:38 <kilian> i.e. when no direct sync will happen any more
19:13:02 <kilian> an exception would logically be a security upload or major broken version that's fixed with the next upload
19:13:32 <kilian> obviously not an exception would be all "just eye candy" stuff that can easily wait for the next release and has no relevant impact on the user experience
19:14:13 <tumbleweed> kilian: you can still sync after DIF, they just don't happen automatically
19:14:52 <kilian> tumbleweed: let's put it that way, I'd try to have my stuff in before
19:15:53 <kilian> tumbleweed: but in a way, it very much remind me of Debian Freeze for Testing
19:15:56 <tumbleweed> doing stuff after DIF really isn't anything to worry about, either
19:16:07 <kilian> tumbleweed: sure
19:16:08 <tumbleweed> Final Freeze is closer to Debian Freeze
19:16:09 <bdrung> kilian: until when can you upload new packages or new upstream releases to ubuntu?
19:16:26 <kilian> bdrung: i don't get that question
19:16:28 <kilian> sorry
19:16:31 <cody-somerville> kilian, Do you hang out in any Ubuntu IRC channels?
19:16:55 <tumbleweed> kilian: bdrung is asking that in terms of the release schedule
19:17:05 <kilian> cody-somerville: eventually, time permitting.. but usually only to get stuff fixed that doesn't work for me
19:17:19 <bdrung> kilian: until which date do you need to get a new upstream release into ubuntu to ship it with the next release?
19:18:15 <bdrung> kilian: are you subscribed to Ubuntu's mailing lists?
19:18:40 <kilian> tumbleweed, bdrung: at the totally latest - the release date (but that's assuming a very large security flaw)
19:18:54 <kilian> bdrung: sure, like ubuntu-security
19:19:21 <tumbleweed> kilian: right, but without bureocracy?
19:19:34 <Laney> ubuntu-devel-announce is one you should be on
19:19:36 <tumbleweed> *bureaucracy
19:19:41 <bdrung> kilian: i was talking about new upstream release, i.e. new features
19:19:42 <kilian> Laney: right
19:20:32 <Laney> the guys are asking you what the last date for a 'normal' featureful upload is
19:20:38 <Laney> i.e. one for which you do not have to seek approval
19:21:03 <kilian> bdrung: IIRC that was 10 days like in unstable
19:21:31 <kilian> before freeze and hard freeze of course
19:22:03 <Laney> https://wiki.ubuntu.com/PrecisePangolin/ReleaseSchedule
19:22:52 <Laney> we're talking about Feature Freeze. After this date, uploads should be bug fix only unless you have an exception from the release team
19:23:17 <kilian> Laney: sure
19:24:15 <Laney> anyone else?
19:24:25 <tumbleweed> kilian: are you intending to use your MOTU rights for packages that you already maintain in Debian or are you interested in wider QA efforts?
19:26:01 <kilian> tumbleweed: I would naturally focus on my packages the most but as far as my commitment to Debian mentors permits I'd also lend those packages a helpnig hand - including also helping fixing those up I use at work where I find them not doing what they should
19:26:30 <kilian> (like writing LP bugs and seeing what the current maintainers needs - if that's an upload that'd be fine with me)
19:26:54 <kilian> "maintainer" in the sense of the last upload or most common uploader naturally
19:27:14 <bdrung> kilian: imagine you have uploaded a new version of a package to debian. how do you get that version into ubuntu?
19:27:55 <kilian> bdrung: if there's a BZR repo by putting it in there or otherwise with a source-only upload as opposed to a sourceful (but binary) upload in Debian
19:28:27 <kilian> s/or/and/
19:28:43 <bdrung> kilian: what would you do if there is no source change needed for ubuntu?
19:29:39 <kilian> bdrung: i don't quite get that.. if the ubuntu version is derived from the debian version and I've just put new stuff in - how could the ubuntu version not need it?
19:30:01 <kilian> bdrung: other than I've derived my debian update from the ubnntu version
19:30:15 <cody-somerville> Unfortunately, I have to unexpectedly jet. Kudos to tumbleweed for picking up the rest of the meeting as chair.
19:30:16 <cody-somerville> #unchair
19:30:16 <meetingology> Current chairs: cody-somerville
19:30:23 <cody-somerville> #chair tumbleweed
19:30:23 <meetingology> Current chairs: cody-somerville tumbleweed
19:30:25 <cody-somerville> #unchair
19:30:25 <meetingology> Current chairs: cody-somerville tumbleweed
19:30:28 <cody-somerville> #unchair cody-somerville
19:30:28 <meetingology> Current chairs: cody-somerville tumbleweed
19:30:33 <cody-somerville> lol
19:30:36 <Laney> If the Ubuntu package is equal to the Debian one and you then upload a new Debian revision after the automatic imports have ceased (i.e after DIF)
19:30:37 <tumbleweed> #unchair cody-somerville
19:30:37 <meetingology> Current chairs: cody-somerville tumbleweed
19:30:42 <Laney> haha.
19:30:43 <tumbleweed> nope. not gonna happne
19:31:25 <Sweetshark> meetingology seems to be rather strongminded.
19:31:25 <meetingology> Sweetshark: Error: "seems" is not a valid command.
19:31:37 <kilian> Laney: depends on the change.. like said above I could discuss whether the change would warrant an upload after DIF
19:32:01 <bdrung> kilian: assume it warrants an upload
19:32:32 <kilian> Laney: then seek confirmation with ubuntu-dev and go ahead if permitted
19:33:06 <bdrung> kilian: would you then upload the source package of debian to ubuntu?
19:33:06 <kilian> but still that doesn't get me to that point where the ubuntu package doesn't need the update like plotted before
19:33:24 <kilian> bdrung: depends on the version currently in ubuntu
19:33:43 <kilian> bdrung: most probably introduce a new version number first and then upload
19:35:02 <bdrung> kilian: assume that you have uploaded a new version of portaudio19 to Debian.
19:35:49 <kilian> bdrung: ok
19:35:52 <tumbleweed> guys, I think we need to wrap this up and move to a vote
19:36:45 <tumbleweed> bdrung: are you almost finished?
19:36:55 <bdrung> kilian: what i asked for: if ubuntu made no changes to the debian package, new version can be _synced_
19:37:19 <kilian> bdrung: of course
19:37:42 <bdrung> kilian: what is the difference between a sync and a normal ubuntu upload?
19:37:58 <kilian> the sync is the pure debian source upload
19:38:05 <kilian> i.e. unchanged with identical version number
19:38:15 <kilian> (like with portaudio19)
19:38:15 <tumbleweed> ok, bdrung is done
19:38:40 <kilian> whereas a regular ubuntu upload has another version (and potentially a diff beyond just debian/changelog)
19:39:35 <tumbleweed> #vote Should we grant kilian MOTU rights?
19:39:35 <meetingology> Please vote on: Should we grant kilian MOTU rights?
19:39:35 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
19:39:35 <bdrung> kilian: yes, but a sync is done by launchpad and normally not a source upload by a developer
19:39:39 <tumbleweed> #voters bdrung tumbleweed laney micahg cody-somerville barry stgraber
19:39:39 <meetingology> Current voters: barry bdrung cody-somerville laney micahg stgraber tumbleweed
19:40:45 <tumbleweed> +0 [ I think kilian needs some more experience with sponsored uploads in Ubuntu before getting component-wide privileges ]
19:40:45 <meetingology> +0 [ I think kilian needs some more experience with sponsored uploads in Ubuntu before getting component-wide privileges ] received from tumbleweed
19:40:53 <barry> +0
19:40:53 <meetingology> +0 received from barry
19:41:23 <stgraber> +0 [I don't doubt the packaging knowledge but I'd like to see more Ubuntu-specific experience through sponsoring]
19:41:23 <meetingology> +0 [I don't doubt the packaging knowledge but I'd like to see more Ubuntu-specific experience through sponsoring] received from stgraber
19:41:35 <bdrung> -1 i recommend to do some syncs / uploads through sponsors to get more familiar with the Ubuntu procedures and differences
19:41:35 <meetingology> -1 i recommend to do some syncs / uploads through sponsors to get more familiar with the Ubuntu procedures and differences received from bdrung
19:42:21 <micahg> +0 echo what tumbleweed, bdrung, and stgraber said
19:42:21 <meetingology> +0 echo what tumbleweed, bdrung, and stgraber said received from micahg
19:42:33 <tumbleweed> Laney?
19:42:49 <Laney> -1 The discussion has highlighted a lack of knowledge about Ubuntu procedures. I'd recommend sticking around for a while and taking a direct involvement in your Debian packages in Ubuntu (through sponsors on this side) to gain the experience required.
19:42:59 <Laney> Bot.
19:43:13 <tumbleweed> #endvote
19:43:13 <meetingology> Voting ended on: Should we grant kilian MOTU rights?
19:43:13 <meetingology> Votes for:0 Votes against:1 Abstentions:4
19:43:13 <meetingology> Motion denied
19:43:21 <tumbleweed> Laney: err he might be case sensitive
19:43:24 <Laney> must be
19:44:34 <tumbleweed> kilian: I'm sorry that the result came otu this way. I strongly recommend using sponsors for a handful of uploads and re-applying
19:44:40 <Laney> kilian: If you hang around in #ubuntu-motu and get some stuff sponsored you'll very quickly get the knowledge we're looking for
19:45:41 <tumbleweed> who's next? adam_g?
19:45:58 <adam_g> o/
19:46:00 <barry> kilian: stick with it, and thanks for your contributions to ubuntu!
19:46:16 <Laney> there's no meeting after us, so we can run over a bit if we need to and everyone can stick around
19:46:24 <tumbleweed> #topic ubuntu-server-dev application for Adam Gandelman
19:46:49 <tumbleweed> oops, and MOTU too
19:46:53 <tumbleweed> we'll vote on them separately
19:47:02 <tumbleweed> adam_g: care to introduce yourself?
19:47:09 <tumbleweed> #link https://wiki.ubuntu.com/AdamGandelman/UbuntuServerDevApplication
19:47:16 <adam_g> i'm adam, i work on the ubuntu server team at canonical. i help maintain the server package set with a f
19:47:19 <adam_g> ocus on the many openstack components, through sponsorship up until now.  i'm seeking MOTU + upload righ
19:47:22 <adam_g> ts to the server package set. i'm also applying for membership to the ubuntu-server-dev team, which the
19:47:25 <adam_g> DMB owns. a number of packaging branches I work on are hosted there.
19:47:44 <Laney> membership in the server-dev team gives you rights to the server package set
19:47:47 <Laney> they're granted together
19:48:09 <adam_g> Laney: i see! didn't know they came together
19:48:52 <tumbleweed> any questions for adam_g?
19:49:42 <stgraber> adam_g: are you subscribed to ubuntu-devel-announce and read it daily?
19:49:58 <Laney> adam_g: do you see any solution to your "What I like least in Ubuntu" issue?
19:50:16 <Laney> if you see such a problematic package do you raise it with the developers involved?
19:50:25 <adam_g> stgraber: Hmm, it appears i am not. i am subscribed to ubuntu-devel, and follow threads there daily
19:51:05 <stgraber> adam_g: please subscribe to ubuntu-devel-announce now then, that's where freezes are announced and it's a must read for anyone who has upload rights
19:51:32 <adam_g> Laney: yes, i have been trying to ensure a higher level of quality in the packages i touch, either thru fixing the issues myself or doing my best to encourage better practices of those who may no longer seek sponshorship review
19:51:58 <adam_g> stgraber: definitely will do, thanks
19:52:08 <Laney> some developers call out mistakes on ubuntu-devel when they see them
19:52:13 <Laney> do you think that's a good idea?
19:52:39 <barry> adam_g: what do you think is the biggest cause for the wide disparity in packaging practices?
19:53:32 <adam_g> Laney: if its some general pattern of bad practices among certain packages, its probably a good idea. though, id prefer to reach out to specific developers personally first, to avoid singling any one person out on a public list
19:54:10 <adam_g> barry: lack of peer review, probably, for developers who are no longer required to seek sponsorship for their work
19:54:47 <adam_g> barry: we've been tyring to solve this issue around the openstack packages this sycle, by setting up staging packaging branches where we can collobarte on changes before they make it the ubuntu branches
19:54:56 <bdrung> adam_g: are there tools that helps raising the quality of a package?
19:55:13 <stgraber> adam_g: (reply when you're done with the current questions): let's say you have ubuntu-server upload rights and want to upload lxc later this afternoon, can you do it and if not, why?
19:56:18 <adam_g> bdrung: well, there's lintian, but that can only test so much.  im perhaps overly paranoid and do my best to physically install packages i touch, to confirm my changes,  even for trivial changes
19:56:33 <barry> adam_g: do you think that doing more code reviews before uploads would help with that (if it's due to laziness, or evolving best-practices), and if so would you encourage or force more reviews before uploads?
19:58:14 <bdrung> adam_g: another question for the question stack: Do you collaborate with Debian developers? Are you involved in Debian?
19:58:21 <adam_g> barry: i do think evolving the workflow to encourage that practice would help. at the same time ubuntu is too large to enforce it for every change against every package. there should be a good middle ground, i think
20:00:30 <adam_g> stgraber: im not certain lxc is part of the server seed, i would have to check. and im hestitant to touch such a complex package without confirmation from those that know it better htan me. in the case of lxc, even if i had upload rights i'd probably seek a +1 from someone who knows the pkg better than myself
20:00:52 <stgraber> adam_g: lxc is part of ubuntu-server
20:00:59 <Laney> how can you check if a package is seeded?
20:01:37 <stgraber> adam_g: assuming you just need to do a minimal change to it anyway, would you be allowed to upload it today?
20:02:11 <adam_g> Laney: there is a list of each package set, but my book for it eludes me atm
20:03:18 <stgraber> adam_g: (lxc just happens to be the best example of a specific kind of package that's in the ubuntu-server package set and that I want you to talk about ;))
20:03:43 <adam_g_> apologies, terminal dropped
20:03:58 <adam_g_> stgraber: i believe that i would be able to upload it
20:04:42 <stgraber> adam_g_: you'd technically be able to upload it indeed (as it's in your package set), now the release team (and me in particular) wouldn't be too happy about it, why?
20:05:40 <adam_g_> stgraber: because we are so late in the cycle
20:06:19 <stgraber> adam_g_: true but following that reasoning we wouldn't upload anything after feature freeze ;)
20:06:39 <stgraber> adam_g_: there's a specific reason why you shouldn't upload lxc until the 29th, any idea what it's?
20:08:02 <adam_g_> stgraber: of the top of my head, no im not sure
20:09:38 <stgraber> adam_g_: I'm hoping you're aware that we are currently in beta2 freeze right?
20:10:05 <adam_g_> stgraber: yes, i am.
20:10:29 <adam_g_> i had the pleasure of seeking +1 from an archive admin for a new binary package on Friday
20:10:38 <stgraber> ok, other DMB members are poking me to tell you why so I'll explain ;)
20:10:53 <stgraber> lxc is in the ubuntu-server packageset even though it's a universe package
20:11:09 <stgraber> some universe packages can be affected by a freeze too (not limited to main packages)
20:11:15 <stgraber> which is the case of lxc
20:11:20 <stgraber> as it's a dependecy of arkose
20:11:25 <stgraber> which is another universe package
20:11:30 <stgraber> itself seeded by edubuntu
20:11:36 <stgraber> and on the Edubuntu DVD media
20:11:47 <stgraber> so any upload of lxc would require a rebuild and retest of all the Edubuntu images
20:12:05 <adam_g_> that makes sense
20:12:12 <stgraber> that's why it's frozzen and why you should ask for the release team approval before uploading it until past-beta2
20:13:15 <stgraber> adam_g_: you can check it with "seeded-in-ubuntu lxc"
20:13:19 <stgraber> stgraber@castiana:~/data/code/ubiquity/ubiquity$ seeded-in-ubuntu lxc
20:13:19 <stgraber> lxc (from lxc) is seeded in: edubuntu: dvd
20:13:57 <adam_g_> stgraber: i see, i was not aware of that tool, thanks for the tip
20:14:02 <stgraber> adam_g_: 20:13 < Laney> also apt-cache show lxc | grep ^Task
20:14:11 <stgraber> (copy/pasting from another channel)
20:14:53 <stgraber> I'd highly recommend running these before any upload when the archive is frozzen (check #ubuntu-devel status and ubuntu-devel-announce to know when it's the case)
20:16:06 <adam_g_> i've been following the freeze closely this cycle, and as i said, have already run into an instance where archive admin approval was required. some of the tooling is still new to me, and knowing where to go for this informatio is invaluable, thanks stgraber
20:16:54 <micahg> adam_g_: are there any plans to collaborate with Debian on openstack packaging?
20:17:52 <adam_g_> micahg: yes, this process is still evolving as openstack in debian is quite new.  we've already done some work to reduce the delta on a couple of components (nova, keystone) and hope to be doing more collaboration moving forward.  i believe we'll be discussing this with the debian developers working on this stuff at the upcoming openstack design summit in april
20:18:25 <micahg> adam_g_: any plans to eventually have some stuff uploaded to Debian first as the desktop team does?
20:18:42 <bdrung> (and then just sync it from Debian)
20:19:46 <adam_g_> micahg: i'd love to get to that point. like i said, this is all evolving. the debian packages currently target a much wider configuration base than we can currently support in ubuntu. we've also been scrambling to keep pace with changes upstream in our packaging, going into LTS, that we haven't had the cycles to focus on that for precise
20:20:31 <micahg> adam_g_: I'm just glad it's being considered and worked towards, this is great news, thanks
20:20:32 <adam_g_> there are some other complications as well, but collaboration is definitely high on the TODO moving forward
20:20:37 <Laney> do you think you could get to the stage where there is one openstack team working on the same packages?
20:20:42 <Laney> i.e. with a shared VCS
20:21:44 <adam_g_> Laney: there is a lot of work todo, but that is the goal, or at least get to a point where changes we make get forwarded to debian immediately, instaed of baking in ubuntu till someone gets a free moment to sync everythign up
20:22:39 <Laney> it is my experience that cross-distro packaging teams are an excellent way to work, fwiw
20:22:46 <Laney> no more questions from me :-)
20:22:48 <tumbleweed> adam_g_: on the MOTU part of your application. Do you feel that you are a part of the MOTU team? Do you hang out on IRC with MOTU or have an interest in archive-wide QA?
20:22:53 <Laney> (on the server part)
20:24:01 <adam_g_> tumbleweed: i do hang in #ubuntu-motu, and have had experience touching universe packages. id certainly love to get more exposure to the rest of the archive and distro through more involvement in MOTU
20:25:04 <tumbleweed> do you have any ideas on how we can grow MOTU? We're a pretty tiny team, for so many packages
20:25:53 <tumbleweed> excuse the impossible question :P
20:25:57 <bdrung> and some MOTU are absorbed by other teams (like me)
20:26:34 <adam_g_> i'd suggest trying to make the learning curve less steap, through continued improvement to documenation, online classes, blogs, etc.
20:26:46 <adam_g_> but perhaps thats true of all ubuntu development, and not just MOTU
20:27:31 <Laney> some people have all of their energy sucked up by annoying things like immense transitions for obscure programming languages that nobody uses :P
20:27:48 <tumbleweed> (some people say they choose that for themselves)
20:27:49 <micahg> well, with MOTU and core-dev specifically, you're dealing with a wide range of packaging and upstreams, so you can't really make the curve less steep, for other things like packagesets and PPU, we can certainly try to streamline things
20:27:58 <Laney> "because it's there"
20:28:28 * Sweetshark is shortly afk, phone. brb.
20:29:00 <Laney> Sweetshark: sorry, we'll get to you soon
20:29:11 <tumbleweed> ok, shall we wrap up the inquisition?
20:29:18 <adam_g_> micahg: my comment was more wrt ubuntu development and all of the great tools and processes that exist for making that kind of work easier. i sometimes feel like im finding out about an easter egg when i hear about tools like 'seeded-in-ubuntu' :)
20:30:00 <barry> adam_g_: i can sympathize :)
20:30:23 <Sweetshark> <- back
20:30:39 <tumbleweed> adam_g_: hopefully there are some more easter eggs for you in ubuntu-dev-tools & devscripts :)
20:31:02 <tumbleweed> ok, I'm not seeing anyone else jumping to ask questions
20:31:55 * Laney has none
20:31:56 <tumbleweed> #vote should adam_g be added to the ubuntu-server team?
20:31:56 <meetingology> Please vote on: should adam_g be added to the ubuntu-server team?
20:31:56 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:32:06 <tumbleweed> hopefully meetingology remembers the voters
20:32:07 <Laney> +1
20:32:08 <tumbleweed> +1
20:32:08 <meetingology> +1 received from tumbleweed
20:32:13 <Laney> :( it does :(
20:32:16 <tumbleweed> #voters bdrung tumbleweed Laney micahg cody-somerville barry stgraber
20:32:16 <meetingology> Current voters: Laney barry bdrung cody-somerville laney micahg stgraber tumbleweed
20:32:19 <Laney> +1
20:32:19 <meetingology> +1 received from Laney
20:32:21 <barry> +1
20:32:21 <meetingology> +1 received from barry
20:32:25 <bdrung> +1
20:32:25 <meetingology> +1 received from bdrung
20:32:26 <micahg> +1
20:32:26 <meetingology> +1 received from micahg
20:32:29 <stgraber> +1
20:32:29 <meetingology> +1 received from stgraber
20:32:46 <tumbleweed> #endvote
20:32:46 <meetingology> Voting ended on: should adam_g be added to the ubuntu-server team?
20:32:46 <meetingology> Votes for:6 Votes against:0 Abstentions:0
20:32:46 <meetingology> Motion carried
20:32:50 <micahg> umm, that should be ubuntu-server-dev :)
20:33:01 <bdrung> adam_g_: re easter eggs: do you know wrap-and-sort and suspicious-source?
20:33:02 <tumbleweed> yes, that :)
20:33:22 <tumbleweed> adam_g_: congratulations, good luck with it
20:33:34 <Laney> something like dpkg -L devscripts | grep usr/bin | shuf | head -10
20:34:07 <adam_g_> bdrung: not until now, but wish i did. wrap-and-sort would have saved me quite a bit of time recently
20:34:10 <tumbleweed> are we going straight on to a MOTU vote or any more qeustions?
20:34:10 <adam_g_> tumbleweed: thanks
20:34:31 <bdrung> no questions from me
20:34:37 <Laney> one second
20:35:15 <stgraber> I think I'm ready to vote for MOTU based on the answers given before (once Laney is ready)
20:35:42 <Laney> adam_g_: looking at https://launchpad.net/~gandelman-a/+uploaded-packages I don't see many uploads outside of the server set that we just voted on. Do you have any other Universe activity that's not reflected there?
20:35:59 <Laney> be that community stuff or uploads that aren't shown for whatever reason
20:37:25 <adam_g_> Laney: hmm perhaps i do not, though i thought i did. ive helped with MIRs for various python library's promotion *out of* universe, if that counts :P
20:37:50 <tumbleweed> pish :)
20:38:42 <Laney> thanks, that's all
20:38:59 <tumbleweed> right, voting
20:39:19 <tumbleweed> #vote Should adam_g join MOTU?
20:39:19 <meetingology> Please vote on: Should adam_g join MOTU?
20:39:19 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:40:43 <bdrung> +1
20:40:43 <meetingology> +1 received from bdrung
20:41:01 <tumbleweed> +0 From the questioning, I'm sure you have the skills, but I haven't seen the interest yet
20:41:01 <meetingology> +0 From the questioning, I'm sure you have the skills, but I haven't seen the interest yet received from tumbleweed
20:41:14 <stgraber> +0 [I'd like to see some more !server-package-set involvment and more interactions with the MOTU community]
20:41:14 <meetingology> +0 [I'd like to see some more !server-package-set involvment and more interactions with the MOTU community] received from stgraber
20:41:15 <Laney> +0 I don't question your technical skill, but I'd like to see some involvement with the community before giving a +1.
20:41:15 <meetingology> +0 I don't question your technical skill, but I'd like to see some involvement with the community before giving a +1. received from Laney
20:41:21 <micahg> +0 I think adam_g_ will make a fine MOTU, but would like to see some more work in that area
20:41:21 <meetingology> +0 I think adam_g_ will make a fine MOTU, but would like to see some more work in that area received from micahg
20:41:47 <barry> +1 i appreciated the dhpy2 transition you did and would like to see more stuff like that!
20:41:47 <meetingology> +1 i appreciated the dhpy2 transition you did and would like to see more stuff like that! received from barry
20:42:14 <tumbleweed> #endvote
20:42:14 <meetingology> Voting ended on: Should adam_g join MOTU?
20:42:14 <meetingology> Votes for:2 Votes against:0 Abstentions:4
20:42:14 <meetingology> Motion carried
20:42:39 <tumbleweed> gaah, I can't remember how this works. Is the motion really carried?
20:42:40 <micahg> meetingology: apparently needs some help deciding what a good vote is :)
20:42:40 <meetingology> micahg: Error: "apparently" is not a valid command.
20:42:44 <micahg> tumbleweed: no
20:42:48 <tumbleweed> right, I thought so
20:42:59 <adam_g_> lol
20:43:06 * Laney can't remember what the algorithm is
20:43:15 <tumbleweed> Laney: didn't you summarise it to the list?
20:43:28 <Laney> write once read none
20:44:23 <Laney> let's move on
20:44:24 <bdrung> the applicant need at least +4
20:44:40 <adam_g_> thanks all
20:44:43 * tumbleweed finds https://lists.ubuntu.com/archives/technical-board/2011-July/000956.html which was endorsed by the techboard
20:45:11 <stgraber> adam_g_: congrats for the ubuntu-server packageset and I'm sure we'll see you in a few months for MOTU
20:45:14 <tumbleweed> adam_g_: sorry, but we'll happily accept a reapplication from you with some uploads to wave at us
20:45:36 <adam_g_> sounds reasonable, thanks again
20:46:13 <tumbleweed> #topic PPU application for Bjoern Michaelsen
20:46:22 <Sweetshark> o/
20:46:22 <Sweetshark> Hi all, sorry for mixing it up on the agenda: I am only applying for PerPackageUploader rights for LibreOffice, not for a PackageSet. (I didnt want to mess with the agenda during the meeting to avoid confusion.)
20:46:24 <tumbleweed> does everyone still have time for this?
20:46:26 <Sweetshark> o/
20:46:29 <Sweetshark> Hi all, sorry for mixing it up on the agenda: I am only applying for PerPackageUploader rights for LibreOffice, not for a PackageSet. (I didnt want to mess with the agenda during the meeting to avoid confusion.)
20:46:39 <tumbleweed> Sweetshark: np
20:46:51 <barry> i'm good for one more
20:47:08 * tumbleweed is too
20:47:28 * bdrung is, but may starve. ;)
20:47:37 <tumbleweed> ok, let's hurry up then :)
20:47:47 <tumbleweed> Sweetshark: care to introduce your application?
20:47:51 <tumbleweed> #link https://wiki.ubuntu.com/BjoernMichaelsen/DeveloperApplication
20:47:51 <Sweetshark> You can see my application at
20:47:51 <Sweetshark> #link https://wiki.ubuntu.com/BjoernMichaelsen/DeveloperApplication
20:47:51 <Sweetshark> I am Bjoern Michaelsen and work on Canonicals Desktop team since February 2011 and was on Sun/Oracles OpenOffice.org team before.
20:47:56 <tumbleweed> ^5
20:48:03 <Sweetshark> With regard to direct Ubuntu contributions, I provided the packaging for the libreoffice source package for natty, oneiric and precise (and libreoffice-l10n in natty and oneiric -- its gone in precise). I also provided some of the backports, although luckily I am supported there since 3.5.X by ricotz now. I try to work as close as possible with _rene_ at Debian and thus sometimes contribute to Debians LibreOffice packaging too.
20:48:09 <Sweetshark> Some of the libreoffice packaging changes can be seen here: http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=shortlog;h=refs/heads/ubuntu-precise-3.5 (this is the branch for LibreOffice 3.5.X on precise).
20:48:14 <Sweetshark> I am applying for PerPackage rights to be able to get a small fix in when it is needed urgently and no sponsors are available. If possible at all, I would usually resort the letting someone else (pitti, seb128 or anyone else who cant hide fast enough) look over my upload anyway even with rights because of the size of the package.
20:48:37 <Sweetshark> (I had some time to prepare myself for this ;) )
20:49:38 <barry> Sweetshark: do you anticipate many long-term deltas between ubuntu and debian?
20:50:33 <Sweetshark> barry: I try to kill them as much as possible and not to introduce new ones.
20:50:56 <Laney> do you contribute directly to the main debian branch too?
20:51:57 <Sweetshark> barry: For precise, I freshly branched of the debian, and then rebased all changes on top of that anew (carefully checking if they are really needed anymore)
20:52:01 <Sweetshark> Laney: yes.
20:52:31 <bdrung> Sweetshark: why do the libo icons not look nice in precise?
20:52:39 <bdrung> (maybe offtopic)
20:52:57 <Sweetshark> Laney: although I always keep in touch with _rene_ when doing this, so that there are no unsuspected surprises for him.
20:53:42 <Laney> nice, good to see you guys working together
20:54:07 <Laney> So, I take it you didn't know anything about packaging before starting in this position?
20:54:07 <bdrung> yes, good to see that collaboration
20:54:17 <Laney> How would you say your competence is now?
20:56:09 <Sweetshark> bdrung: honestly, I havent looked to deep into that yet, we had too many big changes causing me to look at issues elsewhere.
20:57:48 <micahg> Sweetshark: are you familiar with library transitions in Ubuntu?
20:58:42 <bdrung> Sweetshark: are you always allowed to upload libreoffice once you have upload rights?
20:58:52 <Sweetshark> Laney: I wouldnt claim to be an expert with dpkg -- esp. since LibreOffice is "special" in some ways, so I might not know the canonical way to do this. But then again, LibreOffice is special so it is not that relevant for perpackage rights.
20:59:15 <Sweetshark> micahg: you mean like the multiarch transition?
20:59:31 <micahg> Sweetshark: no, like libssl
21:00:04 <Laney> I'm not asking how confident you are in general, but how you feel about handling the LO package
21:00:30 <Sweetshark> bdrung: no, I have to keep the release schedule in mind. And again for LibreOffice: buildtimes until the deadlines.
21:01:42 <bdrung> Sweetshark: would you be allowed to do an upload _today_?
21:04:04 <Sweetshark> Laney: I am confident with LibreOffice packaging. between LibreOffice 3.4/3.5 oneiric/precise, we (Ubuntu/Debian) switched from the old go-oo build system to directly using LibreOffice native buildsystem with migrating all patches over, so in a way I was one of the creator of this 'new' packaging.
21:06:04 <Sweetshark> bdrung: beta freeze, so not without approval from release team. And again: I need to add buildtimes (esp. for arm) to my calculations.
21:06:33 <bdrung> yes
21:06:52 <micahg> Sweetshark: if libssl were to bump its SONAME, would that affect libreoffice and how so
21:07:01 <bdrung> Sweetshark: how long does a build take on a recent quad-core machine?
21:08:10 <Sweetshark> micahg: Im sorry, I dont know what you are aiming at.
21:09:07 <Sweetshark> bdrung: on my notebook (i7Quad, 16GB RAM) it takes 2:10 minutes with l10n and ccache. ~3:50 without ccache.
21:09:22 <micahg> Sweetshark: if there were a need for another libssl transition, would that affect libreoffice and how so?
21:10:57 <Sweetshark> bdrung: a upstream developer build (no l10n, no mozilla, no binfilter) takes ~1:30h without ccache, 5min with hot ccache on a reasonable fast machine.
21:12:42 <Sweetshark> micahg: Well, I guess I would have to check if ssl is part of the UNO-ABI. If so, that would have wideranging implications as it isnt allowed to get incompatible. If so, the old libssl would need to stick around.
21:14:13 <tumbleweed> Sweetshark: are you only after PPU rights for libreoffice itself, or any particular related source packages too?
21:14:41 <Sweetshark> (well UNO is allowed to get incompatible with LibreOffice 4.0, but we are not going for that upstream yet)
21:14:49 <Sweetshark> tumbleweed: just libreoffice for now
21:14:59 <micahg> Sweetshark: what if the UNO-ABI was compatible
21:15:16 <Sweetshark> micahg: extensions wouldnt work
21:16:27 <Sweetshark> micahg: (that is binary C++ extensions, which to be honest is a rare creed)
21:17:46 <tumbleweed> Sweetshark: it seems like recently your sponsored libreoffice uploads have been waved through with minimal review, as your sponsors clearly trust you. Are you still getting any useful feedback from them?
21:18:38 <Sweetshark> tumbleweed: If I ask for it yes. Otherwise not so much.
21:20:44 <Laney> Sweetshark: I'm looking at https://launchpad.net/ubuntu/+source/libreoffice/1:3.5.0-1ubuntu2
21:21:07 <Laney> can you talk us through the reasons for the first changelog item there - the breaks/replaces - why they were required
21:21:18 <Laney> was the previous package upload broken?
21:22:17 <Sweetshark> Laney: basically the debianized way to split libreoffice here is a making things a bit tricky.
21:23:27 <Sweetshark> we have a binary in libreoffice-core called unopkg.bin, which usually is called from a very thin script-wrapper called unopkg which was in libreoffice-common.
21:24:27 <Laney> so you forgot to add the breaks/replaces when it moved package?
21:24:36 <Sweetshark> as libreoffice-core depends on libreoffice-common one cant depend from libreoffice-common on -core.
21:25:40 <tumbleweed> ok, we need to wrap this up and vote, before micahg has to run off or bdrung eats his keyboard
21:25:40 <Laney> sorry, we're going to be out of time
21:25:57 <tumbleweed> #vote Should we grant Sweetshark PPU rights for libreoffice?
21:25:57 <meetingology> Please vote on: Should we grant Sweetshark PPU rights for libreoffice?
21:25:57 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
21:26:33 <bdrung> +1
21:26:33 <meetingology> +1 received from bdrung
21:26:52 <stgraber> +0
21:26:52 <meetingology> +0 received from stgraber
21:27:00 <barry> +1
21:27:00 <meetingology> +1 received from barry
21:27:45 <Sweetshark> however the unopkg script was called from triggers, thus leading to situations were the script was there, but the binary was missing. Thus the script was moved to -core too. And yes, the replaces/breaks where needed for that. I would need to recheck, if I missed them in that upload or if it was in the same upload.
21:28:45 <micahg> -1
21:28:45 <meetingology> -1 received from micahg
21:28:57 <micahg> I'll have to provide my reasoning later
21:29:11 <stgraber> tumbleweed, Laney: ^
21:29:44 <tumbleweed> +0 I understand that libreoffice is a complex package and so is hard to get review for. But I don't want to grant this, with only a single endorsement whene there are a fair number of people worried about recent issues with the package
21:29:44 <meetingology> +0 I understand that libreoffice is a complex package and so is hard to get review for. But I don't want to grant this, with only a single endorsement whene there are a fair number of people worried about recent issues with the package received from tumbleweed
21:30:05 <Sweetshark> stgraber: doesnt really matter though anyway.
21:30:19 <Laney> +1 I have reservations about your answers to the question about transitions and the breaks/replaces upload that I pointed out, and I would urge you to seek clarification on that, but I don't want to block your application based on it.
21:30:19 <meetingology> +1 I have reservations about your answers to the question about transitions and the breaks/replaces upload that I pointed out, and I would urge you to seek clarification on that, but I don't want to block your application based on it. received from Laney
21:31:18 <tumbleweed> #endvote
21:31:18 <meetingology> Voting ended on: Should we grant Sweetshark PPU rights for libreoffice?
21:31:18 <meetingology> Votes for:3 Votes against:1 Abstentions:2
21:31:18 <meetingology> Motion carried
21:31:20 <Laney> this is a package that benefits a lot from peer review
21:32:07 <Sweetshark> Laney: right, however everytime I need it, everyone is running away ;
21:32:10 <Sweetshark> ;)
21:32:17 <Laney> hah, indeed
21:32:17 <tumbleweed> Sweetshark: I feel that you should be able to get more endorsements to a developer application for such a core package
21:32:53 <Sweetshark> tumbleweed: well, pitti was almost the only sponsor.
21:33:08 <tumbleweed> Sweetshark: yes, the curse of a massive, complicated package
21:33:23 <Sweetshark> didrocks did one upload, but I dont thing there was much review there.
21:33:33 <tumbleweed> yeah, I see that
21:34:13 <tumbleweed> anyway
21:34:32 <tumbleweed> I'm sorry that we can't grant this application now, but we can dicuss this afterwards
21:34:35 <tumbleweed> #topic AOB?
21:34:49 <Laney> yes, let's please limit to two applicants per meeting
21:34:53 <Sweetshark> bryceh got involved in one, but that upload was broken by an intermediate kdelibs upload. (It was that upload that was broken by it, the package that was in precise at that time was also ftbfs because of the kdelibs update.
21:34:58 <Laney> and update the agenda page to reflect this
21:35:05 <tumbleweed> Laney: +1
21:35:05 <bdrung> i worked on eclipse and know why i would try to escape a libreoffice review ;)
21:35:30 <stgraber> Laney: +1
21:35:44 <tumbleweed> Laney: care to take an action on that?
21:35:58 <Laney> ok
21:36:04 <bdrung> Laney: +1
21:36:32 <tumbleweed> #action Laney to document that we're only doing <=2 applicants per meeting
21:36:32 * meetingology Laney to document that we're only doing <=2 applicants per meeting
21:36:40 <tumbleweed> next chair?
21:36:50 <Laney> cody again :P
21:36:53 <Laney> or me i think
21:36:54 <tumbleweed> lol
21:37:13 <tumbleweed> laney is next on https://launchpad.net/~developer-membership-board/+members
21:37:20 <bdrung> (with round robin)
21:37:29 <Laney> i was referring to the fact that cody skipped an entire round
21:37:50 <bdrung> i don't mind giving him another chance ;)
21:37:55 <tumbleweed> works for me. keep you as standby?
21:37:59 <Laney> yep
21:38:05 <tumbleweed> right, I propose bed time
21:38:37 <tumbleweed> #endmeeting