15:00:06 <skaet> #startmeeting
15:00:06 <meetingology> Meeting started Fri Mar 23 15:00:06 2012 UTC.  The chair is skaet. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00:06 <meetingology> 
15:00:06 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:00:12 <skaet> [TOPIC] Release general overview - skaet
15:00:12 <skaet> Please remember to .. when you're done, and o/ if you want us to pause. :)
15:00:12 <skaet> Agenda can be found:
15:00:12 <skaet> #link https://wiki.ubuntu.com/ReleaseTeam/Meeting/2012-03-23
15:00:12 <skaet> Individual team status links will be added to it from:
15:00:13 <skaet> #link https://lists.ubuntu.com/archives/ubuntu-release/2012-March/thread.html
15:00:16 <skaet> .
15:00:18 <skaet> We're now in Beta 2 Freeze, and the archive is frozen, so all changes will need to be reviewed by the release team.   Changes to the unseeded universe can continue to go in, but changes to seeded packages will need review.
15:00:22 <skaet> #ubuntu-release if questions, please.
15:00:24 <skaet> .
15:00:27 <skaet> For the first time we'll be using precise-proposed as a staging area while we're in Freeze.   unity is currently blazing the trail for us there using this new capability.
15:00:29 <skaet> .
15:00:31 <skaet> Schedule is at:
15:00:34 <skaet> #link https://wiki.ubuntu.com/PrecisePangolin/ReleaseSchedule
15:00:35 <skaet> #link http://fridge.ubuntu.com/calendars/ubuntu-release-calendar/
15:00:38 <skaet> .
15:00:39 <skaet> Upcoming Dates:
15:00:41 <skaet> � 2012/03/24 - Framework for Beta 2 release notes available for input
15:00:45 <skaet> � 2012/03/29 - DocumentationStringFreeze for ubuntu-doc and server-guide at 2100 UTC
15:00:47 <skaet> � 2012/03/29 - Beta 2 Release
15:00:50 <skaet> .
15:00:51 <skaet> Bugs committed to be fixed by the engineering teams can be found:
15:00:54 <skaet> #link http://reports.qa.ubuntu.com/reports/kernel-bugs/reports/rls-p-tracking-bugs.html
15:00:55 <skaet> Bugs that you would like the engineering teams to consider for fixing, should be assigned to specific teams, so they can be found.
15:00:58 <skaet> .
15:01:00 <skaet> Individual Team Statuses Received by 1500 UTC:
15:01:03 <skaet> Hardware Certification - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001015.html - brendand
15:01:05 <skaet> Quality Assurance -  https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001019.html - jibel
15:01:08 <skaet> Security team  -  https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001016.html- mdeslaur
15:01:12 <skaet> Kernel team - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001000.html - ogasawara
15:01:15 <skaet> Foundations -https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001024.html -  cjwatson
15:01:18 <skaet> Server -https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001020.html - arosales
15:01:19 <skaet> Linaro -  https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001011.html - fabo
15:01:21 <skaet> Ubuntu One - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001006.html-  joshuahoover
15:01:23 <skaet> Desktop Team - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001012.html - pitti
15:01:25 <skaet> Unity Framework Team - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001022.html - dbarth
15:01:28 <skaet> Unity Services and Settings - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001027.html - Cimi
15:01:31 <skaet> Kubuntu - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001025.html-  Riddell
15:01:34 <skaet> Edubuntu - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001008.html- stgraber or highvoltage
15:01:36 <skaet> Xubuntu - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001014.html - astraljava
15:01:39 <skaet> Ubuntu Studio - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001017.html - scott-work
15:01:41 <skaet> Lubuntu  - https://lists.ubuntu.com/archives/ubuntu-release/2012-March/001021.html - gilir
15:01:46 <skaet> Mythbuntu - no update received - superm1
15:01:47 <skaet> .
15:01:50 <skaet> [TOPIC] Comments, Question and Answer Session
15:01:59 <Riddell> hi
15:02:26 <mdeslaur> hello
15:02:48 <arosales> hello
15:03:14 <Riddell> \o
15:03:31 <skaet> hello everyone.   :)   was just about to ask for show of hands,  but Riddell's started us off.   :)
15:03:43 <skaet> go Riddell
15:04:02 <Riddell> that was deliberate as a starting question: how's everyone feeling about beta 2? any worries or things to look out for?
15:04:09 <highvoltage> o/
15:04:23 <pitti> I'll feel much better once that unity is in, and works :)
15:04:28 <highvoltage> (just waving hi, not noting any worries)
15:04:35 <Riddell> I think Kubuntu is good from smoketesting today but I still don't have precise images working on my arm board (of ubuntu desktop never mind kubuntu)
15:05:14 <tumbleweed> hi, no mail from MOTU this week, nothing big I'm aware of
15:05:14 <pitti> I'm not aware of true blockers in ubuntu desktop yet
15:05:27 <pitti> (again, that's pre-unity landing :-P *knocking on wood*)
15:05:42 <Riddell> pitti: what about wallpapers?
15:06:07 <pitti> Riddell: oh, we still have the old one? /me puts that on his list
15:06:17 <arosales> The MIR and security team have been doing a great job on plowing through the MIRs for server, that was one of the worrisome points.
15:06:39 <Riddell> pitti: I don't know but I heard rumours your artists haven't got round to either getting the precise ones in or the FFe needed for them
15:07:04 <Cimi> I am on wallpapers
15:07:12 <Riddell> pitti: NBS and component mismatches all good?
15:07:15 <Cimi> doing reviews this morning
15:07:25 <Riddell> Cimi: got a FFe?
15:07:36 <pitti> Riddell: mopping up the last things; kenvandine is on fixing telepathy-qt4, to get back beer on precise_probs
15:07:37 <Cimi> Riddell, not yet, we don't have the default set either
15:07:50 <Cimi> Riddell, we are targeting at beginning next week
15:07:54 <Riddell> pitti: oh interesting, is he talking to shadeslayer about telepathy-qt4?
15:08:07 <Riddell> Cimi: beginning next week is beta freeze
15:08:07 * pitti relays that
15:08:25 <skaet> Riddell, Cimi - we're beta frozen now.
15:08:27 <Cimi> Riddell, we are not ready for them today
15:08:28 <skaet> this is pretty late
15:08:42 <Cimi> skaet, they are published in the bugreport
15:08:50 <Cimi> skaet, but we need higher resolution
15:08:57 <Cimi> skaet, and few of them might get removed
15:08:59 <pitti> we can do Monday under the condition that the size doesn't grow noticeably
15:09:12 <pitti> if it's bigger than the current one and overflows images, we have to do it post-beta
15:09:16 <skaet> Cimi,  is what's up there now going to be ok for ubuntu-docs to do their screenshots from?
15:09:30 <pitti> with "noticeably" == <= +200 kB or so
15:09:55 <Cimi> pitti, we'll probably have less wallpapers than ubuntu wallpapers in 11.10 package
15:10:08 <pitti> Cimi: sounds promising :)
15:10:28 <Cimi> ;-)
15:10:58 <arosales> o/
15:11:16 <skaet> Cimi,  what about the screen shots?
15:11:43 <Cimi> skaet, screen shots are taken against default wallpapers, isn't it?
15:11:51 <Cimi> *wallpaper
15:11:51 <skaet> Cimi,  yes
15:12:00 <cjwatson> I thought we'd been told the default wallpaper was changing a bit too
15:12:10 <Riddell> Cimi: will the scrollbar and slider behaviour be changing in 12.04?
15:12:12 <Cimi> skaet, the default wallpaper won't change that much
15:12:18 <cjwatson> how about it not change at all?
15:12:36 <Cimi> Riddell, you mean the left-click thing?
15:12:40 <cjwatson> then it won't affect screenshots
15:12:45 <Riddell> Cimi: I guess so yes
15:12:54 <Cimi> cjwatson, it changed so subtly, you won't notice
15:12:54 <pitti> if just the non-default ones change, it's not crucial to press into b2
15:13:07 <pitti> same for the subtle default change, I figure
15:13:20 <cjwatson> Cimi: I love being told that kind of thing ... actually not really
15:13:29 <Cimi> all the process of the LTS is to taking up 6 cycles and refining, the wallpaper is part of this process and is a refinements of the last
15:13:46 <cjwatson> if it's so subtle you won't notice, we could skip any screenshot risk by not taking that change
15:14:09 <Riddell> Cimi: are your processes aligned to the ubuntu release cycle including freezes?
15:14:30 <Cimi> Riddell, not really, but I am personally aware of them
15:14:57 <Riddell> is there someone aware of them or is that a team failure?
15:15:07 <Cimi> Riddell, I've asked the final default wallpaper, I'll look at it in a minute
15:15:35 <Cimi> Riddell, I'm not speaking of the system team now, I am dealing of a designer thing
15:15:43 <Riddell> skaet: maybe an action to ensure the design team is aware of the cycle they are working to?
15:16:01 <skaet> Riddell,   yes,  I was making a note of that.
15:16:14 <Cimi> systems team is doing great :-) and it's not that designers are doing bad, just that the selection and all the contest took more time
15:16:28 <Riddell> Cimi: what is the systems team?
15:16:42 <Cimi> Riddell, the team I am representing now
15:16:58 <Cimi> Riddell, I am an engineer of Systems but I work in London with designers
15:17:02 <skaet> #action - review design schedules, and dx system team release shedules against Ubuntu release schedule at UDS for Q
15:17:02 * meetingology - review design schedules, and dx system team release shedules against Ubuntu release schedule at UDS for Q
15:17:09 <Riddell> Cimi: isn't that Unity services and settings?
15:17:36 <Cimi> Riddell, it is
15:17:37 <skaet> Riddell,   yes, its the systems aspect.
15:17:59 <Riddell> "systems" seems awfae generic sounding, that's why I'm getting confused
15:18:09 <Riddell> anyway more important things to discuss I expect :)
15:18:21 <Cimi> Riddell, I will make sure designers will respect release schedule more firmly
15:18:28 <Cimi> no worries, skaet as well
15:18:37 <Cimi> I apologize for the issues if there were any
15:19:01 <cjwatson> mm, I never knew what Systems meant myself :)
15:19:27 <cjwatson> (maybe that should be "[DX Systems] Release Meeting 2012-03-30", since most of us aren't DX?)
15:20:03 <skaet> ..?
15:20:14 <cjwatson> yah, sorry
15:20:17 <Riddell> ..
15:20:24 <skaet> :)
15:20:27 <skaet> A documentation freeze exception (and adjustment of the translations deadlines) was made for ubuntu-docs and the server guide - to give them more time to get the content created.   Anyone who is able to help them with parts,  would be welcome.   Details of what needs to be done can be found:
15:20:27 <skaet> #link http://pad.ubuntu.com/ubuntu-docs-todo (contact jbicha if questions)
15:20:27 <skaet> #link https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/UbuntuServerGuide (contact pmathulis if questions)
15:21:01 <skaet> it was relevant to the prior point, of impact of some of the changes being discussed,  so seemed appropriate to insert here.
15:21:02 <skaet> ..
15:21:03 <Cimi> give me few mins to check the final 12.04 default wallpaper
15:21:10 <skaet> Cimi,  sure.
15:21:25 <skaet> arosales,  go
15:21:29 <arosales> Just a coment
15:21:33 <arosales> cjwatson: Riddell: Thanks for your help on bug 948437 and bug 948438
15:21:36 <ubottu> Launchpad bug 948437 in chef (Ubuntu Precise) "Remove unsupported release from Precise" [High,Fix released] https://launchpad.net/bugs/948437
15:21:37 <ubottu> Launchpad bug 948438 in ohai (Ubuntu Precise) "Remove unsupported release from Precise" [High,Fix released] https://launchpad.net/bugs/948438
15:21:45 <arosales> ..
15:21:53 <skaet> :)
15:21:54 <Riddell> all in a day's work from your friendly archive admin team
15:22:16 <skaet> o/
15:22:36 <Cimi> Riddell, for the left-click thing on the scale/scrollbar, it will get in 12.04 only if it will get merged in upstream gtk
15:22:41 <Cimi> Riddell, we will not distropatch gtk+
15:22:47 <Cimi> seb128 can confirm
15:23:03 <Riddell> Cimi: and any plans for Qt as used by various Ubuntu Desktop things?
15:23:20 <Cimi> Riddell, no plans for 12.04 I'd say
15:23:33 <Cimi> Riddell, but I doubt the patch will be difficult to do
15:23:43 <Riddell> mm, inconsistent scrollbar behavious between applications seems nasty
15:24:01 <Cimi> Riddell, what are you referring to?
15:24:03 <Riddell> patches are always harder than expectred :)
15:24:16 <Cimi> Riddell, overlay scrollbars or left-click jump-to behavior?
15:24:25 <Riddell> Cimi: if you're using ubuntu desktop and gtk changes then you have different behaviour between say firefox and ubuntu one
15:24:28 <Cimi> Riddell, overlay scrollbars for qt are not in the plans
15:24:43 <Riddell> dunno whatever
15:24:48 <Cimi> ah ok, you're talking abut overlay scrollbars now, and yes there are no plans now
15:25:00 <Cimi> and I think we should keep the conversation apart from this meeting
15:25:06 <Cimi> but thanks for raising the issue
15:25:08 <Riddell> ..
15:25:18 <skaet> brendand, any questions about apw's summary?  is there an ETA when some of that retesting they're asking for can happen?   also is  https://bugs.launchpad.net/hw-labs/+bug/834731 still a blocker since it can't be reproduced?
15:25:20 <ubottu> Launchpad bug 834731 in debian-installer (Ubuntu) "Dell PowerEdge R810 fails to mount file system at /dev/sda1" [Medium,Incomplete]
15:26:02 <skaet> ..
15:26:03 <brendand> skaet, no - i will discuss taking the tag off it with ara
15:26:18 <Cimi> skaet, Riddell I received the new final 12.04 default wallpaper
15:26:19 <brendand> where is apw's summary?
15:26:33 <skaet> brendand,   he posted it to ubuntu-release mail list
15:26:39 <Riddell> Cimi: tell it to the desktop team :)
15:26:41 <Cimi> it won't affect screenshots with apps used in the ubuntu electronic manual on the desktop
15:27:07 <skaet> Cimi, thats good news, thanks.
15:27:10 <Cimi> maybe it should be used for the default screenshot in the ubuntu webpage once 12.04 is released, for sake of consistency
15:27:22 <brendand> skaet, ah ok. good news is that bug 714862 is fix released now and tested
15:27:24 <Cimi> but I don't think we are dealing with something that affects focs
15:27:24 <ubottu> Launchpad bug 714862 in Linux "Atheros AR3011 cannot be turned up/is not recognized." [Medium,Confirmed] https://launchpad.net/bugs/714862
15:27:52 <skaet> [ACTION] skaet discuss screenshots for ubuntu web page with web team and Cimi.
15:27:52 * meetingology skaet discuss screenshots for ubuntu web page with web team and Cimi.
15:29:33 <skaet> brendand,  Can the ones looking for retesting get scheduled for early next week/later today?
15:30:17 <brendand> skaet, probably. i'll check and let you know
15:30:22 <skaet> its probably too late for Beta 2 at this point, but getting them in as soon as possible after the Beta2 release seems prudent.
15:30:25 <skaet> Thanks.
15:30:43 <skaet> ..
15:30:55 * skaet looks around for other o/ before going on to her next one ;)
15:31:30 <Riddell> skaet: you're next :)
15:31:40 <skaet> :)
15:31:43 <skaet> dbarth, ogra_ - any estimates on when compiz will pick up the OpenGLES?
15:31:43 <skaet> ..
15:32:16 <skaet> fabo, ^  probably as well.  ;)
15:32:17 <ogra_> skaet, i uploaded the gles driver today 8sits in NEW and waits for an archive admin to letz it into multiverse)
15:32:35 <ogra_> once thats in i'll throw the compiz patch into our package
15:32:54 <ogra_> (patch is ready but without driver we couldnt test yet)
15:33:11 <ogra_> (it works in the luinaro images though, so i dont expect actual issues)
15:33:24 <ogra_> skaet, i would say right after beta
15:33:44 <ogra_> (i dont want to risk beta image stability for it)
15:33:45 <ogra_> ..
15:33:51 <skaet> ogra_,  thanks,  :)  That's what I was trying to figure out.
15:33:59 <skaet> ..
15:34:34 <skaet> jibel,  any preliminary feedback on the Beta 2 images that started going up earlier today?
15:35:47 <jibel> from a QA perspective and the testing we did, B2 is in a rather good shape. The installer sprint helped a lot
15:36:07 <jibel> But I'm prudent, Unity never land without a bunch of surprises. So we'll know the real status of 12.04 once it's in.
15:36:32 * skaet nods
15:36:59 <jibel> pitti, any ETA for a fix for bug 916291? It is now blocking oneric main and universe testing
15:37:01 <ubottu> Launchpad bug 916291 in libreoffice (Ubuntu Precise) "failed to upgrade from Oneiric to Precise: ERROR: Cannot determine language! - exit status 134" [Critical,Triaged] https://launchpad.net/bugs/916291
15:37:11 <jibel> upgrade testing I mean
15:37:21 <pitti> jibel: we actually believed it to be fixed already
15:37:35 <pitti> so, as we currently didn't debug yet what's causing it, still a couple of days
15:37:41 <pitti> which will unfortunately mean post-b2 :(
15:37:52 <jibel> ok, thanks
15:39:29 <skaet> .. I think,  next question/comment?
15:40:38 <dbarth> ogra_: great news
15:40:40 <skaet> scott_work, astraljava, highvoltage, Riddell - any FFE's being waited on for your images?
15:40:53 <Riddell> not that I know of
15:41:09 <highvoltage> skaet: nope
15:41:11 * skaet puts ticky mark in the Kubuntu column. :)
15:41:24 <highvoltage> (stgraber did a good job of poking me all the time to get things in on time)
15:41:26 * skaet ticky marks Edubuntu.   :)
15:41:41 <Riddell> highvoltage: teachers pet!
15:41:51 <highvoltage> hie hie
15:42:09 <skaet> lol
15:43:01 <skaet> any other FFE's  that folks want to see in Beta2 but haven't been commented on?
15:43:45 <scott-work> skaet: no FFe's that i am aware of
15:44:04 <scott-work> i believe all we had are already completed
15:44:39 <skaet> thanks scott-work.
15:45:33 <skaet> also,  thanks tumbleweed for the update on Universe last week,  attached it to the minutes from last week.  :)
15:45:43 <scott-work> not sure about xubuntu, i asked in channel and astral.java is away from computer at the moment (who is here for xubuntu)
15:46:12 <skaet> scott-work, he was here at the start of the meeting, so something must have come up. :/
15:46:22 <ScottK> BTW, there was a volunteer to test powerpc images for Xubuntu on (IIRC) the QA list today.
15:46:58 <Riddell> volunteers to test the kubuntu images on arm welcome
15:47:05 <scott-work> skaet: i think he was on a tram with a laptop and low battery
15:47:41 <skaet> ScottK, interesting,  that's not one on Xubuntu's manifest for this release.
15:47:54 <ScottK> Yes.  They specifically asked if it could be added back.
15:48:03 <ScottK> IIRC it was just dropped due to lack of testers.
15:48:25 <skaet> pitti, cjwatson,  ^ thoughts?
15:49:02 <pitti> question for xubuntu really; if someone wants them and can test them, sure
15:49:24 <pitti> we should just keep in mind that adding a powerpc image quadruples image build time
15:49:38 <ScottK> https://lists.ubuntu.com/archives/ubuntu-qa/2012-March/002054.html
15:49:42 <pitti> in case they need fast turnarounds for bug fixes
15:49:58 <pitti> but that's not a big blocker, of course
15:50:18 <ScottK> skaet: I'm not sure there are Xubuntu people active on that list.  Could you follow up with them since they aren't here?
15:50:24 <skaet> I'll follow up with Xubuntu team offline.
15:50:25 <skaet> :)
15:50:43 <ScottK> Great.
15:50:57 * skaet sees ScottK is faster at typing than she is.  :)
15:50:57 <cjwatson> the new-powerpc-buildd RT looks days away from completion
15:50:59 <cjwatson> ...
15:51:26 <skaet> ..
15:51:35 <skaet> anything else before we wrap up?
15:52:05 <Daviey> Things look surprisingly good!
15:52:28 <skaet> Thanks for your participation, brendand, jibel, mdeslaur, cjwatson, dbarth, Daviey, arosales,  fabo, pitti, Cimi, Riddell, stgraber, highvoltage, ogra_, tumbleweed
15:52:33 <skaet> #endmeeting