15:00:57 <NCommander> #startmeeting
15:00:57 <meetingology> Meeting started Thu Feb  9 15:00:57 2012 UTC.  The chair is NCommander. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00:57 <meetingology> 
15:00:57 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:01:14 * davidm waves
15:01:20 <dannf> hey
15:01:20 <ogra_> wow, thats timing :)
15:01:24 <NCommander> [topic] https://wiki.ubuntu.com/ARM/Meeting/2012/20120209
15:01:51 <NCommander> [topic] Action Items from last meeting
15:01:58 <NCommander> [topic] janimo to look into LibO
15:02:02 <ogra_> lots ;:)
15:02:09 <janimo> hi
15:02:10 * NCommander looks for mercy on janimo's soul
15:02:22 <ogra_> NCommander, he volunteered !
15:02:28 <janimo> indeed I did
15:02:29 <NCommander> dd if=/dev/mercy of=/dev/janimo/soul
15:02:30 <mahmoh> hi
15:02:33 <janimo> I do not (yet) regret it
15:02:50 <ogra_> must have to do with his transylvanian inheritance :)
15:02:50 <NCommander> janimo: yet being the operative word here
15:03:39 <janimo> true. I am looking at this now on the panda. If you'll see me curse these days, it's because I've been where NCommander has been before
15:03:56 * NCommander needs a t-shirt
15:04:11 * ogra_ doesnt want to go there ... evar !
15:04:18 <NCommander> "I braved the depths of hell^W Libreoffice and all I got was this lousy t-shirt"
15:04:39 <ogra_> though, mono is broken too
15:04:44 * ogra_ hides
15:04:47 <NCommander> [action] ogra_ to debug mono
15:04:47 * meetingology ogra_ to debug mono
15:04:49 <NCommander> Ok
15:04:50 <NCommander> done
15:04:51 <ogra_> lol
15:05:08 * ogra_ looks for that rock and brick he collected before
15:05:21 <NCommander> janimo: anything else to report or can I move on?
15:05:27 <janimo> no really?mono broken on arm? impossible, I hear a company bases it's business on it not being broken on arm. You are all lying
15:05:39 <ogra_> lol
15:05:42 <janimo> NCommander, nope I hope I'll make progress till next meeting
15:05:50 <janimo> but I ave started on it
15:05:51 * NCommander thinks we've lost janimo to the madness already
15:06:02 <ogra_> thats the winter
15:06:17 <NCommander> [topic] dannf to tidy up a kernel package for armada
15:06:19 <ogra_> being locked in at -20°C does weird things to you
15:06:38 <NCommander> ogra_: I lived in a mountian town like that. I'm still perfectly sane
15:06:45 <ogra_> LOL
15:06:49 <ogra_> LOLOLOLOL
15:06:54 <dannf> NCommander: done afaik
15:07:00 * ogra_ cleans coffee from his kbd
15:07:17 <NCommander> dannf: indeed, we're working on havinga kernel today (to be reported on later)
15:07:29 * GrueMaster had coffee shoot up his nose, laughing so hard.
15:07:52 <NCommander> ogra_: GrueMaster oh you guys suck
15:08:03 <GrueMaster> :D
15:08:03 <NCommander> [topic] infinity to pull said kernel package into d-i
15:08:17 <ogra_> is infinity even here ?
15:08:33 <janimo> ogra_, I heard he planned on snorting coke a few hours ago
15:08:37 <NCommander> No, but I thinkthis is a c/ogivenwestilldon't have an uploadedkernel
15:08:38 <ogra_> yeah
15:08:42 * NCommander smacks his spacebar
15:09:18 <theadmin> Hey wtf! I thought meeting starts at 20:00 UTC >.<
15:09:27 <theadmin> No fair I sezzit
15:09:45 <ogra_> the ARM meeting never ever started at 20UTC
15:10:16 <NCommander> We'll be having the usual IRC meeting on #ubuntu-meeting, on
15:10:16 <NCommander> Thursday 2011-02-09 at 15:00 UTC.
15:10:41 * NCommander would be very happy if the meeting was at 20:00 UTC but :-P
15:10:51 <NCommander> [topic] janimo or GrueMaster to test the mx5 kernel from jcrigby
15:10:54 * ogra_ wouldnt
15:11:13 <GrueMaster> Done.  Latest images have the new mx5 kernel
15:11:24 <theadmin> Either I'm confusing something or... Well I'm here for the first time, buuut: http://i.imm.io/gbSI.png
15:11:41 <NCommander> [topic] Standing Items
15:11:49 <GrueMaster> Still fails on START-R rev board.  USB issues.
15:12:16 <NCommander> theadmin: wrong meeting. This is the ARM development team meeting, not IRC council
15:12:35 <theadmin> NCommander: Ah, pardon me then. ARM is cool, I'll listen in if you don't mind?
15:12:38 <janimo> I tested the kernel it was ok, people uploaded it then
15:12:51 <NCommander> [topic] http://status.ubuntu.com/ubuntu-precise/ubuntu-arm.html
15:12:56 * janimo answered late on previous topic
15:13:03 <NCommander> Well
15:13:05 <NCommander> ...
15:13:18 <NCommander> The items are increasing
15:13:28 <NCommander> I think we fail
15:13:40 <ogra_> huh ?
15:13:43 * GrueMaster is too sleepy to comment on futility.
15:13:45 <ogra_> we look better than ever
15:14:10 <ogra_> slightly below trend (if it would be in the right angle)
15:14:12 <NCommander> ogra_: we're supposed to close items, not add half-a-million new closed items
15:14:28 <ogra_> nothing changed over the last week
15:14:29 <NCommander> THATS NOT HOW WE'RE SUPPOSED TO GET ON THE TRENDLINE
15:14:32 * NCommander screams
15:14:36 * ogra_ wonmders what you are referring to=
15:14:50 <NCommander> ogra_: madness
15:14:58 <NCommander> [topic] ARM Server Status (NCommander)
15:15:00 <ogra_> there were no items added
15:15:03 <NCommander> So, I've got news!
15:15:09 <theadmin> Can anyone change topic or what...
15:15:12 <theadmin> [topic] tests
15:15:17 <theadmin> Guess not :D
15:15:25 <NCommander> I saved a bunch of money changing my insurance!
15:15:26 <theadmin> Sorry, getting used to things
15:15:36 <ogra_> theadmin, please dont interfere with the meeting
15:15:39 <NCommander> But I also have ARM server news
15:15:52 <theadmin> ogra_: Understood.
15:15:53 <NCommander> armadaxp finally has a usable kernel git tree
15:16:00 <ogra_> theadmin, NCommander is the meeting chairt, only the chair can change topics and we try to keep the meeting short
15:16:14 <janimo> NCommander, great
15:16:21 <ogra_> yay
15:16:38 <NCommander> Using my gitified marvell patches, cooloney made them less crack, then we ported the Marvell sauce onto the oneiric tree
15:16:38 <rbasak> \o/
15:16:50 <NCommander> So we went from 3.0.15->3.0.17 with Marvell
15:17:04 <NCommander> We'll now track oneiric-updates, so we'll have security and updates for Armada until oneiric goes EOL
15:17:06 <ogra_> wow, two micro versions !
15:17:10 <ogra_> enormous
15:17:26 <ogra_> :P
15:17:47 <NCommander> ogra_: it wasn't a small job, the tree we got was based off an ubuntu tree of unknown origin, which required a ton of patch sorting and fun
15:17:48 <rbasak> Are there any plans to bring it up to precise?
15:18:11 <rbasak> Or will it stay based on oneiric indefinitely?
15:18:14 <NCommander> rbasak: Marvell has been told that weneed a 3.2 kernel. We won't be doing the work to port it
15:18:28 <rbasak> OK, thanks
15:18:43 <NCommander> rbasak: the armadaxp kernel will go into precise, its simply tracking oneiric since there tree is on the same major as oneiric's
15:18:53 <rbasak> Right
15:19:57 <NCommander> Unlessa 3.2 kernel magically materializes before release, armada xp will be a universe supported flavor
15:20:23 <ogra_> even though the kernel package will live somewhere else :)
15:20:26 <NCommander> infinity and I are making the necessary demonic sacirifices to get d-i to work properly like that with netboot images
15:20:37 <NCommander> ogra_: no, the kernel going in universe, we decided to fix d-i
15:20:38 <ogra_> NCommander, the kernel will go to main
15:20:47 <ogra_> we have approval and all
15:20:50 <NCommander> we did?
15:20:52 <NCommander> *do
15:20:54 <NCommander> Damn
15:20:54 <ogra_> no d-i hacjking required
15:21:02 <NCommander> we weren't goingto hijack d-i
15:21:05 <ogra_> unless that changed since tuesday
15:21:13 <NCommander> d-i was simply going to pull in the universe udebs during the buildstep
15:21:30 <NCommander> but we got approval for unsupported kernel in main, then yay
15:21:43 <ogra_> we have release team approval, the kernel package will be in main, but unsupported and not in the manifest
15:21:48 <NCommander> oh
15:21:49 <davidm> NCommander, kernel in main
15:21:52 <NCommander> davidm: awesome
15:22:00 <NCommander> That makes life insanely less complicated
15:22:09 <ogra_> (if you would read the team reports you would know btw :P )
15:22:42 <janimo> NCommander, although d-i supporting universe kernels would have been useful in the future for other flavours
15:22:47 <janimo> or for current mx53
15:22:48 <NCommander> Anyway, I'm shacking loosing the last of the packaging bugs (linux-armadaxp tried to build on amd64 for one)
15:23:06 <NCommander> But we should see an upload into NEW byEOD today or tomorrow
15:23:08 <mahmoh> NCommander: how soon do we expect a kernel in main?
15:23:18 <ogra_> janimo, thats super tricky since there (flasely) is a way to get rid of unwanted udebs by moving them to universe ...
15:23:28 <NCommander> mahmoh: once it is approved from NEW, it goes into universe. Just needs a MIR to promote
15:23:32 <ogra_> janimo, making d-i universe aware would break a lot through that
15:23:46 <janimo> ogra_, I am not arguing it is tricky to accomplish, but it is useful :)
15:24:06 <NCommander> janimo: its probably easier to get release/kernel team blessings to dump an unsupported kernel in main
15:24:49 <ogra_> janimo, yes, but we would have to fix that broken concept alongside
15:24:54 <janimo> NCommander, but then it means it is supported. Are there no cases to want it unoficcially supported but workng with d-i. Is netinstall not such a use case?
15:25:02 <ogra_> else we break x86 stuff
15:25:12 <ogra_> which is not wanted before an LTS
15:25:12 <NCommander> janimo: I proposed the solution of rm -r universe
15:25:29 <NCommander> janimo: historically, we've had a few packages inmain that are unsupported
15:25:37 <janimo> NCommander, I can get behind such a command
15:25:37 <NCommander> linux-ports being the poster child for that trope
15:26:03 * GrueMaster wonders if this is a topic for Kernel Status?
15:26:12 <NCommander> [topic] Kernel Status (cooloney, ppisati)
15:26:14 <NCommander> Right
15:26:14 <NCommander> ok
15:26:36 <NCommander> I think we pretty muchcovered the current kernel status
15:26:46 <NCommander> Anything else to bring up
15:26:53 <janimo> ac100 new test deb based on a 3.0.19 upstream advertised on the ac100 ml
15:26:58 <ogra_> janimo has a new ac100 kernel coming :)
15:27:11 <ogra_> and mx5 seems sorted
15:27:14 * NCommander just got an armel/powerpc FTBFS on linux-armadaxp
15:27:16 <janimo> once marvin puts it in his stable, not exp branch
15:27:17 <NCommander> WOOO
15:27:24 <NCommander> Packaging needs to be hit with a brick
15:27:32 <ogra_> yeah
15:27:35 <janimo> NCommander, I would have been more worried if that build succeeded
15:27:44 <GrueMaster> mx5 kernel still needs work.  It still doesn't support USB on the newer rev board.
15:27:46 <NCommander> janimo: its still running on i386 >.>;
15:27:52 <ogra_> and even more if it worked :)
15:28:08 <ogra_> GrueMaster, dont use USB then :P
15:28:21 * ogra_ hides behind a chair
15:28:22 * NCommander facepalms
15:28:25 <janimo> GrueMaster, we should get a 3.2 mx5 kernel sometime, this is 3.1 .
15:28:29 <GrueMaster> For a desktop image not to use keyboard/mouse...difficult.
15:28:34 <ogra_> pfft
15:28:38 <ogra_> be creative !
15:28:44 <NCommander> write a script
15:28:54 <ogra_> use your soldering skills ... its a dev board after all
15:29:05 <GrueMaster> oem-config doesn't use preseed other wise I would.
15:29:16 <NCommander> ^- ogra_
15:29:21 <NCommander> Care to fix that? :-)
15:29:35 <GrueMaster> And I refuse to molest any of my stock dev boards.
15:29:55 <ogra_> NCommander, yes, after FF
15:29:58 <ogra_> its tasked
15:30:09 <NCommander> cool
15:30:10 <GrueMaster> Soldering iron == bad touch.
15:30:21 <ogra_> try the other side :P
15:30:24 <NCommander> ew
15:30:31 <NCommander> [topic] ARM Porting/FTBFS status (NCommander, janimo)
15:30:39 <NCommander> libo is broken
15:30:42 <NCommander> mono is broken
15:30:49 <NCommander> four letter words are broken
15:30:53 <janimo> given back empathy anf gnome-games on armhf
15:30:55 <GrueMaster> No, say it isn't so....
15:31:01 <janimo> armel is still waiting for the fixed mesa to build
15:31:10 <NCommander> janimo: package name? I'll rescore
15:31:14 <ogra_> upstart seems to need some love
15:31:25 <janimo> NCommander, waiting for build to finish, it has started 8 h ago
15:31:31 <janimo> finished in 1h:30 on armhf
15:31:38 <ogra_> and indeed qtwebkit
15:31:42 <janimo> we need more pandas in the build center
15:31:51 <NCommander> janimo: ow
15:32:10 <ogra_> well, all images failed due to empathy/gnome-games
15:32:27 <ogra_> (but thats for a later topic)
15:32:30 <janimo> due to mesa egl not providing some deps
15:32:37 <janimo> so not actually a change in those gnome apps
15:32:42 <NCommander> movingon
15:32:45 <NCommander> [topic] ARM Image Status (ogra, NCommander)
15:33:03 <ogra_> awww, did they switcfh them to clutter ?
15:33:08 <ogra_> well, all images failed due to empathy/gnome-games
15:33:10 <ogra_> :)
15:33:16 <janimo> ogra_, I think gnome games has been using clutter for a long time
15:33:19 * ogra_ likes his "up" key
15:33:21 <janimo> empathy, no idea.
15:33:25 <ogra_> k
15:33:33 <ogra_> we should test performance then
15:33:37 <janimo> empathy uses every technology
15:33:47 <ogra_> GrueMaster, can you do a quick check with your next desktop tests ?
15:33:55 <ogra_> just to see if they are still usable
15:34:00 <GrueMaster> Check what?
15:34:06 <ogra_> (i.e. play mahjongg for 5 min)
15:34:23 <GrueMaster> WHAT?!?!?  Me play a game???
15:34:25 <ogra_> not sure how to test empathy
15:34:29 * GrueMaster shuders
15:34:36 <ogra_> you could try a voip call or so
15:34:38 <janimo> I think we should drop games altogether and let people use games in their browser
15:34:44 <ogra_> ++
15:34:49 <ogra_> tell that to -desktop though
15:34:53 <NCommander> GrueMaster: try playing Skyrim with qemu-user-i386 + wine on ARM
15:35:00 <GrueMaster> Yea, I'll check them
15:35:09 <ogra_> NCommander, qemu-x86 wont run
15:35:11 <GrueMaster> Erm, no.
15:35:24 <janimo> well if I was in charge I'd drop empathy too and the whole telepathy baggage
15:35:25 <ogra_> threading issues i was told by linaro
15:35:26 <GrueMaster> Alien Arena on panda might be interesting though.
15:35:26 <janimo> but I am not
15:35:31 <ogra_> cant make it work
15:35:43 <ogra_> well, thats all about images i had :)
15:36:09 <NCommander> nethack works great on ARM, what other game do you need?
15:36:23 <GrueMaster> Zork works too.
15:36:30 * NCommander does wish Dwarf Fortress was opensource so he could 1. package it 2.compile it on ARM
15:36:31 <GrueMaster> Just saying.
15:36:32 <ogra_> well, wait until nethack gets switched to clutter too
15:36:40 <NCommander> ARGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH\
15:36:46 <NCommander> HHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH
15:36:49 <ogra_> upstream has funny ideas lately
15:37:00 <ogra_> to clutter the world etc
15:38:30 <janimo> nethack too works in a browser I hear
15:38:43 <janimo> we need less apps in the image, so we have fewer bugs
15:38:45 <janimo> :)
15:38:49 <ogra_> haha
15:38:53 <ogra_> NCommander, move ?
15:39:04 <NCommander> [topic] QA Status (GrueMaster, mahmoh)
15:39:10 <GrueMaster> Spot tested 20120207.1 desktop armhf images yesterday.  mx5 had a few issues (HDMI addon board had it confused, and START-R still doesn't see USB).
15:39:40 <GrueMaster> Also worked up a few scripts to start testing on arm server (LAMP, Ruby on Rails, suspend/resume).
15:40:44 <GrueMaster> Tested the 3.0.17 kernel on armadaxp.  The Marvell patches do something wacky to mmap, it fails to allocate above 2900M.
15:41:16 <GrueMaster> That bug was fixed in all other arm kernels (bug 861296).
15:41:18 <ubottu> Launchpad bug 861296 in linux-ti-omap4 (Ubuntu Oneiric) "mmap fails to allocate 2030Mb heap on ARM" [Undecided,Fix committed] https://launchpad.net/bugs/861296
15:42:20 <GrueMaster> Starting to dive into power meter testing today/tomorrow.  Hope to have some data starting next week.
15:42:56 <GrueMaster> Not much else to report.  Just lots of work going on.
15:43:03 <ogra_> http://image.img-erento.com/20171/5073643_dia_2.jpg
15:43:09 <ogra_> power meter testing ?
15:43:16 <NCommander> [topic] Linaro Updates (rsalveti)
15:43:26 * rsalveti waves
15:43:40 <GrueMaster> Using a power meter to measure system amp load while running.
15:43:46 <rsalveti> we're all busy at connect mostly this week
15:44:06 <rsalveti> but we worked on helping fixing a bunch of multiarch related packages
15:44:26 <rsalveti> and the cross buildd is almost ready, just fixing the web interface to be easy to use
15:44:40 <ogra_> GrueMaster, i was referring to the pic :)
15:44:56 <rsalveti> another good thing is that riku is now working on trying to get libreoffice to build and work for armhf
15:45:14 * ogra_ humps rsalveti's leg
15:45:15 <rsalveti> NCommander: just make sure you send everything you had in the past
15:45:21 <rsalveti> if you didn't do it already
15:45:24 <GrueMaster> So, another duplication of effort?  Great.
15:45:36 <ogra_> GrueMaster, no, a handover
15:45:38 <rsalveti> not duplication, we're working together on this
15:45:41 <NCommander> rsalveti: you have a time machine?
15:45:52 <rsalveti> :-)
15:46:28 <rsalveti> meanwhile steve is working on ruby and haskell I believe
15:46:40 <rsalveti> but it's probably not critical for the desktop
15:47:10 <rsalveti> should have a better report next week, once connect is done :-)
15:47:17 <rsalveti> but that's mostly it
15:47:28 <rsalveti> I asked the freescale LT to fix the imx53 3.2 kernel
15:47:31 <rsalveti> we'll see how it goes
15:48:52 <rsalveti> questions?
15:49:04 <janimo> rsalveti, do you know about omap4 sgc for armhf?
15:49:07 <janimo> omap3
15:49:09 <janimo> sorry
15:49:17 <ogra_> rsalveti, is anyone ever looking at chromium again ?
15:49:34 <rsalveti> janimo: we hope that koen will get this fixed and released soon
15:49:35 <ogra_> i wonder what we should do with it, the binary in the archive is three releases old
15:49:52 <janimo> rsalveti, ok thanks
15:49:53 <rsalveti> I'll talk with him next week, but he was working on getting it available for angstrom
15:50:16 <rsalveti> ogra_: if we get a new release, we update
15:50:23 <rsalveti> otherwise we'll just kill it  for now
15:50:33 <NCommander> anything else
15:50:36 <rsalveti> I believe we'll get it at some point, not yet sure for precise
15:50:40 <ogra_> rsalveti, well, there were three (or four) new releases
15:50:46 <rsalveti> ogra_: is chromium broken again?
15:50:59 <ogra_> it didnt build since natty
15:51:04 <ogra_> or even before
15:51:25 <rsalveti> I remember riku said it was fixed, maybe with debian, will ping him today
15:51:49 <rsalveti> .. :-)
15:52:06 <ogra_> i think he only made it cross buildable
15:52:12 <ogra_> it still fails in the archive
15:52:35 <rsalveti> well, if it works by cross building it there's hope to have it working natively
15:52:56 <ogra_> right, iirc there were issues with ffmpeg or so
15:53:03 <ogra_> riku will likely know more
15:53:04 <rsalveti> #action rsalveti to follow with riku to see if chromium will get fixed
15:53:04 * meetingology rsalveti to follow with riku to see if chromium will get fixed
15:53:19 <ogra_> or micahg ... iirc he took over from riku but gave up
15:53:22 <rsalveti> #action rsalveti to follow with koen at ELC to see if we'll get armhf drivers for sgx (omap3)
15:53:22 * meetingology rsalveti to follow with koen at ELC to see if we'll get armhf drivers for sgx (omap3)
15:54:28 <NCommander> [topic] AOB
15:55:03 <NCommander> closing the meeting out in 3
15:55:06 <NCommander> 2
15:55:08 <NCommander> 1
15:55:11 <NCommander> #endmeeting