19:15 <wxl> #startmeeting Lubuntu 10 February 2016 19:00 UTC meeting
19:15 <meetingology> Meeting started Wed Feb 10 19:15:04 2016 UTC.  The chair is wxl. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:15 <meetingology> 
19:15 <meetingology> Available commands: action commands idea info link nick
19:15 <wxl> https://wiki.ubuntu.com/Lubuntu/IRC%20Meetings/Agenda is our agenda
19:15 <wxl> i know that tsimonq2 is anxious to get started on his topic so i'll let him go first
19:16 <wxl> #topic Test cases for Lubuntu
19:16 <tsimonq2> ooh yay
19:16 <tsimonq2> okay, so as you all know we have atest cases for Lubuntu on iso.qa.ubuntu.com and packages.qa.ubuntu.com
19:16 <tsimonq2> to generate the test cases they have to be manually written out
19:16 <wxl> not as we *all* know, but some of us, yes
19:17 <tsimonq2> wxl: well yeah :D
19:17 <tsimonq2> so anyeays
19:17 <wxl> for those that don't know, it's a qa tool for testing to ensure that our testing process is the same for every test
19:17 <tsimonq2> *anyways
19:17 <tsimonq2> (this is why wxl going first with QA would have been best XD)
19:18 <tsimonq2> anyways, so I wanted to bring this up because I have been recently been getting into writing test cases. Basically, if you are looking at the tracker and you feel that a test for an application would be nice, speak up, because I would like to benefit Lubuntu by making more test cases
19:19 <thsefdhefgsethfs> o/
19:19 <tsimonq2> (sorry for the weird wording this is just on the spot)
19:19 <wxl> hai noah XD
19:19 <tsimonq2> thsefdhefgsethfs: question? XD
19:20 <tsimonq2> so anyways, I am asking the general Lubuntu people if more test cases are needed
19:20 <tsimonq2> and I will make them happen
19:21 * tsimonq2 is cringing at his weird wording XD
19:21 <redwolf> ...
19:21 <wxl> we definitely need LXQt testcases
19:21 <wxl> we should start with the main LXQt components and then add apps as we finally decide on them
19:21 <tsimonq2> I agree
19:21 <redwolf> +1
19:21 <tsimonq2> is there a list somewhere, wxl?
19:21 <wxl> git.lxde.org :)
19:22 <wxl> or you could just use the wiki page that talks about installing lxqt
19:22 <wxl> since it has a list of packages
19:22 <tsimonq2> wxl: for people who don't know, where's that?
19:22 <wxl> but one package may specify multiple deliverables so perhaps it'd be best to start with the upstream page i mentioned
19:22 <wxl> https://wiki.ubuntu.com/Lubuntu/LXQt
19:22 <tsimonq2> because I could get a fresh VM or something and use that to test
19:22 <tsimonq2> oh okay
19:23 <tsimonq2> wxl: what do you mean by multiple deliverables?
19:23 <wxl> multiple commands/programs/etc
19:23 <tsimonq2> ahh okay
19:24 <tsimonq2> wxl: I'm just curious as to what's LXDE and what's LXQt on that upstream link you sent me
19:25 <wxl> lxde components are at the bottom
19:25 <wxl> EVERYTHING is lxqt now
19:25 <tsimonq2> oic the LXDE-only packages are on the bottom with deprecated or whatever that is
19:25 <tsimonq2> gotcha
19:26 <wxl> they're not deprecated, but they're not the main focus of the lxde team
19:26 <tsimonq2> ahh makes sense
19:26 <wxl> it's been made clear to me that lxde will continue, albeit without the support of the entire lxde team
19:26 <redwolf> yes
19:26 <tsimonq2> so I'll get at least merge proposals for the LXQt test cases, maybe I might even create a folder in the testcase dir
19:26 <tsimonq2> wxl: makes sense :)
19:27 <wxl> keep the lubuntu-devel mailing list informed about progress
19:27 <wxl> you might want to make a blueprint to track progress
19:27 <tsimonq2> is there anywhere I should document the merge proposals/testcases I write for LXQt, sort of a todo list, or should I just crank it out on my own tools?
19:27 <tsimonq2> yeah I'll do that
19:28 <wxl> yep :)
19:28 <tsimonq2> nvm on the former
19:28 <tsimonq2> so I'll create a blueprint and I'll meail the lubuntu-devel list about that
19:28 <tsimonq2> also
19:28 <wxl> yep
19:29 <tsimonq2> because we still support LXDE even for the LTS, I was wondering if any should be updated
19:29 <tsimonq2> so, I'll email lubuntu-devel, but I was wondering if any need updating
19:29 <wxl> the testcases for lxde?
19:29 <tsimonq2> yes
19:29 <tsimonq2> on packages.qa.ubuntu.com
19:30 <wxl> none that i know of but it's worth auditing
19:30 <tsimonq2> so just keep your eyes out for any testcases that need improving, file a bug, and don't be afraid to assign me andor email me at tsimonq2@ubuntu.com
19:31 <tsimonq2> *and/or
19:31 <wxl> okie dokie
19:31 <wxl> thanks for your help with the testcases, tsimonq2
19:31 <tsimonq2> no problem
19:31 <tsimonq2> any questions/comments/concerns, let me know at tsimonq2@ubuntu.com
19:31 <tsimonq2> I'll email the list in a few hours
19:31 <wxl> ok i guess i'll start on my topic then unless people have questions or antyhing
19:31 * tsimonq2 is done with what he has to say
19:32 <wxl> #topic QA
19:32 <wxl> i'll keep this brief as i have emailed the lubuntu-devel list about it
19:32 <wxl> current focus should be on smoke testing trusty daily images
19:32 <wxl> the current plan (changed again) is to release on the 18th
19:33 <wxl> we should have images to test on the tuesday before, if not sooner
19:33 <wxl> until then, we should just run through the dailies and see if there are any big problems
19:33 <wxl> as per the past few point releases we have done, there will be no alternates and no amd64+mac image (though they were released with the original trusty)
19:34 <wxl> it would always be good to go through old bugs on the release notes and see if any of those bugs are fixed or not and if so mark them as such on the wiki
19:34 <tsimonq2> okay, *my* plan is to confirm bugs for the release notes on Monday night, then if we have images, test those (I would do this over the weekend but dad is taking us to the dells :D)
19:34 <wxl> i know tsimonq2 and i and others all have plans of doing so, but the more eyes on it the better
19:34 <tsimonq2> (sorry for interrupting :) )
19:34 <wxl> np you just repeated me anyways :)
19:35 <tsimonq2> :D
19:35 <wxl> next focus will be on xenial daily images
19:35 <wxl> we are (i've confirmed this) doing releases back to back
19:35 <wxl> so the release of xenial beta 1 will be the week right after trusty 14.04.4
19:35 <wxl> so no rest for the wicked! keep on testing!
19:36 <tsimonq2> time providing, that will go on my Monday agenda as well
19:36 <tsimonq2> wxl: when can we expect images?
19:36 <wxl> same philosophy as with trusty applies: smoketest for obvious problems before the milestone, look for bugs that are fixed
19:36 <wxl> tsimonq2: releases are (usually) always thursday and we (usually) always have images the tuesday before
19:37 <wxl> so since we'll release beta1 on the 25th, the milestone images will be available on the 23rd
19:37 <wxl> this is covered in the testing wiki page
19:37 <wxl> which i admit is a bit long, but there's a lot of really valuable info there
19:38 <wxl> beyond that exploratory testing of lxqt and/or the raspberry pi2 images is always welcome
19:38 <wxl> i linked the lxqt page before
19:38 <tsimonq2> and a note, if you are looking to get into QA but don't know how, you can find us here :)
19:38 <tsimonq2> or the Testing page
19:38 <tsimonq2> (which wxl has yet to link :) )
19:38 <wxl> https://wiki.ubuntu.com/Lubuntu/Testing
19:39 <wxl> and here';s the raspberry pi page https://wiki.ubuntu.com/Lubuntu/RaspberryPi
19:39 <tsimonq2> we are always looking for more help, so if you haven't looked into QA, it's pretty easy :)
19:39 <wxl> i'd like to figure out a way to get an image for the original Raspberry Pi, but that's kind of way at the bottom of my list so don't anyone get too excited :)
19:39 <wxl> oh!
19:40 <redwolf> will be able to provide a download link for that machine?
19:40 <wxl> and just a reminder that we only release PPC images in LTS and both xenial and trusty are LTSs so if you have the hardware or know anyone that does test test test
19:40 <wxl> i still have machines to send out to people
19:40 * tsimonq2 notes that if he got a Raspberry Pi, this would be a lot quicker, and people could expect it sooner :)
19:40 * wxl hangs his head out in shame
19:40 <wxl> tsimonq2: well, there is some serious work involved, me thinks
19:41 <wxl> redwolf: that machine, meaning the original Pi?
19:41 <redwolf> no, the Pi2, adding the ISO download to the others
19:41 <tsimonq2> wxl: If it runs with Debian, I can figre it out :D
19:41 <tsimonq2> s/figre/figure/
19:41 <wxl> redwolf: an iso is not relevant to the Pi2 unfortunately
19:41 <wxl> redwolf: but if you follow the link downloadable images are available
19:42 <wxl> although reading it now it's not clear
19:42 <redwolf> sorry, let me explain. the same way we provide at lubuntu.me (and still in lubuntu.net) downloads for all machines in several versions, another link to the Pi2 one
19:42 <redwolf> kinda official
19:42 <tsimonq2> =1
19:42 <wxl> yeah but only kinda official
19:42 <tsimonq2> s/=/+/
19:42 <wxl> this is a community supported thing in a way beyond that of ppc
19:43 <wxl> which is to say we're not using canonical's build hardware to pump out the images
19:43 <redwolf> mhm
19:43 <wxl> so we have to link outside the normal canonical world
19:43 <wxl> but that's no problem. sure we can!
19:43 <redwolf> okies :)
19:43 * tsimonq2 would like that
19:44 <wxl> i think phillw is hosting the images outside of the torrents available on the ubuntu flavor maker page
19:44 <redwolf> aye
19:44 <wxl> it's here
19:44 <wxl> http://phillw.net/isos/lubuntu/wily/
19:44 <tsimonq2> wxl: and if it's just a imple process and the source code is available, I might find a way to automate it, then we could throw it on a server :D
19:45 <wxl> tsimonq2: yeah i need to talk to flexiondotorg_ about it
19:45 <wxl> redwolf: you want to take care of linking it on the website?
19:45 <tsimonq2> wxl: but Canonical hosting would be awesome
19:45 <redwolf> I will, yes :)
19:45 <wxl> tsimonq2: it's NOT going to happen
19:45 <wxl> oh!
19:45 <tsimonq2> wxl: just curious, why not?
19:46 <wxl> #action tsimonq2 will make a blueprint for lxqt testcases
19:46 * meetingology tsimonq2 will make a blueprint for lxqt testcases
19:46 <wxl> #action wxl will edit the RaspberryPi page to include clear download links
19:46 * meetingology wxl will edit the RaspberryPi page to include clear download links
19:46 <wxl> #action redwolf will include the RaspberryPi download link(s) to the lubuntu.me website
19:46 * meetingology redwolf will include the RaspberryPi download link(s) to the lubuntu.me website
19:46 <redwolf> O.O!
19:46 <wxl> :)
19:47 <wxl> only one other thning i wanted to add is some new information that passed by the lubuntu-devel mailing list: we're now on the ubuntu downloads page!
19:47 <tsimonq2> #action Trusty needs testing in the upcoming week for the point release, tsimonq2 will definitely test
19:47 * meetingology Trusty needs testing in the upcoming week for the point release, tsimonq2 will definitely test
19:47 <tsimonq2> ysy
19:47 <tsimonq2> s/s/a/
19:47 <wxl> see "ubuntu flavors" at http://www.ubuntu.com/download
19:47 <wxl> this takes you to http://www.ubuntu.com/download/ubuntu-flavours
19:48 <wxl> it's got kind of random ordering
19:48 <tsimonq2> #action tsimonq2 will send an email to lubuntu-devel about the QA testcases
19:48 * meetingology tsimonq2 will send an email to lubuntu-devel about the QA testcases
19:48 * tsimonq2 is done with #action for now :)
19:48 <wxl> there's a bug to get that ordered
19:48 <wxl> most likely alphabetical
19:48 <wxl> that's this one https://bugs.launchpad.net/ubuntu-website-content/+bug/1543783
19:48 <ubot93> Launchpad bug 1543783 in ubuntu-website-content "Order flavours on flavour download page alphabetically" [Undecided,New]
19:49 <wxl> i also filed one to get the right website linked https://bugs.launchpad.net/ubuntu-website-content/+bug/1543842
19:49 <ubot93> Launchpad bug 1543842 in ubuntu-website-content "change link to Lubuntu on flavor downloads page to lubuntu.me" [Undecided,Confirmed]
19:49 * tsimonq2 has to take off in < 7 minutes
19:49 <tsimonq2> oh okay
19:49 <wxl> i also checked around to make sure we don't still have any lubuntu.net references and couldn't find any so not sure what's up with that
19:49 <wxl> that's it for me
19:50 <wxl> #topic donation area
19:50 <wxl> with phillw not being here, i'm going to speak for him
19:50 <wxl> i know we're still waiting on the gosh darned paperwork
19:50 <phillw> o/
19:50 <wxl> oh!
19:50 <wxl> hai phillw
19:50 <wxl> want to take over?
19:50 <tsimonq2> hey it's phillw!
19:50 <phillw> fed!!!
19:50 * wxl pats phillw's distended tummy :)
19:51 <phillw> I will get copies of paperwork emailed out this week.
19:51 <wxl> so if all goes well, maybe we'll have a donation area before the end of the month???
19:52 <phillw> By Release time :)
19:52 <tsimonq2> if you don't mind me asking, what exactly is the purpose of the donation area?
19:52 <wxl> hehe yay! that would be great!
19:52 <tsimonq2> where do the funds go?
19:52 <tsimonq2> (my question is the latter)
19:52 <phillw> Someone needs to give Julien a dig, he's had his paperwork for a while after the 1st batch was lost in the post.
19:53 <wxl> tsimonq2: they'll go to various and sundry needs of the lubuntu team, since we don't directly get any community donations funding
19:53 <wxl> phillw: may i nominate you for that task?
19:53 <tsimonq2> wxl: example?
19:53 <wxl> tsimonq2: buying and shipping ppc machines to testers :)
19:54 <tsimonq2> wxl: orrrr shipping Raspberry Pis to eager testers? XD
19:54 <phillw> wxl: I'll look out for him, although redwolf tends to speak more often.... basically next one who sees him - remind him!
19:54 <wxl> tsimonq2: don't get too excited
19:54 <redwolf> ok
19:54 <wxl> #action redwolf phillw and/or wxl to have Julien send on his paperwork for the donation area
19:54 * meetingology redwolf phillw and/or wxl to have Julien send on his paperwork for the donation area
19:54 <wxl> anything else on the donation area?
19:55 * tsimonq2 remains silent
19:55 <phillw> I'll email redwolf our constitution, even though not launched, it can be news on lubuntu.me
19:55 * tsimonq2 has to jet, bye guys!
19:55 <wxl> that'd be fab!
19:55 <wxl> bai tsimonq2 thanks again
19:56 <redwolf> o/ tsimonq2
19:56 <wxl> #action phillw to give redwolf our constitution (re: donations) to get up on lubuntu.me
19:56 * meetingology phillw to give redwolf our constitution (re: donations) to get up on lubuntu.me
19:56 <redwolf> yes, we have a blog ;)
19:56 <wxl> hehe
19:56 <wxl> ok my co-worker is getting hungry so i'll move this along
19:56 <wxl> we don't have anyone to talk on lxqt so i'm going to just move on from that topic
19:57 <wxl> aaaaaaaaaaaaaaand nio is not around either
19:57 <phillw> http://phillw.net/LubuntuConstitution.txt
19:57 <phillw> redwolf: that okay for you?
19:58 <redwolf> yes! I'll re-format that
19:58 <redwolf> no need for signatures and dates and stuff publicly!
19:59 <phillw> redwolf: the sigs bit was for if bank needed it signing. They did not :P
19:59 <redwolf> okies. I will prepare a "nice-looking" page
20:00 <wxl> #topic anything else
20:00 <wxl> anything else anyone?
20:00 <phillw> redwolf: as it is news - remember s/has been opened/ is being opened/ :D
20:00 <wxl> artwork news redwolf ?
20:00 <redwolf> no
20:01 <wxl> yes there is
20:01 <wxl> :)
20:01 <redwolf> really?
20:01 <redwolf> please, refresh my memory
20:01 <wxl> isn't there some new stuff in the Lenny family?
20:01 <redwolf> oh yes!! I have a new practice designer :)
20:02 <wxl> well that
20:02 <wxl> but don't we have a borg????
20:02 <wxl> and potatoes
20:02 <wxl> :)
20:02 <redwolf> yes, but everybody saw that :) (I think)
20:02 <wxl> oh
20:02 <wxl> well i didn't think they did
20:02 <wxl> not everyone subscribes to that page and it's not easy to find
20:03 <redwolf> phillw already told me we have to promote that wiki page a bit more
20:03 <wxl> give us the link then!
20:03 <redwolf> Lenny's? https://wiki.ubuntu.com/Lubuntu/Marketing/Lenny
20:03 <wxl> yay Lennys!
20:04 <wxl> are we going to have a squirrel?
20:04 * wxl ducks
20:04 <phillw> we will need one... ish
20:04 <redwolf> of course ;) every release mascot
20:04 <wxl> well
20:04 <wxl> good luck :)
20:04 <wxl> and on that note, i'm ready to call it quits
20:04 <redwolf> ta!
20:04 <phillw> thanks for chairing :)
20:05 <wxl> thanks everyone!
20:05 <wxl> #endmeeting