16:24 <blackboxsw_> #startmeeting cloud-init status meeting
16:24 <meetingology> Meeting started Tue Aug 25 16:24:27 2020 UTC.  The chair is blackboxsw_. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:24 <meetingology> 
16:24 <meetingology> Available commands: action commands idea info link nick
16:24 <blackboxsw_> #chair smoser rharper falcojr lucasmoura
16:24 <meetingology> Current chairs: blackboxsw_ falcojr lucasmoura rharper smoser
16:25 <blackboxsw_> hey folks, welcome to another cloud-init bi-weekly (or bi-monthly) community status meeting
16:25 <blackboxsw_> or semi-monthly
16:26 <blackboxsw_> ... anyhow. We use this platform/channel to discuss latest and greatest cloud-init, as well as ensuring that there are a couple of upstream developers present to field questions or discussion as needed.
16:26 <blackboxsw_> We gather here in this IRC channel every 2 weeks to discuss current development tasks and progress on cloud-init. All questions and side-conversations welcome
16:26 <blackboxsw_> we keep our meeting minutes from previous meetings here:
16:27 <blackboxsw_> #link https://cloud-init.github.io
16:27 <blackboxsw_> The topics we'll cover today: Previous Actions, Recent Changes, In-progress Development, Community Charter, Office Hours (~30 mins).
16:27 <blackboxsw_> #topic Previous Actions
16:27 <blackboxsw_> Looks like no carryover actions from last meeting
16:27 <blackboxsw_> #topic Recent Changes
16:30 <blackboxsw_> The following changes have landed in tip of master since last meeting (08/14/20).
16:30 <blackboxsw_> found via git log --since 2020-08-014
16:30 <blackboxsw_> #link https://paste.ubuntu.com/p/h2qxwKwvFw/
16:31 <blackboxsw_> things to note. we *JUST* cut 20.3 upstream release as of 20 seconds ago. Thanks a bunch James(falcojr) for getting the Azure timeout pr up to close out this upstream release.
16:31 <blackboxsw_> and thanks smoser, rharper and meena for all the reviews and work here.
16:34 <blackboxsw_> in the last couple weeks we got fixes to reduce boot timeouts for certain azure accelerated network instances, fix oracle datasource retries, handle compressed user-data on juju deployed machines in 'cloud-init query', and early boot dhclient will not attempt to run outside of the /var/tmp sandbox directory if that directory is marked no-exec
16:34 <blackboxsw_> thanks otubo for that noexec branch
16:35 <blackboxsw_> #topic In-progress  Development
16:36 <blackboxsw_> So thanks all for the 20.3 upstream release. We will be tagging that release and pushing that tag to master just after this meeting
16:36 <blackboxsw_> falcojr: is our release lead for this upstream release and SRU so he'll be working through the release process work items. Thanks falcojr.
16:37 <blackboxsw_> -next step on the release process is to publish to Ubuntu Groovy (20.10) and then queue up a -proposed cloud-init SRU upload into xenial, bionic and focal.
16:37 <blackboxsw_> we will then begin the SRU testing (which we hope to keep at around ~7days)
16:38 <blackboxsw_> as smoser mentioned earlier. cloud-init has to follow this process to update cloud-init in stable Ubuntu releases
16:38 <blackboxsw_> #link https://wiki.ubuntu.com/CloudinitUpdates
16:39 <blackboxsw_> An email will be sent to the cloud-init mailinglist notifying the community about the SRU under test in the event that folks have spare cycles to pitch in on some of the verification effort
16:40 <blackboxsw_> also "in-progress" paride is cleaning up a bunch of automated CI-related failures and lint issues in cloud-init, so expect some branches against cloud-init on that front as well
16:40 <blackboxsw_> #topic Community Charter
16:41 <blackboxsw_> The following topics are still topics for ongoing community development anyone new to cloud-init, or with a bit of time could easily grab one of these bitesized tasks:
16:41 <blackboxsw_> JSON schema extensions to validate user-data before instance launch: https://bugs.launchpad.net/cloud-init/?field.tag=bitesize
16:41 <blackboxsw_> - Datasource documentation and updates
16:41 <blackboxsw_> -  cloudinit.net refactor into distro-specific networking subclasses cloudinit.distros.networking: https://bugs.launchpad.net/cloud-init/+bugs?field.tag=net-refactor
16:41 <blackboxsw_> As always: thank you all for bug contributions, PR submissions, triage and discussion participation.
16:41 <blackboxsw_> If anyone would like to be involved more than they currently are, please feel free to contact us here in IRC #cloud-init on Freenode or on the mailing list cloud-init@lists.launchpad.net and we can see how best we can get you "set up"
16:42 <blackboxsw_> #topic Office Hours (next ~30 mins)
16:42 <blackboxsw_> his time of the meeting is really just an open door for any discussions, concerns, bugs, questions or general prodding of upstream devs to make sure existing development work is unblocked where possible.
16:42 <blackboxsw_> *This time
16:42 <blackboxsw_> while we're at it with meeting time.... I'll set the next cloud-init status meeting date in the topic of this IRC channel
16:42 <AnhVoMSFT> When do you anticipate the next SRU would be?
16:43 <AnhVoMSFT> (after 20.3)
16:44 <blackboxsw_> AnhVoMSFT: thanks for the question. I hope today for 20.3, I think 20.4 will likely align with the next Ubuntu release cycle (20.10)  so, October, 2020
16:46 <blackboxsw_> as mentioned in passing earlier, we are looking at trying to create an upstream release of cloud-init when any significant feature set has landed in tip to make release verification easier (and hopefull include less sprawling sets of broad commit streams).
16:46 <blackboxsw_> this ultimately may translated to 4-5 releases per year
16:46 <blackboxsw_> I expect a frequency of < 3 months
16:48 <blackboxsw_> #topic #cloud-init pull-requests https://git.io/JeVed | Meeting minutes: https://goo.gl/mrHdaj | Next status meeting Sep 8 16:15 UTC | 20.2 (Apr 26) | 20.3 (estimated Aug 19th) https://bugs.launchpad.net/cloud-init/+filebug
16:49 <blackboxsw_> next status meeting sept 8th, same time ^
16:49 <AnhVoMSFT> Thanks. There's some planned work for Azure's pre-provisioning v2 and will need some change in cloud-init. We're trying to get a sense of when cloud-init SRUs land so that we can communicate the timeline
16:52 <blackboxsw_> @AnhVoMSFT generally cadence has been ~3 months between SRUs, I think we'd like to see a slightly higher frequency than that because our last SRU was so costly. but I think expectation for this pass is likely 10/15/2020
16:53 <blackboxsw_> also, if we are looking to test features in Ubuntu Groovy 20.10 images, they don't require an SRU, so upload to that development release are possible any time (we could do that as frequently as weekly if need be)
16:56 <AnhVoMSFT> thanks for the clarification @blackboxsw_
16:57 <blackboxsw_> so as of today, I expect we'll have an SRU in October and likely something beginning of Jan
16:57 <blackboxsw_> I'll take an action for us to communicate via mailinglist the next estimated SRU once this SRU for 20.3 closes out
16:59 <blackboxsw_> #action bbsw add workitem to SRU release process to announce to mailinglist estimated next SRU timeframe
16:59 * meetingology bbsw add workitem to SRU release process to announce to mailinglist estimated next SRU timeframe
16:59 <blackboxsw_> and again we hope to have 20.3 SRU complete by next week
16:59 <blackboxsw_> complete, as in publish the 20.3 SRU for next week into Ubuntu xenial and later
17:00 <blackboxsw_> I expect today we publish tip of master (20.3) into Ubuntu Groovy (20.10) so expect to see it in your friendly neighborhood ubuntu cloud-images in the next day or two
17:04 <blackboxsw_> falcojr: I just annotated tag 20.3 and pushed to upstream
17:04 <blackboxsw_> so we have a signed tag
17:04 <blackboxsw_> falcojr: so next task is https://trello.com/c/KxShylli/14-upload-source-tarball-to-launchpad
17:05 <falcojr> Cool, I can jump on that
17:12 <blackboxsw_> ok I think we'll wrap up the status meeting. Thanks all for tuning in!
17:13 <blackboxsw_> #endmeeting