17:30 <blackboxsw> #startmeeting Cloud-init bi-weekly status
17:30 <meetingology> Meeting started Tue Jan  7 17:30:28 2020 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:30 <meetingology> 
17:30 <meetingology> Available commands: action commands idea info link nick
17:30 <blackboxsw> #chair Odd_Bloke
17:30 <meetingology> Current chairs: Odd_Bloke blackboxsw
17:30 <blackboxsw> #chair rharper
17:30 <meetingology> Current chairs: Odd_Bloke blackboxsw rharper
17:31 <blackboxsw> Welcome to the first cloud-init community status meeting of 2020. cloud-init upstream uses this meeting as a platform for community updates, feature/bug discussions, and an opportunity to get some extra input on current development.
17:31 <Odd_Bloke> usrdev: I'm not 100% sure from that description, could you file a bug using the link in the topic and attach the output of `cloud-init collect-logs` on an affected instance?
17:31 <blackboxsw> We generally have this meeting ever 2 weeks (outside of intermittent holidays)... You can always find the next scheduled meeting in the topic of this channel
17:31 <blackboxsw> Let
17:31 <blackboxsw> Let
17:32 <blackboxsw> Let's schedule the next meeting now as well
17:32 <blackboxsw> Any objections to Jan 21 ?
17:33 <robjo> Look I'm not late ;)
17:33 <blackboxsw> ok topic set for next meeting
17:33 <blackboxsw> nope, just me robjo :) welcome to the party
17:33 <blackboxsw> as always previous meeting minutes are here.
17:33 <blackboxsw> #link https://cloud-init.github.io/status-2019-12-10.html#status-2019-12-10
17:34 <blackboxsw> topics for this round: Feel free to interject/suggest other topics at any time. Our typical format is the following: Previous Actions, Recent Changes, In-progress Development, Community Charter, Upcoming Meetings, Office Hours (~30 mins).
17:34 <robjo> The move to Tuesday creates a conflict for me for the last 15 minutes of the meeting. Generally I don't think that's an issue as we are often done in less than 1 hour, just pointing out that usually I have to leave 15 minutes early
17:34 <robjo> not today ;)
17:36 <blackboxsw> +1 robjo. We'll try to keep it snappy :) and if others have conflicts we can certainly touch on shifting the schedule a bit. We generally have a conflict at 1 hr before this meeting, which is the only reason it isn't 1 hr earlier
17:36 <blackboxsw> #topic Previous Actions
17:37 <blackboxsw> last round: rharper to confirm https://github.com/canonical/cloud-init/pull/42 can land. COMPLETED
17:37 <blackboxsw> action2:  upstream core-devs to decide about whether a PR can land if any upstream dev still has 'requested changes'
17:38 <blackboxsw> Odd_Bloke: started writing up a spec/procedure for PR review and he is currently working on adding a documentation addition PR to http://cloudinit.readthedocs.io that will describe the workflow for a PR to get from proposed -> merged.
17:39 <blackboxsw> that PR should likely be up this week for review if folks are watching our review queue
17:39 <blackboxsw> #link https://github.com/cloud-init/cloud-init/pulls
17:39 <blackboxsw> No other actions from the previous meeting in December.
17:39 <blackboxsw> #topic Recent Changes
17:40 <blackboxsw> recent commits that made it into tip: found via git log --since 12-10-2019
17:41 <blackboxsw> let's see if I get throttled for spam
17:41 <blackboxsw> - freebsd: fix create_group() cmd (#146) [Gonéri Le Bouder]
17:41 <blackboxsw> - doc: make apt_update example consistent (#154)
17:41 <blackboxsw> - doc: add modules page toc with links (#153) (LP: #1852456)
17:41 <blackboxsw> - Add support for the amazon variant in cloud.cfg.tmpl (#119)
17:41 <blackboxsw> [Frederick Lefebvre]
17:41 <ubot5> Launchpad bug 1852456 in cloud-init "doc: list of modules is no longer present" [Medium,Triaged] https://launchpad.net/bugs/1852456
17:41 <blackboxsw> heh
17:41 <blackboxsw> - freebsd: fix create_group() cmd (#146) [Gonéri Le Bouder]
17:41 <blackboxsw> 10:41     - doc: make apt_update example consistent (#154)
17:41 <blackboxsw> 10:41     - doc: add modules page toc with links (#153) (LP: #1852456)
17:41 <blackboxsw> 10:41     - Add support for the amazon variant in cloud.cfg.tmpl (#119)
17:41 <blackboxsw> 10:41       [Frederick Lefebvre]
17:41 <blackboxsw> 10:41     - ci: remove Python 2.7 from CI runs (#137)
17:41 <blackboxsw> 10:41     - modules: drop cc_snap_config config module (#134)
17:41 <blackboxsw> 10:41     - migrate-lp-user-to-github: ensure Launchpad repo exists (#136)
17:41 <blackboxsw> 10:41     - docs: add initial troubleshooting to FAQ (#104) [Joshua Powers]
17:41 <blackboxsw> 10:41     - doc: update cc_set_hostname frequency and descrip (#109)
17:41 <blackboxsw> 10:41       [Joshua Powers] (LP: #1827021)
17:41 <ubot5> Launchpad bug 1827021 in cloud-init "SSH Documentation should mention "Host Key"" [Medium,Triaged] https://launchpad.net/bugs/1827021
17:41 <blackboxsw> - ci: emit names of tests run in Travis (#120)
17:41 <blackboxsw> 10:41     - Release 19.4 (LP: #1856761)
17:41 <ubot5> Launchpad bug 1856761 in cloud-init "Release 19.4" [Undecided,Fix released] https://launchpad.net/bugs/1856761
17:41 <blackboxsw> 10:41     - rbxcloud: fix dsname in RbxCloud [Adam Dobrawy] (LP: #1855196)
17:41 <blackboxsw> 10:41     - tests: Add tests for value of dsname in datasources [Adam Dobrawy]
17:41 <blackboxsw> 10:41     - apport: Add RbxCloud ds [Adam Dobrawy]
17:41 <blackboxsw> 10:41     - docs: Updating index of datasources [Adam Dobrawy]
17:41 <ubot5> Launchpad bug 1855196 in cloud-init "RBXCloud has no dsname defined, so datasource cannot be properly detected." [Low,Triaged] https://launchpad.net/bugs/1855196
17:41 <blackboxsw> 10:41     - docs: Fix anchor of datasource_rbx [Adam Dobrawy]
17:41 <blackboxsw> 10:41     - settings: Add RbxCloud [Adam Dobrawy]
17:41 <blackboxsw> 10:41     - doc: specify _ over - in cloud config modules
17:41 <blackboxsw> 10:41       [Joshua Powers] (LP: #1293254)
17:41 <ubot5> Launchpad bug 1293254 in cloud-init "style guide on dashes vs underscores in cloud-init" [Low,Fix released] https://launchpad.net/bugs/1293254
17:42 <blackboxsw> - tools: Detect python to use via env in migrate-lp-user-to-github
17:42 <blackboxsw> [Adam Dobrawy]
17:42 <blackboxsw> - Partially revert "fix unlocking method on FreeBSD" (#116)
17:42 <blackboxsw> - tests: mock uid when running as root (#113)
17:42 <blackboxsw> [Joshua Powers] (LP: #1856096)
17:42 <blackboxsw> - cloudinit/netinfo: remove unused getgateway (#111)
17:42 <blackboxsw> - docs: clear up apt config sections (#107) [Joshua Powers] (LP: #1832823)
17:42 <ubot5> Launchpad bug 1856096 in cloud-init "unittest failure when running tests as root: no such file or dir: 'ud'" [High,Fix released] https://launchpad.net/bugs/1856096
17:42 <blackboxsw> - doc: add kernel command line option to user data (#105)
17:42 <blackboxsw> [Joshua Powers] (LP: #1846524)
17:42 <ubot5> Launchpad bug 1832823 in cloud-init "docs: confusing heading "Add apt repositories"" [Low,Fix released] https://launchpad.net/bugs/1832823
17:42 <ubot5> Launchpad bug 1846524 in cloud-init "docs: cloud-init user-data docs should mention kernel cmdline options" [Wishlist,Fix released] https://launchpad.net/bugs/1846524
17:42 <blackboxsw> - config/cloud.cfg.d: update README [Joshua Powers] (LP: #1855006)
17:42 <blackboxsw> - azure: avoid re-running cloud-init when instance-id is byte-swapped
17:42 <blackboxsw> (#84) [AOhassan]
17:42 <blackboxsw> - fix unlocking method on FreeBSD [Igor Galić] (LP: #1854594)
17:42 <blackboxsw> - debian: add reference to the manpages [Joshua Powers]
17:42 <blackboxsw> - ds_identify: if /sys is not available use dmidecode (#42)
17:42 <blackboxsw> [Igor Galić] (LP: #1852442)
17:42 <ubot5> Launchpad bug 1855006 in cloud-init "config/cloud.cfg.d/README says "All files" rather than "*.cfg"" [Low,Fix released] https://launchpad.net/bugs/1855006
17:42 <blackboxsw> - docs: add cloud-id manpage [Joshua Powers]
17:42 <blackboxsw> - docs: add cloud-init-per manpage [Joshua Powers]
17:42 <ubot5> Launchpad bug 1854594 in cloud-init "lock passwd implemented wrong on FreeBSD" [Medium,Fix released] https://launchpad.net/bugs/1854594
17:42 <blackboxsw> - docs: add cloud-init manpage [Joshua Powers]
17:42 <blackboxsw> - docs: add additional details to per-instance/once [Joshua Powers]
17:42 <blackboxsw> - Merge pull request #96 from fred-lefebvre/master [Joshua Powers]
17:42 <blackboxsw> - Update doc-requirements.txt [Joshua Powers]
17:42 <ubot5> Launchpad bug 1852442 in cloud-init "ds-identify uses the /sys filesystem which is linux specific and non-portable" [Undecided,Fix released] https://launchpad.net/bugs/1852442
17:42 <blackboxsw> - doc-requirements: add missing dep [Joshua Powers]
17:42 <blackboxsw> Ok that should do it.
17:42 <blackboxsw> maybe best to just pastebin next time
17:43 <robjo> yup
17:43 <blackboxsw> lots of doc changes as you can see. dropping python 2.7 automatic testing
17:44 <blackboxsw> some additional FreeBSD enablement work landed too (thanks Goneri && meena )
17:44 <blackboxsw> total changelog since last meeting:
17:44 <blackboxsw> #link https://paste.ubuntu.com/p/Cwnn3SbmWQ/
17:44 <blackboxsw> much better
17:44 <blackboxsw> #topic In-progress Development
17:45 <blackboxsw> We've dusted off our shoes and will get back into using our Trello board more frequently for the immediate updates for what we are currently working.
17:45 <blackboxsw> New Year's resolution and all
17:45 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
17:46 <blackboxsw> expect to see more cloud-init cards migrating through the lanes of the board. Expectation as well is that we'll drop the backlog and ideas lanes and keep the board a simple kanban of what is in progress, review and done
17:47 <blackboxsw> Also note I'm going to drop the community charter lane and create bugs for each item, tagging them 'bitesize' so that quick drivebys of developers that want to contribute can search bugs for those straightforward tasks
17:47 <blackboxsw> that said, some high level goals upstream is working:
17:48 <blackboxsw> - cloud-init one-shot daemon work
17:48 <blackboxsw> - cloud-init network hotplug handling
17:48 <blackboxsw> - boot performance  improvements
17:49 <blackboxsw> - github automation and tooling improvements for expedited reviews and process
17:50 <blackboxsw> I think that plus reviewing the PR active review queues will keep folks busy for the next 2 weeks :)
17:51 <blackboxsw> we will likely be adding a cloud-init SRU into xenial, bionic, disco, eoan into the mix as well
17:51 <blackboxsw> #topic Community Charter
17:52 <blackboxsw> So generally I'd be pointing to the trello lane "Community low hanging fruit" but I hope to convert those cards to bugs today. So let's say community ongoing efforts fall into two camps"
17:53 <blackboxsw> 1. add json schema validation to missing cloudinit/config/cc_*py modules.  ( I think there are about 45 remaining modules that need json schema for syntax validation)
17:53 <blackboxsw> 2. doc scrub and update for datasources in read the docs
17:54 <blackboxsw> All of these items can easily be worked in parallel, which is why they are a good set of tasks for the greater community
17:55 <blackboxsw> Expect to find them by searching cloud-init bugs for bitesize tag
17:55 <robjo> With bugs remaining in launchpad, would it be a good idea to have things like the schema validation not as bugs but issues in GitHub?
17:55 <robjo> that would make them more visible IMHO
17:55 <robjo> and those are not really bugs nor is it pressing
17:56 <blackboxsw> #link https://bugs.launchpad.net/cloud-init/?field.tag=bitesize
17:57 <blackboxsw> robjo: good suggestion.  I think we were trying to avoid the confusion of having two places for bugs (launchpad bugs and github issues) That is a good point though, and maybe it's worth a mailing list discussion to get others to weight in.
17:58 <Odd_Bloke> I would be -1 on enabling issues, we would spend our entire lives telling people to report in Launchpad instead.
17:59 <Odd_Bloke> I totally understand wanting to separate "bugs" and "development tasks", though.
18:00 <Odd_Bloke> But I don't think we have a _great_ way of doing that which doesn't end up with a confusing experience for bug reporters.
18:00 <robjo> True that people will equate issues in GitHub with bugs and thus file problems there rather than launchpad, it's a two edged sword
18:00 <blackboxsw> right, I think designation is there. We could also add a link to community charter bugs to the top-level README.md for the github project. Just so there is a close breadcrumb in github to get to those items
18:01 <Odd_Bloke> Our plan is to assess how this is working in a month or two, so if it's not working well then we can figure something else out.
18:01 <blackboxsw> I think the designation of "community development tasks" is there by using bitesize tag or some equivalent
18:02 <blackboxsw> #ACTION bbsw seed initial community charter bitesize bugs
18:02 * meetingology bbsw seed initial community charter bitesize bugs
18:02 <blackboxsw> #topic Office Hours (next ~30 mins)
18:02 <robjo> Well, "community development tasks" is a bit mis-leading, after all the core team should be part of the "community" right?
18:03 <robjo> So everything is really a  "community development tasks", just that some things are easier than others ;)
18:03 <blackboxsw> robjo: yes absolutely. right... I've seen some projects use 'goodfirstbug' or something like that  too
18:04 <blackboxsw> just something to reduce the barrier to involvement for anyone wanting to contribute
18:05 <blackboxsw> and yes, core team should be accountable to work on some of those community charter tasks when time permits
18:05 <robjo> Yes, I think it is important to label the "easy" stuff to help people find a place to get started
18:05 <blackboxsw> so that hopefully next cloud-init summit we can set a charter for something else
18:06 <robjo> just based on experience there are a lot of people that are sensitive to wording and we don't really want to get into the bikeshedding that comes along with such situations
18:07 <blackboxsw> for those reading, office hours is a time of open and unstructured discussion. core cloud-init devs will have eyes on the channel to field questions, concerns, feature or bug discussions. Participate at will. In the absence of any ongoing discussions, upstream will groom/review the active review queue @  https://git.io/JeVed |
18:09 <Odd_Bloke> Honestly losing my mind over this bug: https://bugs.launchpad.net/cloud-init/+bug/1858615
18:09 <ubot5> Ubuntu bug 1858615 in cloud-init "Fail to boot when NoCloud datasource is included" [Undecided,New]
18:09 <Odd_Bloke> The board reboots if you use dmidecode!
18:10 <Odd_Bloke> smoser: As you said, that's a regression.  Do you think it follows that the fix should be in cloud-init?
18:10 <Odd_Bloke> Because I don't know how you deal with something that broken from where we are in the stack. :/
18:10 <Odd_Bloke> (Unless we think this is enough evidence that we can't reliably use dmidecode on aarch64, then I guess it is on us to stop doing that. :( )
18:10 <robjo> This was probably in the e-mail by rharper I have not yet read, but I'll ask anyway ;)
18:11 <robjo> I think I had some pending merge proposals in launchpad and patches, did these "magically" make their way into GitHub? DO I need to sort out where hings were?
18:11 <smoser> i've heard "board reboots if you use dmidecode" before.
18:12 <smoser> and maybe even cloud-init skipped calling dmidecode on aarch64 to avoid that.
18:12 <smoser> but that is sheer non-sense
18:12 <Odd_Bloke> Very glad that boards like this are going to be in the walls of every building in 5 years. ;)
18:12 <smoser> umm..... fix your hardware ?
18:13 <blackboxsw> other dmidecode issues on other hardware here too https://bugs.launchpad.net/qemu/+bug/1243287
18:13 <ubot5> Ubuntu bug 1243287 in QEMU "[KVM/QEMU][ARM][SAUCY] fails to boot cloud-image due to host kvm fail" [Undecided,Fix released]
18:13 <smoser> its more forgivable because dmidecode is priviledged but i swear that all it does is *read* /dev/mem
18:16 <blackboxsw> robjo: for your pending merge proposals we'd like to see you propose against github if possible. Looking for a run of ./tools/migrate-lp-user-to-github robjo <your_GITHUB_USERNAME> to get your github user included as a CLA signer
18:17 <blackboxsw> then we have Conributor License Agreement accountability and can start merging those branches on the github side
18:17 <robjo> Yesh I haven't migrated to the GitHub repo.... even in 2020 the 24 hour/day limitation remains, darn it ;)
18:17 <robjo> I'll get at least my migration to GitHub done this week, possibly even this afternoon
18:18 <blackboxsw> heh, absolutely, and actually I mistyped your migrate cmd:  ./tools/migrate-lp-user-to-github rjschwei <YOUR_GITHUB_USERNAME>
18:39 <blackboxsw> ok think that about wraps the meeting for today. Happy new year folks! Thanks for dropping in!
18:39 <blackboxsw> #endmeeting