15:23 <blackboxsw> #startmeeting Cloud-init bi-weekly status
15:23 <meetingology> Meeting started Tue May 28 15:23:50 2019 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:23 <meetingology> 
15:23 <meetingology> Available commands: action commands idea info link nick
15:23 <blackboxsw> there we go
15:24 <blackboxsw> Hey folks, time for another bi-weekly cloud-init status.  Welcome all!
15:25 <blackboxsw> Generally cloud-init upstream uses this meeting to provide a platform for status updates, raising questions or concerns and feature discussion. All are encouraged to participate as you see fit.
15:25 <blackboxsw> Generally the topics we would like to cover are the following: Previous Actions, Recent Changes, In-progress Development, Office Hours
15:26 <blackboxsw> without further ado let's jump into it.
15:27 <blackboxsw> #topic Previous Actions
15:27 <blackboxsw> From our previous meeting minutes we had a couple of action items that I think are resolved
15:27 <blackboxsw> #link https://cloud-init.github.io/status-2019-05-13.html#status-2019-05-13
15:28 * blackboxsw Odd_Bloke confirm correct status of https://bugs.launchpad.net/cloud-init/+bug/1801364
15:28 <ubot5> Launchpad bug 1801364 in cloud-init "persisting OpenStack metadata fails" [Undecided,Confirmed]
15:28 <blackboxsw> Dan confirmed that this is the proper bug status and still needs a fix
15:28 <blackboxsw> AnhVoMSFT: we had an action related to you "followup on recommended approach for getting kernel/userspace timestamp with or without python-dbus package dependency"
15:29 <blackboxsw> I know rharper had a comment or two in channel about this approach. Hopefully AnhVoMSFT you have everything you need there
15:29 <blackboxsw> if not, you can feel free to ping us for more discussion on that feature
15:30 <blackboxsw> #topic Recent changes
15:31 <blackboxsw> Big news since last bi-weekly status meeting is that we have completed and published 19.1.1 in an SRU into Ubuntu Xenial, Bionic, Cosmic and Disco as of yesterday.
15:31 <blackboxsw> Odd_Bloke: wrote up some content and email around this for more context. Thanks Odd_Bloke
15:32 <blackboxsw> #link https://discourse.ubuntu.com/t/sru-of-cloud-init-19-1-released/11028/2
15:33 <blackboxsw> #link https://lists.launchpad.net/cloud-init/msg00211.html
15:38 <blackboxsw> beyond that we have the following upstream commits landed
15:39 <blackboxsw> d9b1e5de91..HEAD | log2dch
15:39 <blackboxsw> - freebsd: NoCloud data source support [Gonéri Le Bouder] (LP: #1645824)
15:39 <blackboxsw> - Azure: Return static fallback address as if failed to find endpoint
15:39 <blackboxsw> [Jason Zions (MSFT)]
15:39 <ubot5> Launchpad bug 1645824 in cloud-init "NoCloud source doesn't work on FreeBSD" [Medium,Fix committed] https://launchpad.net/bugs/1645824
15:40 <blackboxsw> Thanks again Jason and Gonéri for the commits there. We have a few branches in the wings under review for freebsd and azure that I expect will be landing this week
15:41 <blackboxsw> #topic In-progress Development
15:42 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
15:43 <blackboxsw> Our upcoming work is set and scheduled on this trello board above. As we grab new significant tasks and dev work for cloud-init we will pull those cards into the doing lane
15:44 <blackboxsw> #topic Office hours (next ~30 mins)
15:45 <blackboxsw> This topic is an opportunity for anyone to bring their bugs, features, questions or branches to get some extra eyes or discussion around current development.
15:47 <blackboxsw> It is also a slot of time where upstream developers will be spending some time reviewing active branches to unblock community members and help increase velocity of our review queue.
15:47 <blackboxsw> #link https://code.launchpad.net/cloud-init/+activereviews
15:48 * blackboxsw does as review pass on https://code.launchpad.net/~goneri/cloud-init/+git/cloud-init/+merge/367315. I'm grabbing an active review slot for this now
15:52 <akik> ls
15:52 <akik> sorry
16:03 <blackboxsw> yeah this looks good Goneri https://code.launchpad.net/~goneri/cloud-init/+git/cloud-init/+merge/367315... approved
16:03 <blackboxsw> will merge in ~15
16:13 <blackboxsw> smoser: so sorry on the review delay here for the doc change you took over. https://code.launchpad.net/~smoser/cloud-init/+git/cloud-init/+merge/343546
16:14 <blackboxsw> just approved with a nit if you are around to push that. if not, I'll get that doc branch merged in tomorrow
16:16 <blackboxsw> I think that about wraps this status meeting this week. I think we should take an action to talk about we want  to do with this old branch.
16:16 <blackboxsw> #link https://code.launchpad.net/~amzn-cmiller/cloud-init/+git/cloud-init/+merge/360082
16:16 <blackboxsw> #action blackboxsw discuss with the team about landing the branch https://code.launchpad.net/~amzn-cmiller/cloud-init/+git/cloud-init/+merge/360082
16:16 * meetingology blackboxsw discuss with the team about landing the branch https://code.launchpad.net/~amzn-cmiller/cloud-init/+git/cloud-init/+merge/360082
16:18 <blackboxsw> We'll  hold the next cloud-init status meeting on Monday 3/10
16:19 <blackboxsw> and I'll post the status minutes up to https://cloud-init.github.io momentarily
16:19 <blackboxsw> Thanks again. have a good one guys and gals.
16:19 <blackboxsw> #endmeeting