16:26 <blackboxsw> #startmeeting  Cloud-init bi-weekly status
16:26 <meetingology> Meeting started Mon Jan 28 16:26:28 2019 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:26 <meetingology> 
16:26 <meetingology> Available commands: action commands idea info link nick
16:27 <blackboxsw> hi cloud-init folks, it's that happy time again to chat about cloud-init upstream.
16:27 <blackboxsw> Generally the topics we cover in this status meeting are: Previous Actions, Recent Changes, In-progress Development, and Office hours
16:27 <blackboxsw> #topic Previous Actions
16:30 <blackboxsw> previously we had an action to review  https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/356098. I think rharper and robjo have a couple of back and forths on this branch. looks like we'll be able to land this
16:32 <blackboxsw> and oh noes, we need to followup  and resolve the following MD bug on OpenStack https://bugs.launchpad.net/cloud-init/+bug/1801364
16:32 <ubot5> Ubuntu bug 1801364 in cloud-init "persisting OpenStack metadata fails" [Undecided,Confirmed]
16:32 <blackboxsw> #action carry over blackboxsw close and land Openstack metadata handling bug https://bugs.launchpad.net/cloud-init/+bug/1801364
16:32 * meetingology carry over blackboxsw close and land Openstack metadata handling bug https://bugs.launchpad.net/cloud-init/+bug/1801364
16:32 <robjo> Well that one was just about an additional empty line which I removed in October
16:34 <blackboxsw> ok I'll spend the 2nd half of this meeting going through this again and landing it if no other concerns. #toostale seeing https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/356098
16:35 <blackboxsw> it doesn't look on review that there is anything concerning there.
16:36 <blackboxsw> ok I think that we it for actions last time.
16:36 <blackboxsw> #topic Recent Changes
16:36 <robjo> blackboxsw: There's also https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/357710
16:36 <robjo> which appears to be complaining about he commit message
16:37 <blackboxsw> robjo: oops autolander rejection, will fix the LP commit message now and make approved (for merging)
16:37 <blackboxsw> Server Team CI bot (server-team-bot) wrote on 2019-01-07: 	#
16:37 <blackboxsw> Commit message lints:
16:37 <blackboxsw> - Expected empty line on line 2 of the commit message
16:37 <robjo> Can there not be a template in LP for the commit message?
16:38 <robjo> I can never remember the formatting intricacies and thus depend on one of you guys to set this
16:38 <blackboxsw> robjo: does the 'commit message' on the merge proposal look good to you now https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/357710
16:39 <blackboxsw> at the top
16:39 <robjo> LGTM, thanks
16:39 <blackboxsw> I've clicked approve and it should autoland within ~15 mins
16:39 <blackboxsw> great
16:40 <blackboxsw> so recent commits to upstream cloud-init
16:41 <blackboxsw> - flake8: use ==/!= to compare str, bytes, and int literals
16:41 <blackboxsw> [Paride Legovini]
16:41 <blackboxsw> - opennebula: exclude EPOCHREALTIME as known bash env variable with a
16:41 <blackboxsw> delta [Chad Smith] ([LP: #1813383](https://bugs.launchpad.net/bugs/1813383))
16:41 <blackboxsw> - tox: fix disco httpretty dependencies for py37
16:41 <ubot5> Ubuntu bug 1813383 in cloud-init "opennebula: fail to sbuild, bash environment var failure EPOCHREALTIME" [Undecided,Fix committed]
16:41 <blackboxsw> ha, ircflood boot
16:41 <blackboxsw> not sure how far I got in that list of commits
16:42 <blackboxsw> - lxd: install zfs-linux instead of zfs meta package
16:42 <blackboxsw> 09:41   [Johnson Shi] ([LP: #1799779](https://bugs.launchpad.net/bugs/1799779))
16:42 <blackboxsw> 09:41 - net/sysconfig: do not write a resolv.conf file with only the header.
16:42 <blackboxsw> 09:41   [Robert Schweikert]
16:42 <blackboxsw> 09:41 - net: Make sysconfig renderer compatible with Network Manager.
16:42 <ubot5> Ubuntu bug 1799779 in cloud-init (Ubuntu Disco) "LXD module installs the wrong ZFS package if it's missing" [Medium,Confirmed]
16:42 <blackboxsw> 09:41   [Eduardo Otubo]
16:42 <blackboxsw> - cc_set_passwords: Fix regex when parsing hashed passwords
16:42 <blackboxsw> 09:41   [Marlin Cremers] ([LP: #1811446](https://bugs.launchpad.net/bugs/1811446))
16:42 <ubot5> Ubuntu bug 1811446 in cloud-init (Ubuntu) "chpasswd: is mangling certain password hashes" [Undecided,In progress]
16:42 <blackboxsw> 09:41 - net: Wait for dhclient to daemonize before reading lease file
16:42 <blackboxsw> 09:41   [Jason Zions] ([LP: #1794399](https://bugs.launchpad.net/bugs/1794399))
16:42 <ubot5> Ubuntu bug 1794399 in cloud-init "cloud-init dhcp_discovery() crashes on preprovisioned RHEL 7.6 VM in Azure" [Undecided,Fix committed]
16:42 <blackboxsw> 09:41 - [Azure] Increase retries when talking to Wireserver during metadata walk
16:42 <blackboxsw> 09:41   [Jason Zions]
16:42 <blackboxsw> 09:41 - Add documentation on adding a datasource.
16:42 <blackboxsw> Thanks folks for all the contributions to cloud-init over the last couple of weeks.
16:43 <blackboxsw> Additionally, we just published tip of cloud-init to Ubuntu disco (19.04) development release
16:44 <blackboxsw> and we have queued that release as well (cloud-init 18.5.17)  for SRU (stable release update) into Xenial, Bionic and Cosmic as of Saturday.
16:44 <blackboxsw> the SRU process bug can be watched to see when 18.5.17 publishes to 16.04 18.04 and 18.10.  (xenial, bionic, cosmic)  https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1813346
16:44 <ubot5> Ubuntu bug 1813346 in cloud-init (Ubuntu) "sru cloud-init (18.4.0 update to 18.5-17-gd1a2fe73) Xenial, Bionic, Cosmic" [Undecided,New]
16:46 <blackboxsw> Also we welcome our new QA team member paride to Canonical, he's been working on re-enabling our copr build repos and generally improving the quality of our continuous integration for cloud-init (and other Canonical projects)
16:47 <blackboxsw> #topic In-Progress Development
16:47 <blackboxsw> we tracking our ongoing cloud-init upstream work (and backlog) on our Trello board
16:47 <blackboxsw> #link  https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:49 <blackboxsw> the next couple of weeks will likely result in Ubuntu SRU verificantion for that release into xenial, bionic and cosmic. robjo's been working on a few OpenSUSE/sysconfig network handling branches that will likely land.  and we'll have a couple of EC2 branches that need to address EC2-Classic network re-configuration across reboots
16:50 <blackboxsw> and, as mentioned our upstream copr repo builds will likely be fixed for centos/fedora consumers
16:51 <blackboxsw> #topic Office Hours (next ~30 minutes)
16:52 <blackboxsw> So, upsteram devs will have eyes on this channel for any further discussion, bugs or questions about cloud-init. Please use this venue as you see fit to raise awareness of stale branches, bugs etc so we can queue them up for review.
16:53 * blackboxsw is going to look over  https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/356098 to see if we can close out on that today
17:30 <blackboxsw> https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/357710 merged
17:30 <blackboxsw> and just approved https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/356098
17:30 <blackboxsw> thanks robjo
17:30 <blackboxsw> I think that about wraps it up for today. thanks again for checking in folks.
17:30 <blackboxsw> As always minutes will be posted to cloud-init's  github page @
17:31 <blackboxsw> #link https://cloud-init.github.io
17:31 <blackboxsw> #endmeeting